none
Hyper-v inicia VM mas não abre area de trabalho RRS feed

  • Pergunta

  • quando faço o acesso na rede interna ele redireciona e abre a area de trabalho normalmente mas quando faço o acesso externo ele ativa a vm, quando ele vai iniciar a area de trabalho ele fecha conexão, mensagem de erro ( a area de trabalho remota nao pode se conectar ao computador remoto por uma destas razoes

    1) o acesso remoto ao servidor não esta ativado

    2)o computador remoto esta desligado

    3)o computador remoto nao esta disponivel na rede

    ).

    quarta-feira, 22 de agosto de 2012 13:39

Respostas

  • Agora entendi!

    Pode tentar usar um RDS Gateway, para forçar o tráfego pela porta 443!


    Se foi útil marca como resposta! _________________________________________________ Rafael Bernardes - It Hero 2009 Award Most Influential Virtualization Professional - MiVP http://www.cooperati.com.br

    sexta-feira, 24 de agosto de 2012 07:08

Todas as Respostas

  • você está falando sobre VDI? ou está somente tentando acessar uma vm via RDP?

    Ajudei? Marca como útil, aproveita e visita meu blog :) HowToServer.com Gosta de powershell? entra no grupo do facebook Powershell Brasil

    quarta-feira, 22 de agosto de 2012 13:54
  • estou tentando via rdp, localmente ela funciona perfeitamente mas de fora nao abre a area de trabalho
    quarta-feira, 22 de agosto de 2012 16:29
  • ok, localmente você se refere no console do hyper-v?

    verifique o firewall da vm, tente dar um telnet no ip dela na porta 3389

    coloca o resultado de um ipconfig aqui para nós da maquina de destino e da de origem


    Ajudei? Marca como útil, aproveita e visita meu blog :) HowToServer.com Gosta de powershell? entra no grupo do facebook Powershell Brasil


    quarta-feira, 22 de agosto de 2012 16:48
  • Sim, no console e também em qual quer máquina que estiver na minha rede.

    ipconfig VM 

    Sufixo DNS específico à conexão: 
    Descrição: Adaptador de Rede de Barramento da Máquina Virtual Microsoft
    Endereço Físico: ‎00-15-5D-25-CA-00
    DHCP Ativado: Não
    Endereço IPv4: 10.0.0.31
    Máscara de Sub-rede IPv4: 255.0.0.0
    Gateway Padrão IPv4: 10.0.0.2
    Servidor DNS IPv4: 10.0.0.10
    Servidor WINS IPv4: 
    NetBIOS sobre Tcpip Habilitado: Sim
    Endereço IPv6 link-local: fe80::7dfa:b9c5:45d8:9248%11
    Gateway Padrão IPv6: 
    Servidor DNS IPv6: 

    ipconfig minha maquina 

    Sufixo DNS específico à conexão: 
    Descrição: Realtek PCIe GBE Family Controller
    Endereço Físico: ‎00-24-54-4A-43-12
    DHCP Ativado: Não
    Endereço IPv4: 10.0.0.6
    Máscara de Sub-rede IPv4: 255.0.0.0
    Gateway Padrão IPv4: 10.0.0.2
    Servidores DNS IPv4: 10.0.0.10, 8.8.8.8
    Servidor WINS IPv4: 
    NetBIOS sobre Tcpip Habilitado: Sim
    Endereço IPv6 link-local: fe80::fce1:cf39:300c:a342%12
    Gateway Padrão IPv6: 
    Servidor DNS IPv6: 

    nao fiz o teste do telnet por que ele conecta na host e inicia a vm quando esta desligada, ou seja ele faz a comunicação com a vm externamente mas nao mostra a area de trabalho

    quarta-feira, 22 de agosto de 2012 17:00
  • Amigo desculpe não estou conseguindo entender o seu problema você conecta via RDP no host, liga a vm e abre o console dentro do rdp e ai ele nao exibe a tela da vm? isso?

    Ajudei? Marca como útil, aproveita e visita meu blog :) HowToServer.com Gosta de powershell? entra no grupo do facebook Powershell Brasil

    quarta-feira, 22 de agosto de 2012 19:26
  • Acho que está confundindo as coisas. Pelo meu ver não tem nada de virtualização na sua pergunta.

    Está se referindo ao acesso remoto RDS (ou TS) ao servidor que tem o Hyper-V rodando, correto?


    Se foi útil marca como resposta! _________________________________________________ Rafael Bernardes - It Hero 2009 Award Most Influential Virtualization Professional - MiVP http://www.cooperati.com.br

    quarta-feira, 22 de agosto de 2012 22:24
  • Para entender melhor, no windows 2008 você consegue criar VM's no Hyper-v e designar usuários para acessar elas remotamente. Quando você faz acesso remoto com o login determinado para uma VM o server 2008 automaticamente redireciona para a VM especificada para o usuário ("VIA REMOTE DESKTOP).

    Dentro da minha rede (rede interna) ele acessa normalmente, coloco o usuário no remote e ele encaminha direto para a vm que criei, porém quando acesso de outra filial em uma rede remota, e não interligada (fora do domínio) ele inicia a máquina caso ela esteja ligada (chega ao 2008 server) mas da erro na hora do logon da vm, ao que parece não faz o redirecionamento da VM chega apenas no 2008 server.

    quinta-feira, 23 de agosto de 2012 11:36
  • Agora entendi!

    Pode tentar usar um RDS Gateway, para forçar o tráfego pela porta 443!


    Se foi útil marca como resposta! _________________________________________________ Rafael Bernardes - It Hero 2009 Award Most Influential Virtualization Professional - MiVP http://www.cooperati.com.br

    sexta-feira, 24 de agosto de 2012 07:08