none
Procv só funciona ao teclar F2 RRS feed

  • Pergunta

  • Bom Dia!

    Pessoal,

    Estou com uma planilha onde existe um procv pegando informações de uma pasta de trabalho e exibindo em outra (dentro da mesma planilha) e está "funcionando" porém, preciso dar um F2 (editar a celula na pasta principal) para que a consulta de certo na outra pasta, resumindo, não está automático.

    Alguém já passou por isto?


    VB.NET

    quarta-feira, 1 de agosto de 2012 11:52

Respostas

  • 1 - Digite 1 em alguma célula

    2 - Pressione Ctrl+C

    3 - Selecione todas as 12.000 células

    4 - Vá na janela de colar especial

    5 - Selecione a opção Valores e a opção Multiplicação

    6 - Clique em OK

    Explicação: multiplicando todas essas células por 1, você as converte em valores.

    Uma outra alternativa seria você escrever o PROCV forçando o valor que você está buscando em texto. Ao invés de usar

    =PROCV(A1;C:D;2;0)

    use, por exemplo,

    =PROCV(A1&"";C:D;2;0)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    quarta-feira, 1 de agosto de 2012 22:16

Todas as Respostas

  • Olá Napster, bom dia.

    Eu ainda não passei por este problema mas existe uma configuração que pode ser realizada para o cálculo automático com fórmulas para isso com o Excel 2010 aberto clique em: Arquivo - Opções - Fórmulas.

    Verifique se o cálculo da pasta de trabalho está marcada como Automático.

    E se a opção Habilitar cálculo iterativo está habilitada.

    Espero ter ajudado.


    Hezequias Vasconcelos

    quarta-feira, 1 de agosto de 2012 13:13
    Moderador
  • Olá Hezequias,

    Eu já havia analisado esta possibilidade e esta configuração esta ok, porém, descobri que se eu determinar o valor da célula como ABS também da certo, mas são aproximadamente 12.000 linhas não da para fazer 1 a 1.

    Mas de qualquer forma, muito obrigado e o post continua em aberto, caso tenha alguma outra sujestão.


    VB.NET

    quarta-feira, 1 de agosto de 2012 13:35
  • Olá Napster, 

    Se utilizando as configurações padrões do programa não atendem a meu ver a melhor solução então seria um desenvolvimento que faça e force esse update em sua planilha.

    Neste endereço existe um código VBA que realiza essa operação de update.

    http://stackoverflow.com/questions/154434/how-do-you-get-excel-to-refresh-data-on-sheet-from-within-vba

    Espero ter ajudado.


    Hezequias Vasconcelos

    quarta-feira, 1 de agosto de 2012 14:01
    Moderador
  • 1 - Digite 1 em alguma célula

    2 - Pressione Ctrl+C

    3 - Selecione todas as 12.000 células

    4 - Vá na janela de colar especial

    5 - Selecione a opção Valores e a opção Multiplicação

    6 - Clique em OK

    Explicação: multiplicando todas essas células por 1, você as converte em valores.

    Uma outra alternativa seria você escrever o PROCV forçando o valor que você está buscando em texto. Ao invés de usar

    =PROCV(A1;C:D;2;0)

    use, por exemplo,

    =PROCV(A1&"";C:D;2;0)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    quarta-feira, 1 de agosto de 2012 22:16
  • Boa tarde!

    Excelente! estava com um arquivo gigante 15 mil linhas com este problema! Com a sua explicação foi muito fácil. Muito obrigado! Excel é fantástico!

    quarta-feira, 22 de março de 2017 16:13
  • Demais a solução, me ajudou muito.
    sexta-feira, 5 de maio de 2017 18:49
  • Perfeito!
    segunda-feira, 11 de setembro de 2017 19:07
  • Muito obrigado pela resposta... eu estava me perguntando se teria que entrar item a item para que o cálculo fosse realizado.
    quarta-feira, 18 de julho de 2018 11:35
  • Muito obrigado me ajudou, eu usei a conversão de tudo para texto Ex: =PROCV(A1&"";C:D;2;0).

    Valeu mesmo!

    segunda-feira, 3 de junho de 2019 13:41