none
A conta de administrador do Windows com todos os privilégios acabou? RRS feed

  • Pergunta

  • Pessoal, lá no trabalho nós utilizamos Active Directory, porém o problema veio quando algumas máquinas foram atualizadas para o Windows 8.
    Nós temos uma aplicação Delphi que acessa um caminho de rede mapeado em uma unidade local.
    Essa aplicação também necessita acessar alguns drivers do sistema, o que exige direitos administrativos, e é aí que os problemas começam....

    Mesmo adicionando a conta criada no AD ao grupo de administradores locais da máquina e desabilitando o UAC, ela não inicia e me retorna um erro de permissão.
    Caso eu execute ela como administrador (clicando com o botão direito), ela consegue iniciar normalmente mas não acessa o caminho mapeado (que é mapeado de acordo com usuário devido às permissões definidas).

    O método de adicionar a conta aos administradores locais sempre funcionou nas versões anteriores do Windows, mas é como se o grupo de administradores do Windows 8 tivesse várias restrições.

    Alguém aqui passou por essa situação ou coisa parecida e conseguiu contornar?
    Ou a conta de administrador as quais estamos acostumados morreu?

    terça-feira, 7 de maio de 2013 02:52

Respostas

  • Olá Ricardo, a conta de Administrador que você está se referindo for a que eu estou pensando, ela vem desativada no Windows 8.

    para ativa-la basta seguir os passos:

    Botão direito em cima de Computador > Gerenciar > Usuários e Grupos Locais > Usuários > A conta de Administrador vai estar ai dentro desativada, Ativa a mesma e defina uma senha.

    Ricardo espero que eu tenha te ajudado, um abraço


    Wellinghton Pimentel Se esta sugestão for útil, por favor, classifique-a como útil. Se ela lhe ajudar a resolver o problema, por favor, marque-a como Resposta.

    terça-feira, 28 de maio de 2013 13:08

Todas as Respostas

  • Prezado;

    você ja fez o teste de entra na propriedade do executável na aba compatibilidade e marco a opção de "executar este programa como administrador"  ?
    Ele vai executar o programa com privilegio administrativos, porem com o usuário que esta logado na maquina. 

    quinta-feira, 16 de maio de 2013 03:09
  • Olá Ricardo, a conta de Administrador que você está se referindo for a que eu estou pensando, ela vem desativada no Windows 8.

    para ativa-la basta seguir os passos:

    Botão direito em cima de Computador > Gerenciar > Usuários e Grupos Locais > Usuários > A conta de Administrador vai estar ai dentro desativada, Ativa a mesma e defina uma senha.

    Ricardo espero que eu tenha te ajudado, um abraço


    Wellinghton Pimentel Se esta sugestão for útil, por favor, classifique-a como útil. Se ela lhe ajudar a resolver o problema, por favor, marque-a como Resposta.

    terça-feira, 28 de maio de 2013 13:08
  • Pessoal, lá no trabalho nós utilizamos Active Directory, porém o problema veio quando algumas máquinas foram atualizadas para o Windows 8.
    Nós temos uma aplicação Delphi que acessa um caminho de rede mapeado em uma unidade local.
    Essa aplicação também necessita acessar alguns drivers do sistema, o que exige direitos administrativos, e é aí que os problemas começam....

    Mesmo adicionando a conta criada no AD ao grupo de administradores locais da máquina e desabilitando o UAC, ela não inicia e me retorna um erro de permissão.
    Caso eu execute ela como administrador (clicando com o botão direito), ela consegue iniciar normalmente mas não acessa o caminho mapeado (que é mapeado de acordo com usuário devido às permissões definidas).

    O método de adicionar a conta aos administradores locais sempre funcionou nas versões anteriores do Windows, mas é como se o grupo de administradores do Windows 8 tivesse várias restrições.

    Alguém aqui passou por essa situação ou coisa parecida e conseguiu contornar?
    Ou a conta de administrador as quais estamos acostumados morreu?

    Bom dia,

    Estou com um problema similar na execução de algumas tarefas aqui também e não entendi a resolução desse problema.
    Aqui, temos a uma conta de administrador local (Administrador) e contas de AD. Está adicionado no grupo Administradores (do computador, grupo local) a conta local, os grupos do AD e a minha conta do AD. Porém às vezes recebo que não tenho permissão ou que preciso confirmar a ação, isto é algum bug ou mesmo sendo administrador não possui FULL admin ???


    Que me lembro onde tem dado problema, por exemplo, é quando tento executar algum comando via CMD (o normal, sem ser o admin e diz que "A operação solicitada requer elevação" ou alguns programas que modificam o registro não executam a não ser que eu clique em "Executar como administrador".

    segunda-feira, 28 de julho de 2014 14:34
  • Prezados,

    Tenho o mesmo problema. Procurei por várias soluções e encontrei essa  que  me ajudou, mas....afetou outra coisa.

    " Desabilitar o UAC atrvés das politicas de segurança gpedit.msc

    vá em Configurações do Computador => Configurações do Windows => Configurações de Segurança =>

    Politicas Locais => Opções de Segurança:

    Localize os itens abaixo e efetue a alteração como mencionado.

    - Controle de conta de usuário: comportamento da solicitação de elevação de administradores

    no modo de aprovação de administrador. Altere para Elevar se aviso.

    - Controle de conta de usuário: detectar instalações de aplicativos e perguntar se deseja elevar.

    Altere para Desabilitado.

    - Controle de conta de usuário: Executar todos os administradores no modo de aprovação de administrador. Altere para Desabilitado.

    - Controle de conta de usuário: elevar apenas UIAccess que estejam instalados em locais seguros. Altere para Desabilitado.

    feche o editor e execute o CMD como administrador e digite gpudate /force pressione enter.

    reinicie o computador.

    Créditos: Vinicius B Rodrigues.

    Esta opção resolveu, porem com a UAC desativada, os ícones da tela Iniciar, deixaram de funcionar, pois para isso, a UAC precisa estar ativada.

    Tentei contato telefônico com o suporte da Microsoft, mas a única informação que obtive foi que para suporte telefônico, não basta meu Sistema Operacional ser Original e estar dento do prazo de validade, eu preciso adquirir esta garantia de serviço. Legal né? então, o que me resta é o suporte através do site, onde ate o momento não tem solução alguma para este problema.  

    quinta-feira, 14 de agosto de 2014 12:52
  • Prezados,

    Tenho o mesmo problema. Procurei por várias soluções e encontrei essa  que  me ajudou, mas....afetou outra coisa.

    " Desabilitar o UAC atrvés das politicas de segurança gpedit.msc

    vá em Configurações do Computador => Configurações do Windows => Configurações de Segurança =>

    Politicas Locais => Opções de Segurança:

    Localize os itens abaixo e efetue a alteração como mencionado.

    - Controle de conta de usuário: comportamento da solicitação de elevação de administradores

    no modo de aprovação de administrador. Altere para Elevar se aviso.

    - Controle de conta de usuário: detectar instalações de aplicativos e perguntar se deseja elevar.

    Altere para Desabilitado.

    - Controle de conta de usuário: Executar todos os administradores no modo de aprovação de administrador. Altere para Desabilitado.

    - Controle de conta de usuário: elevar apenas UIAccess que estejam instalados em locais seguros. Altere para Desabilitado.

    feche o editor e execute o CMD como administrador e digite gpudate /force pressione enter.

    reinicie o computador.

    Créditos: Vinicius B Rodrigues.

    Esta opção resolveu, porem com a UAC desativada, os ícones da tela Iniciar, deixaram de funcionar, pois para isso, a UAC precisa estar ativada.

    Tentei contato telefônico com o suporte da Microsoft, mas a única informação que obtive foi que para suporte telefônico, não basta meu Sistema Operacional ser Original e estar dento do prazo de validade, eu preciso adquirir esta garantia de serviço. Legal né? então, o que me resta é o suporte através do site, onde ate o momento não tem solução alguma para este problema.  

    Fiz algo parecido mas foi no regedit. Funcionou do mesmo jeito mas os app metro não funcionam mais (clima, email, etc)

    Desabilitar o UAC pelo próprio Windows:
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System]
    "EnableLUA"=dword:00000000

    • Editado Renan Rufino quinta-feira, 14 de agosto de 2014 13:33
    quinta-feira, 14 de agosto de 2014 13:32