none
Problema conexão remota SQL Server RRS feed

  • Pergunta

  • Olá a todos estou com um problema ao me conectar pelo MSSMS de outro computador....
    Vou listar o que eu ja fiz:
    1-Já habilitei o TCP/IP no SQL Config.Man.

    2- Já dei Allow para conexões remotas na instância.

    3-Ja adicionei ao Windows Firewall a o SQLSERV.exe

    4-Já executei esse fix para porta 1433 -> http://support.microsoft.com/kb/968872

    E nada de acesso... engraçado que habilitei nesse mesmo computador que vai servir de SQL Server o Acesso Remoto que é feito através da porta 3389 e o mesmo funciona quando tento acessar de outra máquina.. Fui em um site de OpenPOrt Check quando coloco porta 3389,80 elas estão abertas mas quando coloco a porta 1433 diz que a conexão foi negada.(<small>Connection refused)</small>

    Se alguém souber uma solução para esse meu problema...

    Ps. da máquina do SQL Server o "telnet ipexterno 1433" funciona mas de outra máquina para essa máquina o telnet funciona somente nas porta 80,3389...
    quarta-feira, 18 de maio de 2011 14:47

Respostas

  • Gostaria de Agradecer a sua ajuda Marco, consegui resolver meu problema...
    Botei o modem em router entrei nele via telnet desabilitei o firewall reiniciei o modem mudei para porta 666 e está funcionando agora...

     

    • Marcado como Resposta Andrius I quarta-feira, 18 de maio de 2011 23:02
    quarta-feira, 18 de maio de 2011 23:02

Todas as Respostas

  • Andrius I,

    Como outra sugestão vc pode fazer os seguintes passos para conexão:

    - Vá em iniciar / executar e digite: cliconfg

    - Na tela mostrada verifique se a flag "Habilitar protocolo de memória compartilhada" está marcada.

    - Passe os protocolos TCP/IP e Pipes Nomeados para a direita.

    - Na aba ALIAS, clique em adicionar e no campos ALIAS DO SERVIDOR, informe: [servidor\instancia]

    - Confirme as alterações e tente acessar.
     

    Tem uma outra analise a ser feita também. Vá na ferramenta SQL Server Configuration Manager.

    Abra o item de Network Configuration e selecione a sua instância. Do lado direito terão todos os protocolos. Habilite : Shared Memory, TCP/IP e Named Pipes. Em seguida reinicie o SQL.

    Veja se resolve.

    Se vc estiver fazendo uma conexão à uma instância nomeada, tipo: SERVIDOR\SQL, verifique se o serviço SQL Browser está ativo.


    Esta instância está com configuração para trabalhar com conexões remotas?

    As portas 1433 e 1434 estão liberadas no firewall?

    Att.,


    Marco Antônio Pinheiro / MCTS - Database Developer 2008 http://marcoantoniopinheiro.blogspot.com Se o post foi útil, não esqueça de marcá-lo.
    quarta-feira, 18 de maio de 2011 15:26
  • Fui no cliconfg fiz o que tu me disse
    Ficando assim:
    http://imageshack.us/f/585/cliconf.jpg/

    Outra análise

    Fui no SSCM habilitei Shared Memory,TCP/IP e Named Pipes reiniciei Sql;

    Ficou assim: http://imageshack.us/f/151/sscm.jpg/

     

    SQL Browser está ativo

    A instância está setada para "Allow Remote connections to this Server"

    E como disse as portas estão(deveriam) liberadas no Firewall
    Utilizei esse .Bat

    @echo ========= SQL Server Ports ===================
    @echo Enabling SQLServer default instance port 1433
    netsh firewall set portopening TCP 1433 "SQLServer" 
    @echo Enabling Dedicated Admin Connection port 1434
    netsh firewall set portopening TCP 1434 "SQL Admin Connection" 
    @echo Enabling conventional SQL Server Service Broker port 4022 
    netsh firewall set portopening TCP 4022 "SQL Service Broker" 
    @echo Enabling Transact-SQL Debugger/RPC port 135 
    netsh firewall set portopening TCP 135 "SQL Debugger/RPC" 
    @echo ========= Analysis Services Ports ==============
    @echo Enabling SSAS Default Instance port 2383
    netsh firewall set portopening TCP 2383 "Analysis Services" 
    @echo Enabling SQL Server Browser Service port 2382
    netsh firewall set portopening TCP 2382 "SQL Browser" 
    @echo ========= Misc Applications ==============
    @echo Enabling HTTP port 80 
    netsh firewall set portopening TCP 80 "HTTP" 
    @echo Enabling SSL port 443
    netsh firewall set portopening TCP 443 "SSL" 
    @echo Enabling port for SQL Server Browser Service's 'Browse' Button
    netsh firewall set portopening UDP 1434 "SQL Browser" 
    @echo Allowing multicast broadcast response on UDP (Browser Service Enumerations OK)
    netsh firewall set multicastbroadcastresponse ENABLE 

     

    Mas até agora não consigo acessar do outro PC.
    O engraçado que da máquina onde está o SQL Server rodando o Telnet e o Managment Studio Acessam a porta 1433 ou dizem que ela está aberta.... mas quando eu vou acessar de fora de outro computador o máximo que consegui foi acessar remotamente através da porta 3389.

    Se alguém soube algo para eu tentar fico grato...


    quarta-feira, 18 de maio de 2011 15:55
  • Faltou uma coisa. No servidor conecte-se ao SSMS e depois vá nas propriedades da instância (No Object Browser). Na guia Security, o modo de autenticação está como? Windows Authentication ou Windows Authentication e SQL Server Authentication?

    Caso não esteja, marque a segunda opção e reinicie a instancia.

    Outra dúvida, qual a versão do SQL?


    Marco Antônio Pinheiro / MCTS - Database Developer 2008 http://marcoantoniopinheiro.blogspot.com Se o post foi útil, não esqueça de marcá-lo.
    quarta-feira, 18 de maio de 2011 17:43
  • Já está como SQL Server Authentication...

    A versão é essa  : "Microsoft SQL Server Enterprise Evaluation Edition (64-bit)"


    Engraçado que acabei de ativar o IIS boto meu IP Externo e ele ja aparece com a página normal... Porta 80 totalmente desbloqueada e a maldita porta 1433 nem sinal...

    quarta-feira, 18 de maio de 2011 17:52
  • Vamos lá...No servidor as portas estão liberadas, protocolos ativados, authentication normal, firewall desbloqueado, browser e alias corretos, e mesmo assim não consegue o acesso.

    Sugiro duas verificações:

    1) Portas. Será que a porta do seu SQL está como 1433 mesmo? Veja em

    2) As contas permitem acessos externos? Está como conexão local ou network service? vá nas propriedades e avalie isso.

     

    Seguem uns links de problemas parecidos.

    http://social.technet.microsoft.com/Forums/pt-BR/admingeralpt/thread/a0b7368c-f680-4e63-aa65-84038a52578c

    http://social.technet.microsoft.com/Forums/pt-BR/sqlserver2005pt/thread/39d66f98-8c7b-4101-9883-a20df956b3f1

    http://social.technet.microsoft.com/Forums/pt-BR/admingeralpt/thread/3a922a6a-11dc-4ac6-af5f-0b86684feabf

     


    Marco Antônio Pinheiro / MCTS - Database Developer 2008 http://marcoantoniopinheiro.blogspot.com Se o post foi útil, não esqueça de marcá-lo.
    quarta-feira, 18 de maio de 2011 18:20
  • Caro Amigo Marco Antônio,
    1) Como eu instalei a instância padrão do MSQLSERVER o padrão é ele setar para 1433. Mesmo assim eu fui no SSCM >Server Network Configuration> TCP/IP > Propriedades ta Enable então fui em IP Addresses la tem IP1 até IP7 depois IPAll do IP1 até o IP7 estão todos como

    Active:YES Enable:NO IP Address: IP Local,IP Localhost, IP Externo, TCP Dynamic Ports está em branco, TCP Port 1433. Em IPAll está TCP Dynamic em branco e TCP Port 1433. Acredito que esteja correto.

    2) Não entendi muito bem essa parte acredito que seja no SSCM> SQL SERVER Services lá tem:
    ---SQL Server(MSSQLSERVER) State:Running Start Mode: Automatic Log On As: NT Authority\Network Service < Não sei se esse seria o correto

    ---SQL Server Browser State:Running Start Mode: Automatic Log On As:NT Authority\LocalService < Não sei se esse seria o correto

    ---SQL Server Agent(MSSQLSERVER) State:Running Start Mode: Automatic Log On As:NT Authority\Network Service < Não sei se esse seria o correto

    Olhei esses links que você me recomendou, testei mas nenhum solucionou meu problema...

    Volto a frisar que é bem estranho que de posse do IP EXTERNO na máquina onde o Servidor SQL Server roda eu consigo acessá-lo tanto via

    telnet ipdoservidor 1433 como com o SQL Server Managment Studio. Mas quando eu tento acessar de um outro computador fora da rede local usando o telnet e o SSMS ele me retorna o erro não pode se conectar ao servidor.

    Espero que alguém me de uma luz porque está díficil...
    Obrigado pela ajudo Marco Antônio.

    quarta-feira, 18 de maio de 2011 19:02
  • Gostaria de Agradecer a sua ajuda Marco, consegui resolver meu problema...
    Botei o modem em router entrei nele via telnet desabilitei o firewall reiniciei o modem mudei para porta 666 e está funcionando agora...

     

    • Marcado como Resposta Andrius I quarta-feira, 18 de maio de 2011 23:02
    quarta-feira, 18 de maio de 2011 23:02