none
Abrir automaticamente aplicação via terminal service pelo WinXP RRS feed

  • Pergunta

  • Olá pessoal, estou tentando acessar uma apllicação publicada via RDP igual ao que fazemos no win2003 porém pelo XP ele não me deixa lançar o aplicativo. Alguém sabe me dizer se isso é possível, se sim o que eu preciso habilitar para esse recurso funcionar. hoje eu já acesso o servidor via RDP, mas quando quero usar a opção de lançar um aplicativo direto não esta rolando...

    Wesley Porto Rodrigues .:. Network & Infraestructure Specialist .:. ITIL and Green IT Implementation


    • Editado Wesley Sampa quarta-feira, 26 de junho de 2013 01:44
    terça-feira, 25 de junho de 2013 18:12

Respostas

  • Olá pessoal, eu consegui chegar a um resultado fazendo o seguinte:

    Objetivo: Customizar o Desktop para um usuário onde ele possa ver apenas os atalhos disponíveis a ele.

    1º - Remover o menu Todos os Programas de um usuário em específico, abra o Bloco de Notas e cole as linhas aseguir no mesmo:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesExplorer]
    "NoStartMenuMorePrograms"=dword:00000001


    Clique em Arquivo » Salvar como... e dê o nome de RemoverTodosProgramas.reg, salve o arquivo em um local de sua preferência e após isso efetue o logon com a conta que deseja aplicar a restrição, aplique este arquivo criado e REINICIE o Windows XP, caso outras contas necessitem desta restrição, faça o mesmo procedimento, efetue o logon com a conta aplique o fix e reinicie o Windows XP.

    Obs: a subchave é acessada totalmente apenas por usuários Administradores mesmo estando dentro da subchave do usuário proprietário e logado no momento, para resolver o problema, efetue o logon como Administrador da Windows XP e modifique o grupo dos usuários que devem receber a restrição para o grupo Administradores temporáriamente, faça Logoff e efetue o logon com o usuário, aplique o fix .reg, REINICIE e efetue o logon novamente com o usuário, tente acessar o menu Iniciar » Todos os programas, caso esteja tudo OK, efetue o logoff e logon novamente com a conta padrão Administrador e tente acessar o menu Iniciar » Todos os programas e ira constatar que o mesmo ainda possui este acesso e o outro usuário não mais, modifique o grupo do usuário novamente para Usuário apenas e efetue o logon com o mesmo já com a restrição ativa. Repita este procedimento anterior para cada usuário até o momento em que todos estiverem da maneira que deseja.

    Fonte: Forum Baboo

    - Instale o programa WinPolicy e aplique todas as regras de restrição que deseja para seu ambiente, no meu caso apliquei TUDO somente para um usuário. Usei o programa para ocultar as demais opções da maquina, como aqui não temos acesso total as políticas tive que fazer dessa forma.

    Pronto! essa foi a solução que achei.


    Wesley Porto Rodrigues .:. Network & Infraestructure Specialist .:. ITIL and Green IT Implementation

    • Marcado como Resposta Wesley Sampa segunda-feira, 1 de julho de 2013 11:24
    segunda-feira, 1 de julho de 2013 11:24

Todas as Respostas

  • Bom dia Wesley, tudo bem?

    Abaixo segue um link que vai te ajudar a configurar de acordo com a sua necessidade.
    No Windows XP tem como você definir o programa que será executado no logon.

    RDP Windows XP iniciar aplicativos no Logon.

    Forte Abraço.


    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com

    quarta-feira, 26 de junho de 2013 11:48
  • Olá Junior, é exatamente isso que fiz ontem mas não esta funcionando, ele não traz a a aplicação como no win2003, não tem msg de erro, ele apenas carrega o desktop ao invés da aplicação, estou fazendo um teste chamando o notepad dele.

    Wesley Porto Rodrigues .:. Network & Infraestructure Specialist .:. ITIL and Green IT Implementation

    quarta-feira, 26 de junho de 2013 12:40
  • Wesley,

    Revise todos os passos que te forneci acima.
    E também revise os caminhos que voce esta colocando na aba " Programas "
    Pois algo de errado esta relacionado neste caminho.
    Veja no Eventvwr se tem algum log relacionado ao RDP.

    Em ultimos casos, crie um arquivo .bat onde chama a aplicação que voce tem.
    No caso na aba programas aponte para esse arquivo .bat

    E volte a postar.


    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com


    • Editado Júnior Ramos quarta-feira, 26 de junho de 2013 13:37 .bat
    quarta-feira, 26 de junho de 2013 13:35
  • Junior, eu revisei todo o documento e mesmo assim não consigo abrir o arquivo, criei uma bat chamando apenas o notepad, coloquei no C: da maquina, e na aba "iniciar um programa" eu marquei o checkbox, e no caminho e nome de arquivo do programa eu coloquei assim: C:\Notepad.bat e em iniciar na seguinte pasta eu deixei assim: C:\

     E mesmo assim ele não me abre apenas o notepad, o que acontece é que ao invés dele abrir o notepad ele abre o dektop por completo e eu não quero isso, quero apenas que ele abra o notepad, da mesma forma que eu faço hoje no win2003.


    Wesley Porto Rodrigues .:. Network & Infraestructure Specialist .:. ITIL and Green IT Implementation

    quarta-feira, 26 de junho de 2013 14:07
  • Esse teu Windows XP, esta totalmente atualizado?

    Revise as atualizações do mesmo, veja se não tem ainda alguma pendente deixe ele com as ultimas atualizações baixadas e instaladas.
    É para funcionar normal o acesso remoto via programa que você definir.

    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com

    quarta-feira, 26 de junho de 2013 14:37
  • Pois é, não ta funcionando, eu consigo acessar a maquina via RDP normalmente, mas quando quero lançar apenas uma aplicação ele não esta rolando.

    Meu objetivo é liberar acesso a duas aplicações a um usuário, mas não quero que ele veja mais nada além disso, tipo, quando o usuário logar ele deixar habilitado apenas o desktop com os dois atalhos para ele executar, os demais acessos devem ficar bloqueados para ele, tipo, Windows Explorer e tals, eu estou testando um programa chamado WinPolicy, mas ele ainda me deixa acessar a pasta Windows Explorer e outras coisas mesmo bloqueando todas as opções do programa.

    Outra coisa ruim, eu não tenho acesso completo ao gpedit dessa maquina por questões de segurança, o que me restaria apenas restringir via registro, mas não sei como fazer...

    Alguma ideia?


    Wesley Porto Rodrigues .:. Network & Infraestructure Specialist .:. ITIL and Green IT Implementation

    quarta-feira, 26 de junho de 2013 14:52
  • O Winpolicy é muito bom.

    Em ambientes de rede pequeno eu adiciono ele em alguns casos.
    Com ele voce pode bloquear várias ferramentas.
    Me adicione no MSN, conversamos la.. se acharmos uma solução depois postamos aqui o resultado a todos.

    abs.


    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com

    quarta-feira, 26 de junho de 2013 15:34
  • Olá pessoal, eu consegui chegar a um resultado fazendo o seguinte:

    Objetivo: Customizar o Desktop para um usuário onde ele possa ver apenas os atalhos disponíveis a ele.

    1º - Remover o menu Todos os Programas de um usuário em específico, abra o Bloco de Notas e cole as linhas aseguir no mesmo:

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USERSoftwareMicrosoftWindowsCurrentVersionPoliciesExplorer]
    "NoStartMenuMorePrograms"=dword:00000001


    Clique em Arquivo » Salvar como... e dê o nome de RemoverTodosProgramas.reg, salve o arquivo em um local de sua preferência e após isso efetue o logon com a conta que deseja aplicar a restrição, aplique este arquivo criado e REINICIE o Windows XP, caso outras contas necessitem desta restrição, faça o mesmo procedimento, efetue o logon com a conta aplique o fix e reinicie o Windows XP.

    Obs: a subchave é acessada totalmente apenas por usuários Administradores mesmo estando dentro da subchave do usuário proprietário e logado no momento, para resolver o problema, efetue o logon como Administrador da Windows XP e modifique o grupo dos usuários que devem receber a restrição para o grupo Administradores temporáriamente, faça Logoff e efetue o logon com o usuário, aplique o fix .reg, REINICIE e efetue o logon novamente com o usuário, tente acessar o menu Iniciar » Todos os programas, caso esteja tudo OK, efetue o logoff e logon novamente com a conta padrão Administrador e tente acessar o menu Iniciar » Todos os programas e ira constatar que o mesmo ainda possui este acesso e o outro usuário não mais, modifique o grupo do usuário novamente para Usuário apenas e efetue o logon com o mesmo já com a restrição ativa. Repita este procedimento anterior para cada usuário até o momento em que todos estiverem da maneira que deseja.

    Fonte: Forum Baboo

    - Instale o programa WinPolicy e aplique todas as regras de restrição que deseja para seu ambiente, no meu caso apliquei TUDO somente para um usuário. Usei o programa para ocultar as demais opções da maquina, como aqui não temos acesso total as políticas tive que fazer dessa forma.

    Pronto! essa foi a solução que achei.


    Wesley Porto Rodrigues .:. Network & Infraestructure Specialist .:. ITIL and Green IT Implementation

    • Marcado como Resposta Wesley Sampa segunda-feira, 1 de julho de 2013 11:24
    segunda-feira, 1 de julho de 2013 11:24