none
Instalação de Software por GPO RRS feed

  • Pergunta

  • Ola pessoal

    Eu tenho na minha Rede dois servidores 2012R2 DataCenter como controladores de dominio, e estações Windows 8.1 e Windows 7 x86, os computadores Windows 8 e Windows 7 estao em OUs diferentes.

    Sendo assim iniciei a instalação de software por GPO ( no caso o JAVA), nas estacoes Windows 7, detectou no primeiro logon e instalou o Java normalmente, nas estações Windows 8.1, a instalação falhou no primeiro logon e foi com sucesso no segundo logon.

    Pesquisando sobre o problema verifiquei que poderia ser a configuração " Esperar pela Rede ao iniciar o computador e fazer logon" porem esta configuração esta habilitada em ambas as GPOs tanto para as estacoes Windows 8.1 quanto para o Windows 7.

    As estações Windows 8.1 sao x64, e Windows 7 x86.

    Bom existe algum motivo para que as estações Windows 8, so consiga efetuar a instalação do software no segundo logon?

    Meu problema com isso é que toda as estacoes de gerentes, diretores, chefes, sao Windows 8.1 e isso esta me causando problemas, tanto agora como futuramente, pois existirão mais atualizacoes do JAVA, e nossa aplicação na nuvem usa o java.

    Desculpem pelo longo post, mas preciso de ajuda com isso.

    Obrigado

    terça-feira, 17 de março de 2015 20:45

Respostas

Todas as Respostas

  • Tiago, boa noite!

    Já validou se no primeiro logon, quando roda o "gpresult -r" se essa GPO está sendo aplicada?

    Algum erro no event viewer?


    Diogo Molina MCP, MCSA, MCSE, MCTS, MCITP, MCT. Ajude manter o forum organizado, se util classifique! Http://diogomolinadesa.org

    quarta-feira, 18 de março de 2015 01:57
  • Ola Diogo

    Os Erros que aparecem sao esses:

    • The assignment of application XStandard from policy install failed. The error was : %%1274
    • The removal of the assignment of application XStandard from policy install failed. The error was : %%2
    • Failed to apply changes to software installation settings. The installation of software deployed through Group Policy for this user has been delayed until the next logon because the changes must be applied before the user logon. The error was : %%1274
    • The Group Policy Client Side Extension Software Installation was unable to apply one or more settings because the changes must be processed before system startup or user logon. The system will wait for Group Policy processing to finish completely before the next startup or logon for this user, and this may result in slow startup and boot performance.

    Porem apos o segundo logon, o software é aplicado corretamente.

    quarta-feira, 18 de março de 2015 20:50
  • Todas as estações de trabalho estão no mesmo site?

    Diogo Molina MCP, MCSA, MCSE, MCTS, MCITP, MCT. Ajude manter o forum organizado, se util classifique! Http://diogomolinadesa.org

    quinta-feira, 19 de março de 2015 10:48
  • Sim, tenho um dominio unico, estao em um mesmo site.
    quinta-feira, 19 de março de 2015 13:56
  • Não sei se é possível, mas seria interessante criar um OU de teste e colocar só uma máquina nessa OU, aplicar a GPO para essa OU a verificar como será o comportamento.

    Diogo Molina MCP, MCSA, MCSE, MCTS, MCITP, MCT. Ajude manter o forum organizado, se util classifique! Http://diogomolinadesa.org

    quinta-feira, 19 de março de 2015 14:08
  • Cara com base no erro, a instalação vai ter que ser executada após o logon.

    Encontre isso aqui, vê te ajuda:

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/4cee3e68-a4ed-4e02-8794-3b1b76c3f662/time-delayed-software-deployment-using-gpo


    Ícaro Melo Administrador de Redes Microsoft


    quinta-feira, 19 de março de 2015 17:12