none
Fixar um valor de uma tabela numa fórmula. RRS feed

  • Pergunta

  • Nessa fórmula: =SOMARPRODUTO(PATRIMÔNIO.xlsx!Tabela911[TOTAL LÍQUIDO];--(PATRIMÔNIO.xlsx!Tabela911[FII]=$C2);--(ANO(PATRIMÔNIO.xlsx!Tabela911[DATA PAGAMENTO])=ANO(M$1));--(MÊS(PATRIMÔNIO.xlsx!Tabela911[DATA PAGAMENTO])=MÊS(M$1))) como eu fixo a coluna [TOTAL LÍQUIDO], para que eu possa arrastar essa fórmula para as outras células adjacentes? 
    segunda-feira, 6 de abril de 2015 22:18

Todas as Respostas

  • Post cruzado com o Microsoft Community:

    http://answers.microsoft.com/pt-br/office/forum/office_2010-excel/fixar-uma-coluna-numa-f%C3%B3rmula/0ac67573-83d5-42e8-af57-a21fa9b45c5d

    Olá Leoramos10!

    Você tem duas alternativas para tornar este intervalo absoluto:

    1º) Utilizar a função INDIRETO:  =INDIRETO("TABELA10[TOTAL]")

    2º) Utilizar a estrutura: =TABELA10[[TOTAL]:[TOTAL]]

    Abraços!


    Rafael Kamimura

    terça-feira, 7 de abril de 2015 11:34
  • Bom dia Leo.

    Confesso que ainda não havia tido problema com isso, mas investigando descobri algo interessante: se vc utilizar a alça inferior direita para arrastar as fórmulas o Excel considera como referência relativa, ou seja, são alterados os nomes dos campos das fórmulas. Entretanto, se vc usar Ctrl+C ou preencher (Ctrl+R, por exemplo), o Excel considera como referência absoluta, ou seja, todos os nomes são preservados.

    Teste aí e veja se funciona.

    Abraço.


    Filipe Magno

    terça-feira, 7 de abril de 2015 12:17
  • Olá.

    utilizando o $ não te ajuda?

    quarta-feira, 15 de abril de 2015 13:37
  • Olá.

    utilizando o $ não te ajuda?

    Olá Lacerda!

    O $ não se aplica nos caso de argumentos de fórmulas referenciadas num endereço de tabela. O $ só pode ser aplicado para definir endereços absolutos em referências do tipo coluna e linha (ex: $A$1).


    Rafael Kamimura

    quarta-feira, 15 de abril de 2015 13:50