none
Problemas com "procv" e campos em ordem decrescente no Excel 2007 RRS feed

  • Pergunta

  • Bom dia pessoal!

     

    Não sei se é um problema do Excel, se é um erro de função ou estou se fazendo errado mesmo ;p

    É o seguinte: estava fazendo um procv em uma tabela, sendo que a tabela que possui os campos da tabela matriz em ordem aleatória (nem crescente, nem decrescente).

    Ok, fiz a proc e percebi que alguns dados estavam errados, então resolvi ordenar em ordem crescente e tudo funcionou. Ao colocar em ordem decrescente a tabela ficou toda bagunçada.

    Então fiz um exemplo bem simplista como demonstração:

     

    - Na Plan1, na primeira coluna tenho a "id" dos usuarios e em seguida proc que chama os nomes da coluna 2 da Plan2

    - Na Plan2 tenho na primeira coluna a "id" dos usuarios e em seguida seus nomes. Tudo em ordem crescente da primeira coluna:

    - Agora ao inverter as "ids" por ordem decrescente na Plan2, começa o problema:

    - Neste caso vemos a bagunça criada em nosso procv:

     

    Alguém já passou por esse problema? É um erro do Excel?

    Desde já agradeço a atenção de todos!

     

    Abraços,


    Tarcísio Gambin | MCP, MCBMSS
    "O conhecimento é livre. Compartilhe você também!"
    quinta-feira, 2 de dezembro de 2010 11:50

Respostas

  • Experimente em Plan1, célula B1 a fórmula:

    =PROCV(A1;Plan2!$A$1:$B$8;2;0) ou =PROCV(A1;Plan2!$A$1:$B$8;2;FALSO)

    Copie e arraste a fórmula. Observe que há um parâmetro a mais na fórmula, que o Excel considera como VERDADEIRO se for omitido.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    quinta-feira, 2 de dezembro de 2010 12:27

Todas as Respostas

  • Experimente em Plan1, célula B1 a fórmula:

    =PROCV(A1;Plan2!$A$1:$B$8;2;0) ou =PROCV(A1;Plan2!$A$1:$B$8;2;FALSO)

    Copie e arraste a fórmula. Observe que há um parâmetro a mais na fórmula, que o Excel considera como VERDADEIRO se for omitido.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br
    quinta-feira, 2 de dezembro de 2010 12:27
  • Perfeito! Realmente estava omitindo o último parametro, causando este problema que voce descreveu.

    Muito obrigado!

     

    Abraços,


    Tarcísio Gambin | MCP, MCBMSS
    "O conhecimento é livre. Compartilhe você também!"
    quinta-feira, 2 de dezembro de 2010 13:22
  • Olá Boa Tarde pessoal

     Estou utilizando o procv e meu resultado vai ser aproximado( Procurar_Intervalo = "Verdadeiro" ), porém ele pode ser um valor aproximado na ordem crescente ou decrescente, mas o excel só me dá a opção de ser classificado em ordem Crescente, sendo assim quando o numero aproximado estiver em ordem decrescente ele estará errado.

    Esse problema tem solução somente com procv ou terei que usar outras formulas para o problema?

    Atenciosamente,

    Leandro

    terça-feira, 30 de dezembro de 2014 15:23
  • Olá Leandro,

    No seu caso, ao invés de utilizar PROCV, utilize um CORRESP aninhado num ÍNDICE:

    =ÍNDICE($B$1:$B$10;CORRESP(C2;$A$1:$A$10;-1))


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    quarta-feira, 31 de dezembro de 2014 15:33