none
Chat (Cliente Externo x Cliente Interno) RRS feed

  • Pergunta

  • Senhores,

    Boa noite, 

    Depois de algumas horas consegui publicar o lync para acesso externo, mas deparei com um problema. 

    Quando eu (cliente interno) envio uma msg ou tenta fazer um share da tela o cliente externo não recebe a mensagem e aparece este erro. (Ao contatar a equipe de suporte, mencione a ID de erro 504 (ID de origem 239).  no cliente.

    Sou novo no fórum e no lync.

    Obrigado!!!



    terça-feira, 14 de maio de 2013 22:54

Respostas

  • O Edge tem 2 placas de rede?

    Pode testar telnet wc.sipdomain 443.
    Próximo passo seria verificar que todos as permissões a nível de firewall foram configuradas.

    Port Summary - Single Consolidated Edge with Private IP Addresses Using NAT
    http://technet.microsoft.com/en-us/library/gg425891.aspx

    David


    quarta-feira, 15 de maio de 2013 01:03

Todas as Respostas

  • Boa noite,

    Como foi feita a publicação? Cliente externo é mobile?

    O cliente externo consegue ver a Presença do cliente interno?


    David

    quarta-feira, 15 de maio de 2013 00:01
  • Olá david,

    Quando digo cliente externo quis dizer cliente fora do domínio.(faltou experiência na explanação!!!rs)

    A publicação foi feita normalmente pelo topology builder. O cliente consegue ver normalmente a presença.

    Um problema detectado foi a falta do registro SRV no dns externo, já criei mas ainda não testei.

    Abs 

    quarta-feira, 15 de maio de 2013 00:10
  • Ok, fora do domínio refere a federação certo?

    O SRV que falta é o _sipfederationtls._tcp.<domain>?


    David

    quarta-feira, 15 de maio de 2013 00:16
  • David,

    Não criei o o da federação é obrigatório ? (Não farei federação)

    Criei apenas este _sip._tls.<domain>.

    Vou tentar fazer o teste remoto agora mesmo.

    quarta-feira, 15 de maio de 2013 00:22
  • Alessandro,


    O _sip._tls.<domain> apenas é necessário se for utilizar clientes Lync 2010 para ligar ao Lync Server 2013.

    Quais os endereços do Edge, Webservice externo ? Não publique o dominio indique só, por exemplo, lyncdiscover.<domain>.


    David

    quarta-feira, 15 de maio de 2013 00:26
  • David,

    Já valeu o aprendizado…..

    lync.<domain> (seria o acesso externo)

    sip.<domain>

    av.<domain> 

    wc.<domain> (conf)

    além do lyncdiscover.


    quarta-feira, 15 de maio de 2013 00:33
  • Tem assim ?

    sip.<domain> IP Publico 1
    av.<domain> IP Publico 2
    wc.<domain> IP Publico 3

    lyncdiscover.<domain> e lync.<domain> para o IP Publico do Reverse Proxy

    Como estão os certificados? Ou seja, o certificado do Edge tem os nomes todos (sip, wc) ? é Publico ou de uma CA interna?
    E o certificado do Reverse Proxy?

    David


    quarta-feira, 15 de maio de 2013 00:38
  • David,

    Antes de mais nada, obrigado pela paciência.

    Está exatamente desta forma. Cada serviço apontando para um IP público nas suas respectivas portas. (como está atrás de firewall, criei as nats apontando para o Edge e para o Proxy reverso, marque no topology builder que o av era feito por NAT)

    O edge tem certificado válido (emitido pela digcert) para internet, para a rede local emiti através do CA interna. O edge tem placa na VLAN de internet com ips internos ex 172.16.0.x y z. Os serviços wc, av etc estão configurados na rede da VLAN 172.16.0.x e no campo nat está com o IP válido do serviço av.

    Para o reverse proxy, eu exportei o certificado válido e importei dentro do TMG.

     Em resumo é assim que está.

    Um teste simples seria acessar http://wc.<domain>.com.br e ver se abre a página do webconferencia ?

    Abs e obrigado mais uma vez!!!!!

    quarta-feira, 15 de maio de 2013 00:48
  • O Edge tem 2 placas de rede?

    Pode testar telnet wc.sipdomain 443.
    Próximo passo seria verificar que todos as permissões a nível de firewall foram configuradas.

    Port Summary - Single Consolidated Edge with Private IP Addresses Using NAT
    http://technet.microsoft.com/en-us/library/gg425891.aspx

    David


    quarta-feira, 15 de maio de 2013 01:03
  • David,

    O edge, tem duas placas de rede Rede interna 192.168.10.x e DMZ 172.16.0.x

    Vou rever as configurações do firewall logo pela manhã e te posto o resultado.


    quarta-feira, 15 de maio de 2013 01:09
  • David,

    Instalei o logging tool para analisar e achei este erro a seguir. 

    O ip seria do meu cliente externo.

    Percebi que o cliente externo não recebe a informação de presença, porém eu (internamente) recebo a dele normalmente.

    Seria este erro um problema de rota ou de regras de firewall ?

    Percebi que conecto internamente apenas pela porta 444 (esta porta está marcada no topology builder como porta para o serviço)

    Abs 


    quarta-feira, 15 de maio de 2013 12:24
  • Boa noite,

    Porta 444?
    No Edge tem de ter rotas para a rede interna (servidores e/ou clientes) a gateway fica definida apenas na interface externa do Edge. Parece um problema de rede (firewall/rotas) mas tem de investigar um pouco.

    David
    quarta-feira, 15 de maio de 2013 22:53