none
SERVER 2003 NÃO FECHA PROCESSOS DE USUÁRIO NO TS RRS feed

  • Pergunta

  • Bom Dia Pessoal..

    É o seguinte.. de uns tempos para cá, notei que meu server está prendendo (não finalizando) os  processos de alguns usuários. Pensei que era o programa "Cobrança" do banco sicredi, que um usuario utiliza, mas agora, até o outlook 2007 da "diretoria' também não está finalizando o processo, quando o usuario fecha a Sessão, ou simplesmente fecha o programa.

    Meu cenário é o seguinte:

    SERVER 2003 ENTERPRISE SP2> Rodando em uma MAQUINA VIRTUAL (VMWARE ) COM 2GB RAM, NO DOMINIO. ESSA MAQUINA É APENAS SERVIDOR DE ARQUIVOS, SERVIDOR DE TS. (É NESSA MAQUINA QUE FICA TRAVANDO OS PROCESSOS. Um detalhe interessante é o seguinte.. As vezes, nem mesmo o usuário ADMINISTRADOR consegue fechar o processo aberto, e mesmo fechando o usuario o processo não fecha. Tenho nela um antivirus da AVIRA, porém deixei desabilitado e mesmo assim, não parou..  Já fiz o seguinte:

    ==> desabilitei antivirus AVIRA
    ==> Parei alguns processos não microsoft
    ==> passei um CHKDSK no disco virtual
    ==> reiniciei o servidor (várias vezes)

    tenho outras VM 02 - CONTROLADOR DE DOMINIO - SERVER 2008, mas tá tudo dentro da normalidade.

    Alguma sugestão, sobre o que eu posso fazer.

    segunda-feira, 8 de julho de 2013 16:49

Respostas

  • Gostaria de sugerir o uso do UPHClean, segue a razão para isso:

    O serviço User Profile Hive Cleanup ajuda a assegurar que as sessões de usuário serão encerradas completamente quando o usuário fizer logoff. Os aplicativos e os processos do sistema mantêm, ocasionalmente, conexões com chaves do Registro no perfil do usuário depois que o usuário faz logoff. Isso faz com que a sessão do usuário não seja encerrada completamente, causando problemas durante a utilização de perfis móveis de usuários, em um ambiente de servidor, ou de perfis bloqueados implementados através do Shared Computer Toolkit para Windows XP.

    Download aqui:

    http://www.microsoft.com/pt-br/download/details.aspx?id=6676

    Felipe Cobu

    • Marcado como Resposta Eleandro segunda-feira, 9 de setembro de 2013 20:30
    sexta-feira, 6 de setembro de 2013 16:37

Todas as Respostas

  • Boa tarde Amigo.

    Seu servidor se encontra totalmente atualizado?

    Me recordo que o Windows Server 2003 teve um Bug referido ao TS, pois o mesmo prendia processos e não deixava finalizar os mesmos, tinha um HotFix que resolvia esse problema, porem hoje nas atualizações do Windows o mesmo já esta incluso.

    Reveja suas configurações de atualizações do Windows e poste novamente.


    Júnior Ramos

    Consultor em TI.

    MCITP | MCTS | MCC |

    Fone: (47) 8417-3475

    E-mail: consultoriaemredes@live.com

    segunda-feira, 8 de julho de 2013 18:25
  • As ultimas atualizações instaladas  foram 18/06 ..mas acabei de verificar novamente..

    Atualizações de alta prioridade
    Não existe nenhuma atualização de alta prioridade disponível para o seu computador.
    Para selecionar outras atualizações, use as opções à esquerda.
    ==============================================================
    segunda-feira, 8 de julho de 2013 20:12
  • Oi pessoal...estou precisando muito disse suporte...alguém poderia dar uma contribuição...realmente não sei mais o que fazer...o problema é que está cada vez mais se agravando... ontem, fiz as rotinas de manutenção (DESFRAGAMENTEI, CHKDSK /R, ANTIVIRUS) tanto no host(físico), quanto nessa VM que fica travando os processos... e MESMO ASSIM, O PROBLEMA PERSISTE.. Alguém pode me dar uma luz, ou ao menos uma nova direção a seguir..
    quarta-feira, 10 de julho de 2013 11:46
  • Olá Eleandro

    Para fins de testes, recomendo o seguinte:

     - Desinstale seu antí-vírus - Apenas desabilitar pode não remover os filtros FLTMC - mais informações: http://blogs.msdn.com/b/ntdebugging/archive/2013/03/25/understanding-file-system-minifilter-and-legacy-filter-load-order.aspx

     - Proceda um clean boot de acordo com estas instruções: http://blogs.msdn.com/b/ntdebugging/archive/2013/03/25/understanding-file-system-minifilter-and-legacy-filter-load-order.aspx

    Por favor compartilhe conosco se após estes procedimentos existe recorrência do problema.


    Fernando H. da Silva - Microsoft Contingent Staff

    • Marcado como Resposta fernando silva 1 quinta-feira, 22 de agosto de 2013 21:53
    • Não Marcado como Resposta Eleandro sexta-feira, 6 de setembro de 2013 13:02
    quinta-feira, 11 de julho de 2013 21:04
  • Bom Dia Pessoal... Estou eu aqui de novo, com o mesmo problema. Na verdade, fiquei um pouco ausente, pois estava com uns problemas grave em alguns clientes, que foram infectados com o vírus antchildporn (http://social.technet.microsoft.com/Forums/pt-BR/a046c963-3fb0-4d62-90e9-7691808159f1/vrus-compacta-arquivo-para-rar-com-senha ) o que deu muito trabalho. Mas voltei, para tentar achar uma solução para esse problema dos processos que ficam travando. Já fiz os testes que foram informados acima, inclusive o CleenBoot porém, o problema ainda persiste. Fiz alguns outros testes também.

    ==> Desistalei o antivírus
    ==> Criei outros usuários para a mesma aplicação que fica travando
    ==> Desistalei e reinstalei o sistema de cobrança do SICRED, UM DOS QUE MAIS TRAVA O PROCESSO

    e mesmo assim, ainda continua. Observei que quando acontece esse travamento, as LEITURAS E GRAVAÇÃO DE E/S no disco, aumenta consideravelmente, e a partir daí, começa uma instabilidade no sistema, o servidor fica LENTO, mesmo estando com uso do CPU menos de 2%, memória usando 55% da capacidade, rede 2% da capacidade.
    Utilizo nesse servidor (SUPERMICRO XEON/6GB) 2HDS SATAII CONVENCIONAL DE 500GB DA SAMSUNG, sem raid. A pergunta é: Até que ponto os HDS podem influenciar no desempenho de um servidor. Hoje temos em média 20 usuários conectados simultaneamente, via TS, nessa VM. Existe alguma recomendação a partir dessas informações... Agradeço! 

    sexta-feira, 6 de setembro de 2013 12:50
  • Gostaria de sugerir o uso do UPHClean, segue a razão para isso:

    O serviço User Profile Hive Cleanup ajuda a assegurar que as sessões de usuário serão encerradas completamente quando o usuário fizer logoff. Os aplicativos e os processos do sistema mantêm, ocasionalmente, conexões com chaves do Registro no perfil do usuário depois que o usuário faz logoff. Isso faz com que a sessão do usuário não seja encerrada completamente, causando problemas durante a utilização de perfis móveis de usuários, em um ambiente de servidor, ou de perfis bloqueados implementados através do Shared Computer Toolkit para Windows XP.

    Download aqui:

    http://www.microsoft.com/pt-br/download/details.aspx?id=6676

    Felipe Cobu

    • Marcado como Resposta Eleandro segunda-feira, 9 de setembro de 2013 20:30
    sexta-feira, 6 de setembro de 2013 16:37
  • Olá Eleandro,

    Veja a lista de hotfix para o serviço do TS do 2003, veja com calma se algum deles se aplica:

     List of Terminal Services related hotfixes for post Service Pack 2 for Windows Server 2003

    Pelo que entendi, aleatórios processos ficam abertos mesmo com o usuário encerrando a sessão remota, correto?

    Se a dica do colega Cobu, que faz muito sentido não ajudar! podemos tentar tirar um dump do processo (procdump sysinternals) para tentar descobrir o que está ocorrendo...

    Att,


    sexta-feira, 6 de setembro de 2013 17:55
  • Oi Felipe...

    Executei sua dica e pelo que observei deu certo. Agora vou acompanhar mais alguns dias, mas já fiz alguns testes e funcionou de boa... Obrigado pela Atenção... Valeu a todos que ajudaram... Um forte abraço.

    segunda-feira, 9 de setembro de 2013 20:30