none
Windows 7 mapeia unidades automaticamente RRS feed

  • Pergunta

  • Amigos, tudo bem?

    Estou com algo bem interessante aqui em nossa rede.

    Temos um servidor Debian que acompanha Samba (compartilhamento de pastas via rede), e lá temos várias pastas que podem ser mapeadas pelo Windows. O servidor possui scripts que rodam quando o usuário se loga na sua máquina, carregando as unidades automaticamente.

    O problema é o seguinte: há um computador da nossa rede que mapeia as duas unidades que devem ser mapeadas, nas letras P e Y. O que acontece é que durante o dia, na utilização do computador, simplesmente o sistema mapeia automaticamente a mesma unidade P em outras letras - uma de cada vez. Ao invés de só duas unidades mapeadas, o Windows cria automaticamente mais 10, 15 unidades, automaticamente, sem script, sem solicitação do usuário.

    Alguém tem uma ideia do que possa ser isto?

    Obrigado!

    • Movido Fábio Jr sexta-feira, 14 de fevereiro de 2014 12:16 Mais adequado
    sexta-feira, 14 de fevereiro de 2014 10:41

Respostas

  • Esse usúario tem algum atalho desse mapeamento ?

    Já tentou apagar as pastas nesse registro e reiniciar a maquina:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2]

    Pode ser útil também:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU]

    e

    [HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices]


    quarta-feira, 12 de março de 2014 14:07

Todas as Respostas

  • Já que não postou script algum considero que é um problema de SO.

    Fábio de Paula Junior

    sexta-feira, 14 de fevereiro de 2014 12:15
  • Fábio, gostaria que eu postasse algum script? Posso postar qualquer um que for necessário.
    sexta-feira, 21 de fevereiro de 2014 15:30
  • Jonathan, você poderia postar o script que faz esse mapeamento nessa máquina?

    Obrigado!

    quarta-feira, 5 de março de 2014 21:49
  • Claro, Luis Miguel.

    Seguinte. Temos cerca de 50 computadores, variando entre XP e 7. Todos fazem login num servidor Debian com Samba 4. Todos eles, ao se logarem, buscam o respectivo script de usuário - netlogon - para, no nosso caso, fazer o mapeamento das pastas. 

    A questão é que nenhum destes teve problema até hoje. Apenas neste computador.

    O script de cada usuário é semelhante ao script a seguir, que é do usuário com problema:

    @echo on

    if (%OS%) == (Windows_NT) goto WINDOWS

    :WINDOWS
    call \\IPA_PDC\NETLOGON\setores\Informatica.bat
    call \\IPA_PDC\NETLOGON\setores\@Publico.bat
    NET USE R:  /delete
    NET USE R:  \\IPA_DADOS\Informatica$\@Geiso
    call \\IPA_PDC\NETLOGON\Labels\Padrao.vbs

    :end

    Para não ficar dúvidas, os bats Informatica e @Publico são os seguintes:

    @echo off

    NET USE Y:  /delete
    NET USE Y:  \\IPA_DADOS\Informatica$

    -----------------------------------------------------------------------------

    @echo off

    NET USE P:  /delete
    NET USE P: \\IPA_DADOS\Publico

    Qualquer informação a mais que precisarem, por favor, é só falar! :)



    quarta-feira, 12 de março de 2014 12:28
  • Esse usúario tem algum atalho desse mapeamento ?

    Já tentou apagar as pastas nesse registro e reiniciar a maquina:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2]

    Pode ser útil também:

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\RunMRU]

    e

    [HKEY_LOCAL_MACHINE\SYSTEM\MountedDevices]


    quarta-feira, 12 de março de 2014 14:07
  • Verifiquei que, por exemplo Luis, no regedit do meu computador, as pastas possuem inúmeros registros em ambos os MountedDevices.

    Posso excluí-los sem problema? Vi que há alguns falando das partições do HD.


    quarta-feira, 12 de março de 2014 17:46
  • Pode, mas não apage os respectivos devices do sistema como o C:

    para uma consulta mais aprofundada:

    http://diddy.boot-land.net/firadisk/files/mounteddevices.htm

    O que influenciaria as partições do HD ?

    Abraços.. Aguardo

    quarta-feira, 12 de março de 2014 19:09
  • Luis, te mando os prints com as pastas e seus registros, de cada uma das 3 chaves.

    RunMRU: Eu excluo todos os registros abaixo? 

    MountedDevices: Excluo todos, menos os últimos?

    quinta-feira, 13 de março de 2014 13:39
  • MountPoint2: Devo excluir todos abaixo? Devo deixar algum? 

    Aguardo sua resposta

    quinta-feira, 13 de março de 2014 13:40
  • Qual é a unidade e pasta que está sendo mapeada varias?
    quinta-feira, 13 de março de 2014 13:45
  • Embora essa lista seja enorme em todas as chaves, esse computador monta só duas unidades, conforme te disse antes. Seriam a \\IPA_DADOS\Publico e \\IPA_DADOS\Informatica$
    quinta-feira, 13 de março de 2014 14:11
  • Tente remover só os registros dessas unidade e reinicie a maquina.
    quinta-feira, 13 de março de 2014 14:23
  • Farei o teste e te reportarei em breve o resultado.
    quinta-feira, 13 de março de 2014 16:07
  • Bom dia

    Fiz a verificação na máquina. Removi as chaves de unidades de rede do MountPoint2 e adicionei uma entrada, no RunMRU, para a unidade que estava com problema.

    Nunca mais o usuário enfrentou esse problema.

    Obrigado amigos! 

    Abraços

    • Editado Jonatha Cardoso sexta-feira, 4 de abril de 2014 14:02 Fim do problema
    terça-feira, 25 de março de 2014 13:31