none
Windows enterprise 2008 32bits com 16gb RRS feed

  • Pergunta

  • Boa tarde a todos

     

    Aqui na empresa o servidor de banco de dados está com o Windows 2008 enteprise SP2 32bits, o servidor tem 16gb e nas propriedades do computador pelo windows marca 16gb corretamente, só que no gerenciador de tarefas só consta 3,5gb de memória física

     

    O correto seria marcar os 16gb no gerenciador não é mesmo? será que vou ter que ativar o PAE no windows?

    Creio que o comando seja esse

    BCDEDIT /set PAE ForceEnable

     

    To pedindo uma ajuda para vocês pois como é servidor de produção não quero fazer na incerteza

     

    Desde já agradeço a atenção

    quinta-feira, 18 de novembro de 2010 18:10

Respostas

  • Boa tarde amigos O comando acima resolve mesmo e é necessário no windows 32 bits para reconhecer mais que 4gb Apliquei no servidor e agora ele está trabalhando com os 16gb Serviu de aprendizado para todos nós Agradeço pela ajuda de todos
    sábado, 20 de novembro de 2010 21:37

Todas as Respostas

  • Boa tarde Jorge,

    Até onde sei, é impossível uma arquitetura de 32bits conseguir utilizar mais de 4gb, devido a capacidade de endereçamento de memória: 2 elevado na 32 = +-4gb.

    No seu caso, você deveria migrar para uma versão 64 bits.


    MCITP Enterprise Desktop Support Technician 7
    quinta-feira, 18 de novembro de 2010 19:04
  • Olá Jorge,

    acrescentando no que o Jose Sasia citou vê os número exatos nesse artigo

    http://msdn.microsoft.com/en-us/library/aa366778%28VS.85%29.aspx


    Relação de Ajuda: Transitive e 2-way, A ajuda B ajuda C, então A ajudou C e C "deve" ajudar A.
    quinta-feira, 18 de novembro de 2010 21:08
  • Bom dia amigos

    Então eu havia visto esse link mas se a gente reparar no gráfico lá diz que o windows enterprise 32bits tem um limite de 64 gb com o PAE habilitado.

     

    Agora eu não sei se ele ja habilita automaticamente ou tenho que digitar o comando acima, por que o windows reconhece que tem 16, só que pelo gerenciador ele só está trabalhando com 3,5

     

     

    sexta-feira, 19 de novembro de 2010 09:30
  • Jorge, bom dia!

    Tem que habilitar ele, segue o link de como fazer

    http://technet.microsoft.com/pt-br/library/cc758228%28WS.10%29.aspx

    Porém, eu não sei como que fica a performance, já que como o José informou, a arquitetura do sistema é projetada para 4 GB, fazendo a conta mencionada acima.

    A sua melhor opção seria colocar um sistema 64bits, mas sei como são as empresas e se falar que vai comprar um outro Windows, vai dar briga...rsrs

    Veja se é isto que está no link que você precisa!

    Abs


    ..::.. Carlos Henrique | MCSA WINDOWS SERVER 2003 ..::..
    sexta-feira, 19 de novembro de 2010 10:57
  • Bom dia novamente pessoal

     

    Obrigado pela atenção Carlos

     

    Fiz o comando aqui, vamos ver o que dá, depois eu posto se ele vai reconhecer toda memória e fica de aprendizado para o pessoal

     

    Então Carlos é que nosso erp não funciona no 32bits então você ja viu ehhehehee

     

     

    Abraço

    sexta-feira, 19 de novembro de 2010 11:26
  • Boa tarde amigos O comando acima resolve mesmo e é necessário no windows 32 bits para reconhecer mais que 4gb Apliquei no servidor e agora ele está trabalhando com os 16gb Serviu de aprendizado para todos nós Agradeço pela ajuda de todos
    sábado, 20 de novembro de 2010 21:37
  • Jorge,

    Qual comando deu certo?

    Abs


    ..::.. Carlos Henrique | MCSA WINDOWS SERVER 2003 ..::..
    segunda-feira, 22 de novembro de 2010 12:51
  • Boa tarde Lucas

     

    O comando foi o BCDEDIT /set PAE ForceEnable

     

    Eu apliquei o comando reiniciei o server, e após reiniciar já estava aparecendo os 16gb no gerenciador de tarefas

     

    Abraços

    segunda-feira, 22 de novembro de 2010 16:50
  • Boa tarde,

     

    Funciona apenas na plataforma 2008 ou na 2003 tb?

     

    Abraços


    "O que é costumeiro no tolo é esquecer nas horas cruciais o que prometera nas horas normais."
    segunda-feira, 22 de novembro de 2010 17:05
  • Boa tarde Michel

     

    Então no meu caso aqui foi o windows 2008

     

    Para o 2003 dá também só que é de uma forma diferente, pelo que vi o 2008 não usa o boot.ini, e o 2003 usa então temos que editar o boot.ini para configurar o PAE

     

    Esse link ta falando isso

    http://msdn.microsoft.com/en-us/library/aa366796%28v=VS.85%29.aspx

     

    Estou copiando para você a parte desse link que diz sobre a plataforma 2003

     

    Windows Server 2003 and Windows XP/2000:   To enable PAE, use the /PAE switch in the Boot.ini file. To disable PAE, use the /NOPAE switch. To disable DEP, use the /EXECUTE switch

     

     

    Espero ter ajudado

     

    Abraços

     

     

    segunda-feira, 22 de novembro de 2010 17:53