none
Configuração de Proxy automática RRS feed

  • Pergunta

  • Bom dia pessoal, estou com uma dúvida/problema espero que vocês possam me ajudar.

    Todos os computadores da rede que trabalho quando logados colocam a seguinte configuração: Proxy Server 128.0.0.0 Porta 80. Todos os usuários recebem essa configuração, erroneamente. E ao fazer o logon com esses usuários novamente, o processo se repete, inclusive no servidor.

    Como faço para deixar essa configuração padrão, ou seja, deixar setado para Detectar Automaticamente as configurações de rede.

    Esse problema surgiu no fim de semana, poderia ser um vírus ou uma má configuração mesmo?

    Desde já agradeço pela ajuda.

    Bruno Sakai

    segunda-feira, 16 de agosto de 2010 14:44

Respostas

  • Bruno, parece sim um tipo de ação interessante para ser feita por um vírus, apesar de nunca ter visto um que faça isso. Verifique se por acaso alguém não colocou por acidente nada em sua Group Policy que faça esta alteração:

    User Configurations >> Windows Settings >> Connection >> Proxy Settings

    Pra saber qual group policy é aplicada ao usuário para você poder conferí-las, execute um gpresult ou rsop.msc

    Boa sorte!


    Se foi útil, não se esqueça de Marcar como Resposta. Cláudio Costa - http://claudio-costa.blogspot.com
    • Marcado como Resposta Bruno Sakai segunda-feira, 16 de agosto de 2010 15:41
    segunda-feira, 16 de agosto de 2010 15:03
    Moderador
  • So vc configurar seu servidor proxy para ser tranparente...

    Depois criar uma GPO para habilitar Detectar Automaticamente as configurações de rede....

    http://img689.imageshack.us/img689/4712/imagemfyk.png

     


    David Dellacenta http://daviddellacenta.spaces.live.com || http://www.andersonpatricio.org || http://www.itcentral.com.br || http://lfdias.mvpbrasil.com.br || http://ffazzani.spaces.live.com
    • Marcado como Resposta Bruno Sakai segunda-feira, 16 de agosto de 2010 15:40
    segunda-feira, 16 de agosto de 2010 15:00
  • Bruno, bom dia!

    Além das opções via GPO do Claudio e do David , se você utilizar script em vbs, pode usar este script, apenas mais um forma de fazer a mesma coisa.

    set wshshell = createobject("Wscript.shell")
    WSHShell.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable", 1, "REG_DWORD"
    WSHShell.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyServer","192.168.5.18:8080"
    WSHShell.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyOverride","<local>http://192.168.5.7;http://192.168.5.3/emc;http://192.168.5.2;http://192.168.5.4"
    WSHShell.RegWrite "HKLM\SYSTEM\CurrentControlSet\Control\Lsa\LmCompatibilityLevel",1,"REG_DWORD"

    abs


    ...Carlos Henrique | MCSA WINDOWS SERVER 2003...
    • Marcado como Resposta Bruno Sakai segunda-feira, 16 de agosto de 2010 15:41
    segunda-feira, 16 de agosto de 2010 15:16

Todas as Respostas

  • So vc configurar seu servidor proxy para ser tranparente...

    Depois criar uma GPO para habilitar Detectar Automaticamente as configurações de rede....

    http://img689.imageshack.us/img689/4712/imagemfyk.png

     


    David Dellacenta http://daviddellacenta.spaces.live.com || http://www.andersonpatricio.org || http://www.itcentral.com.br || http://lfdias.mvpbrasil.com.br || http://ffazzani.spaces.live.com
    • Marcado como Resposta Bruno Sakai segunda-feira, 16 de agosto de 2010 15:40
    segunda-feira, 16 de agosto de 2010 15:00
  • Bruno, parece sim um tipo de ação interessante para ser feita por um vírus, apesar de nunca ter visto um que faça isso. Verifique se por acaso alguém não colocou por acidente nada em sua Group Policy que faça esta alteração:

    User Configurations >> Windows Settings >> Connection >> Proxy Settings

    Pra saber qual group policy é aplicada ao usuário para você poder conferí-las, execute um gpresult ou rsop.msc

    Boa sorte!


    Se foi útil, não se esqueça de Marcar como Resposta. Cláudio Costa - http://claudio-costa.blogspot.com
    • Marcado como Resposta Bruno Sakai segunda-feira, 16 de agosto de 2010 15:41
    segunda-feira, 16 de agosto de 2010 15:03
    Moderador
  • Bruno, bom dia!

    Além das opções via GPO do Claudio e do David , se você utilizar script em vbs, pode usar este script, apenas mais um forma de fazer a mesma coisa.

    set wshshell = createobject("Wscript.shell")
    WSHShell.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyEnable", 1, "REG_DWORD"
    WSHShell.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyServer","192.168.5.18:8080"
    WSHShell.RegWrite "HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ProxyOverride","<local>http://192.168.5.7;http://192.168.5.3/emc;http://192.168.5.2;http://192.168.5.4"
    WSHShell.RegWrite "HKLM\SYSTEM\CurrentControlSet\Control\Lsa\LmCompatibilityLevel",1,"REG_DWORD"

    abs


    ...Carlos Henrique | MCSA WINDOWS SERVER 2003...
    • Marcado como Resposta Bruno Sakai segunda-feira, 16 de agosto de 2010 15:41
    segunda-feira, 16 de agosto de 2010 15:16
  • Obrigado pela atenção.

    David, eu chequei essa configuração e está tudo normal, identico ao da imagem que você colocou no seu post.

    Claudio, fiz isso que você sugeriu e não obtive nada de anormal.

    Eu acabei de chegar na empresa (3 dias), é um empresa de pequeno porte (rede de 40 computadores), e não há um proxy por aqui (por enquanto), a comunicação é feita dos modens as estações por roteadores e switches.

    Vendo as sugestões de vocês, estou começando a acreditar que o problema não é no Windows Server.

    Muito obrigado pela atenção.

    Bruno

    segunda-feira, 16 de agosto de 2010 15:40
  • Pessoal, desculpe "ressuscitar" o tópico, mas andei fazendo alguns testes e o problema realmente está no domínio, pois a mesma maquina fora do dominio não recebe essa configuração, refiz todas as GPOs relacionadas a isso e o problema persiste.

    Alguém pode me indicar um caminho para que eu possa tentar solucionar esse problema? Isso ocorre em estações com Windows 7 Professional, nas estações com XP e Vista esse problema não ocorre.

    Obrigado pessoal

    Bruno

    sexta-feira, 3 de setembro de 2010 18:48