locked
GPO Gerenciamento de Energia RRS feed

  • Pergunta

  • Boa tarde Amigos,

    Preciso criar uma GPO que deixe a configuração do Plano de Energia que eu definir como padrão em algumas máquinas.

    Para esta finalidade, criei uma GPO e linkei a OU que deseja. Na edição da GPO fui em User Configuration > Preferences > Control Panel Settings > Power Options e criei um novo Power Plan com o nome e configurações de energia que desejava.

    Então loguei com um usuário dessa OU para verificar se havia atribuído o novo plano de energia para o usuário.

    Em Opções de Energia no Painel de Controle do usuário, identifiquei que o novo Plano de Energia criado na GPO está lá. Porém ele não vem como DEFAULT. O plano que vem como default é o padrão do Windows que é o "Equilibrado."

    Eu precisava que o novo Plano de Energia criado através da GPO assumisse como DEFAULT para estes usuários.

    segunda-feira, 21 de novembro de 2016 16:29

Respostas

  • Você pode forçar um plano configurando a seguinte política:

    Computer Configuration\Policies\Administrative Templates\System\Power Management\ specify a custom active power plan

    O problema de você criar seu próprio plano, pelo que testei, é que um GUID aleatório é gerado em cada estação em que a política é aplicada. Você poderia usar um script para capturar esse GUID como em:

    https://blogs.technet.microsoft.com/heyscriptingguy/2010/08/31/get-windows-power-plan-settings-on-your-computer-by-using-powershell/

    Mas acho inviável. O ideal é apenas customizar os planos já existentes, do modo que você já fez, só que sem alterar o nome e deixando o campo "Action" como "Update"

    Com isso você poderá usar a GUID padrão para forçar o plano na estação.

    Comando: powercfg /list

    GUID do Esquema de Energia: 381b4222-f694-41f0-9685-ff5bb260df2e  (Equilibrado)
    GUID do Esquema de Energia: 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c  (Alto desempenho) *
    GUID do Esquema de Energia: a1841308-3541-4fab-bc81-f71556f20b4a  (Economia de energia)

    Fontes:

    http://www.thewindowsclub.com/specify-custom-active-power-plan-windows


    • Editado J. Maurício terça-feira, 22 de novembro de 2016 12:40
    • Marcado como Resposta Jackson Pedrini quarta-feira, 23 de novembro de 2016 13:44
    terça-feira, 22 de novembro de 2016 12:18

Todas as Respostas

  • Você pode forçar um plano configurando a seguinte política:

    Computer Configuration\Policies\Administrative Templates\System\Power Management\ specify a custom active power plan

    O problema de você criar seu próprio plano, pelo que testei, é que um GUID aleatório é gerado em cada estação em que a política é aplicada. Você poderia usar um script para capturar esse GUID como em:

    https://blogs.technet.microsoft.com/heyscriptingguy/2010/08/31/get-windows-power-plan-settings-on-your-computer-by-using-powershell/

    Mas acho inviável. O ideal é apenas customizar os planos já existentes, do modo que você já fez, só que sem alterar o nome e deixando o campo "Action" como "Update"

    Com isso você poderá usar a GUID padrão para forçar o plano na estação.

    Comando: powercfg /list

    GUID do Esquema de Energia: 381b4222-f694-41f0-9685-ff5bb260df2e  (Equilibrado)
    GUID do Esquema de Energia: 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c  (Alto desempenho) *
    GUID do Esquema de Energia: a1841308-3541-4fab-bc81-f71556f20b4a  (Economia de energia)

    Fontes:

    http://www.thewindowsclub.com/specify-custom-active-power-plan-windows


    • Editado J. Maurício terça-feira, 22 de novembro de 2016 12:40
    • Marcado como Resposta Jackson Pedrini quarta-feira, 23 de novembro de 2016 13:44
    terça-feira, 22 de novembro de 2016 12:18
  • Boa tarde, 

    Legal utilizei as opções de UPDATE para atualizar o plano de energia. 

    Muito obrigado pela ajuda. Realizei o procedimento e deu certo.

    Uma dúvida... Para forçar um plano de energia configuro conforme está na fonte: http://www.thewindowsclub.com/specify-custom-active-power-plan-windows,,,,, porém isso se aplica somente a Computer Configuration e não User Configuration,,, certo?

    Então se quiser forçar um plano de energia a um usuário em uma máquina e na mesma máquina deixar livre para outro não teria como ne?

    Att,

    • Marcado como Resposta Jackson Pedrini quarta-feira, 23 de novembro de 2016 12:00
    • Não Marcado como Resposta Jackson Pedrini quarta-feira, 23 de novembro de 2016 13:44
    terça-feira, 22 de novembro de 2016 18:58
  • Fico feliz em poder ajudar, se possível, marque meu post anterior como resposta, pois ele já o ajudou.

    Quanto a segunda questão levantada, você poderia criar um grupo de usuários e especificá-lo no filtro de segurança da GPO e remover o Authenticated Users. Entretanto, pelo teste que fiz, o comportamento da GPO fica estranho. Embora o plano escolhido seja aplicado, fica habilitada ao usuário a opção de alterará-lo.



    • Editado J. Maurício quarta-feira, 23 de novembro de 2016 13:30 clareza
    quarta-feira, 23 de novembro de 2016 10:03
  • Olá. Marque o tópico em que eu ajudei a resolver seu problema (para ajudar na minha pontuação) e não sua própria resposta. Se possível, é claro.

    Grato.


    • Editado J. Maurício quarta-feira, 23 de novembro de 2016 13:27
    quarta-feira, 23 de novembro de 2016 13:26
  • Desculpe, já marquei.
    quarta-feira, 23 de novembro de 2016 13:46
  • Muito obrigado!
    quarta-feira, 23 de novembro de 2016 13:56
  • Desculpe, acho q não entendi direito......

    A regra de forçar a GPO de Plano de Energia, sem que tenha a possibilidade de escolha do user,  é atribuída ao computador e não ao user logado correto?

    Sendo assim essa GPO deve ser atrelada a OU o qual o PC esteja inserido e não somente na OU em que o user esteja inserido.

    Correto?

    Sendo assim, todos os users que logarem naquele PC atribuiram a GPO.

    quinta-feira, 24 de novembro de 2016 12:56
  • Exatamente. É aplicada a nível de computador. O que fiz foi testar se era possível filtrar essa GPO por algum grupo de usuários e o comportamento foi o descrito anteriormente.
    quinta-feira, 24 de novembro de 2016 13:15
  • É testei a opção com group porém não funcionou mesmo. A GPO tem que ser aplicada a máquina mesmo para já trazer como DEFAULT.

    Mas obrigado pela atenção.

    quinta-feira, 24 de novembro de 2016 13:56