none
Synchronization Status "Failed" RRS feed

  • Pergunta

  • Pessoal, é o seguinte.

    Tenho um parque enorme, tanto de estações quanto de servidores.

    Ainda possuo, até por falta de recursos, diversos clientes que ainda operam com o WSUS2.0 no Windows 2000.

    O servidor de distribuição "Upstream Server" é WSUS3.0Sp2.

    Ocorre que aqueles servidores Wsus2.0 ao sincronizarem com este Wsus3.0Sp2 apresenta status de falha.

    O interessante é que as atualizações baixam, o quantitativo de aprovadas bate com o servidor PAI, mas o status continua apresentando falha com a msg...

    Tipo: Manual

    Iniciado: 27/1/2011 06:50
    Concluído: 27/1/2011 06:50
    Resultado: Ocorreu um erro ao adicionar atualizações ao banco de dados. Tente sincronizar novamente ou verifique a configuração do banco de dados.

    27/1/2011 O metadado da atualização é inválido e não pôde ser processado corretamente pelo banco de dados. {29695606-6562-40c0-a569-600771e42eb9}, 100

    "Synchronization failed. Reason: System.Data.SqlClient.SqlException: Some update revisions referred to in XML do not exist in the database for update 29695606-6562-40C0-A569-600771E42EB9\100
       at Microsoft.UpdateServices.DatabaseAccess.DBConnection.DrainObsoleteConnections(SqlException e)
       at Microsoft.UpdateServices.DatabaseAccess.DBConnection.ExecuteCommandNoResult()
       at Microsoft.UpdateServices.Internal.DataAccess.ExecuteSPImportUpdate(Int32 upstreamServerLocalId, String xmlUpdateBlob, Byte[] xmlUpdateBlobCompressed, Int32& localRevisionId)
       at Microsoft.UpdateServices.Internal.DataAccess.ImportUpdate(Int32 ussRevLocalId, String xmlUpdateBlob, Byte[] xmlUpdateBlobCompressed, Int32& localRevisionId)
       at Microsoft.UpdateServices.Internal.DataAccess.ImportUpdateForCatalogSync(String xmlUpdateBlob, Byte[] xmlUpdateBlobCompressed, ServerSyncUrlData[] fileUrls)
       at Microsoft.UpdateServices.ServerSync.CatalogSyncAgentCore.ProcessNewUpdate(ServerSyncUpdateData updateData)
       at Microsoft.UpdateServices.Se."

    Já não sei o que fazer.

    O problema não ocorre entre WSUS3.0SP2

    Alguém teria um solução. Não vale recomendar a migração para WSUS3.0.

    Obrigado


    Maxalon
    terça-feira, 1 de fevereiro de 2011 16:34

Respostas