none
Sharepoint Designer x Notificação e-mail RRS feed

  • Pergunta

  •  

    Prezados Colegas,

     

    Aconteceu uma coisa muito estranha comigo ontem e achei interessante postar aqui para saber se já aconteceu com alguem e se já conhecem a causa disto.

     

    Criei um fluxo no SP Designer 2007 para coleta de assinatura para uma bilioteca de documentos do WSS 3.0.

     

    A cada passo ele notifica o criador em que fase o documento está. Para estas notificações utilizei a ação enviar e-mail nativa do SP designer.

     

    Depois de tudo criado resolvi mudar o corpo das notificações de e-mail. Alterei, salvei o fluxo, removi a versão anterior nas definições dabiblioteca, e iniciei o fluxo manualmente.

     

    O fluxo enviou o conteudo do corpo do e-mail anterior. (fiquei extremamente assustado)

     

    Entrei no fluxo e exclui a ação de notificação salvei, rodei o fluxo, e beleza. Não recebi nenhum email.

     

    Em seguida abri o fluxo e adicionei uma nova ação e escrevi tudo dinovo o corpo do e-mail e salvei o fluxo.

     

    Iniciei novamente e adivinha? ao invés de enviar o conteudo novo, enviou o conteudo que eu já tinha excluído anteriormente.

     

    Será que alguem tem uma explicação clara para este incidente?

     

    Abraços,

     

    Heber Lopes

    terça-feira, 4 de março de 2008 07:15

Todas as Respostas

  • Olá Heber tudo bem?

    Realmente achei muito interessante sobre este tema.

    Eu nunca passei por isto e realmente vou aguardar novos posts.. pois é estranho e interessante.

    quinta-feira, 6 de março de 2008 17:11
  • Pois é, Bruniinho

     

    Achei super estranho que cheguei remover o fluxo da lista e gravar novamente no Sharepoint Workflow Designer. E mesmo assim continuou enviando o conteudo antigo. Não sei se pode ser algum cachê do Exchange 2007 que causou isso. Ou o WSS guarda esta informação em algum lugar que não estava sendo atualizada ao gravar o fluxo.  Sei que me borrei todo. Tive que construir um fluxo de mais de 30 condições do zero.

     

    Continuo aguardando a palavra de um sábio que tenha uma explicação para isto.

     

    Atenciosamente,

     

    Heber Lopes

     

    quinta-feira, 6 de março de 2008 17:29
  •  

    Cara, falar em cache, vc ja deu uma olhada no log do Exchange? talvez tenha alguma informação útil, lá!

    Infelizmente não manjo muito de exchange.

     

    segunda-feira, 10 de março de 2008 14:35