none
Acesso de FTP Externo Bloqueado RRS feed

  • Pergunta

  • Pessoal, bom dia.

     

    Já pesquisei em vários posts no fórum e em nenhum encontrei um problema relacionado, tampouco solução.

     

    É o seguinte:

     

    No ISA 2006 tenho uma regra que permite acesso a FTP externo (ftp://ftp.pucmg.br , ftp://ftp.ufmg.br, por exemplo).

    Essa regra esta habilitada para todos os usuários, com o filtro de FTP habilitado e o método de somente leitura desmarcado.

     

    Entretanto, sempre que tentamos de alguma estação acessar um FTP qualquer, ele retorna a seguinte mensagem na tela:

     

    ISA Server: mensagem de erro estendida :

    200 Type set to A
    500 Illegal PORT command

    Quando faço a filtragem do log no monitor do ISA

     

    0x80074e20 FWX_E_GRACEFULL_SHUTDOWN.

     

    Se alguém pudesse ajudar, ficarei grato.

     

    Atenciosamente.

     

     


     

    quinta-feira, 6 de novembro de 2008 13:09

Todas as Respostas

  • Olá Anderson,

     

    Este error acontece quando vc usa FTP via linha de comando ou via Internet Explorer?

    Estes sites usam FTP em Modo Passivo? Se usam então vc precisa seguir o artigo abaixo (tb aplica-se a ISA 2006) para habilitar modo passivo no ISA:

    http://support.microsoft.com/kb/300641/en-us

     

    Abraços,

     

     

    quinta-feira, 6 de novembro de 2008 15:11
  • Se usado pelo IE, qual versão?
    quinta-feira, 6 de novembro de 2008 15:27
    Moderador
  •  

    Olá senhores, na verdade fiz o teste em modo via IE (a versão é a 7 - isso responde também ao Luis Fernando).

     

    Pelo modo de linha de comando, ele conecta até certa parte do site, ai pede usuário e senha (que pelo modo web é passado antes no logon da página principal das faculdades especificadas).

     

     

     

    quinta-feira, 6 de novembro de 2008 17:49
  • No IE7 depois que ele der o erro...

    Clique no MENU PAGINA e selecione ABRIR SITE FTP NO WINDOWS EXPLORER...

    fa zo teste e post novamente.

    abraços
    quinta-feira, 6 de novembro de 2008 18:07
    Moderador
  • Outra coisa que voce deve fazer no Internete Explorer 7 é :

     

    Ferramentas >> Opções de Internet >> Guia Avançada.

    Procure por : USE FTP PASSIVO.

     

    DESMARQUE ESTA OPÇAO !

     

    Depois siga os passos do Luiz ( post acima ) e deve funcionar.

    Abraços.

    quinta-feira, 6 de novembro de 2008 19:13
  • Ola Luiz, segui primerio a orientação postada pelo Yuri, referente a documentação encontrada na página de suporte da MS (http://support.microsoft.com/kb/300641/en-us).

     

    Bom a partir dai consegui conectar nos sites, entretanto a tela que aparece é uma tela de windows em modo web.

    Seguindo sua orientação, ou seja, exibindo como Windows Explorer, ele me deu dois erros diferentes (um em cada site - PUC e Microsiga - distintos.).

     

    No primeiro da PUC ele me informou os seguintes erros:

     

    Erro ao abrir esta pasta no servidor FTP. Certifique-se de que você tem permissão para acessar a pasta.

     

    Detalhes:

    200 Type Set To A

    500 Illegal Port Command

    500 LPRT Not Understood

     

    Para o caso da Microsiga, acontece o seguinte:

     

    Erro ao abrir esta pasta no servidor FTP. Certifique-se de que você tem permissão para acessar a pasta.

     

    Detalhes:

    200 Type Set To A

    500 Illegal Port Command

    500 LPRT 6,16,0,0,0,0,0,0,0,0,0,0,0,0,110,160,128,124,2,10,138 Not Understood

     

    Percebi que já faz downloads de drivers de fabricantes onde o site é do tipo FTP. Também acessa via web esses sites, apenas via pasta tem acontecido esses erros.

     

    Mas as dicas estão no caminho certo. Se souber mais alguma coisa Luiz e Yuri, ficarei grato.

     

     

    quinta-feira, 6 de novembro de 2008 19:14
  • Olá Anderson

     

    Tente digitar no IE o caminho completo já com as credenciais para verificar se o problema está sendo devido a uma falha de logon:

     

    ftp://User_Name: Password@EnderecoServidorFTP

     

    Exemplo:

    ftp://anderson: senha@ftp.domain.com

     

     

    Abraço,

    sexta-feira, 7 de novembro de 2008 04:56
  • Boa tarde,

    Estou com um problema parecido aqui na empresa, tenho o ISA apenas como web proxy e quando tento acessar um ftp externo ou interno ele me dá a msn de acesso negado ERRO 550, alguem poderia me ajudar com isso??

    Obrigado.
    segunda-feira, 17 de novembro de 2008 19:12
  • Amigão, no caso do acesso ftp interno se vc usa o isa como web proxy, e o client proxy provavelmente vc esqueceu de selecionar a opção não usar proxy para endereço locais. Se num for isso, de mais detalhes do tipo de client que vc esta usando.

    terça-feira, 18 de novembro de 2008 00:26
  • Bom, já que o tópico se refere à problemas de FTP no ISA... vamos lá... outro problema:

     

    Tenho uma regra permitindo acesso da rede interna para a externa com HTTP, HTTPS e DNS apenas para usuários autenticados. OK, tudo bem... consigo acessar normalmente qualquer FTP cuja autenticação seja anônima...

     

    Para qualquer FTP que solicite autenticação tenho o seguinte erro:

  • Error Code: 502 Proxy Error. The login request was denied. The logon account might have been disabled or logon information might have changed. Log on again to verify that the information was typed correctly. If the problem continues, report the problem to the administrator of the Internet server you are requesting. (12015)

     

    O IE7 está configurado na zona Internet para logon automático apenas na intranet...

     

    Alguem poderia me auxiliar?

     

    Muito obrigado!!!

terça-feira, 18 de novembro de 2008 13:53
  • Encontrei algo sobre isso:

     

    How to access an FTP site that is not anonymous using Internet Explorer

    Symptom: Internet Explorer cannot access FTP sites requiring credentials.

    Issue: When FTP requests are sent over HTTP for Web proxy clients, only anonymous access is allowed. To use Internet Explorer as an FTP client when an FTP server requires authentication, you must configure Internet Explorer for direct FTP access.

    Solution: Enable the Enable folder view for FTP sites check box in Internet Explorer. This causes Internet Explorer to prompt for credentials. Then specify credentials in the following format: ftp://usernameStick out tongueassword@ftp.usdirectcom.net/. Alternatively, configure the client as a SecureNAT or Firewall client and access the FTP server using an alternative FTP client.

    HTTP 502 Proxy Error - The login request was denied

    Symptom: When accessing an external FTP site that requires authentication, the following error is received: "HTTP 502 Proxy Error - The login request was denied."

    Issue: Web proxy normally sends anonymous authentication information to an FTP site in the first request. If the FTP site rejects and closes the connection at the first try, this error is issued. If you monitor the FTP traffic, you will see a log entry similar to: "Port: 21 FTP failed connection attempt user: anonymous request: Get ftp://FTPServer/."

    Solution: When accessing an external FTP site that requires authentication from a Web proxy client, provide credentials in the URL, in the following format: ftp://usernameStick out tongueassword@FTPServerName.

    This issue does not occur in the following circumstances:

    • SecureNAT clients or Firewall clients make the FTP request.
    • The Enable folder view for FTP sites check box is selected in Internet Explorer. With this setting enabled, Internet Explorer sends the request directly to the FTP site if it can resolve the remote host name, ignoring browser settings. If the host name cannot be resolved, the browser is used.

     

    terça-feira, 18 de novembro de 2008 15:57
  • No caso aqui na empresa nos utilizamos o ISA apenas como filtro de URL, as estações de trabalho sai direto pelo ISA, sem configurar proxy ou utilizar firewall client. Quando tento acessar um FTP externo ele me dá a msn 550 de acesso negado.

    Obrigado....

    terça-feira, 18 de novembro de 2008 19:27
  • Olá Anderson,

     

    Este error acontece quando vc usa FTP via linha de comando ou via Internet Explorer?

    Estes sites usam FTP em Modo Passivo? Se usam então vc precisa seguir o artigo abaixo (tb aplica-se a ISA 2006) para habilitar modo passivo no ISA:

    http://support.microsoft.com/kb/300641/en-us

     

    Abraços,

     

     

    Yuri estou com o mesmo problema mas preciso saber antes o que é FTP em modo passivo? desculpe a minha ignorância..rsss

    sábado, 7 de abril de 2012 12:37