none
Função para calcular Sábado, Domingo e Feriado RRS feed

  • Pergunta

  • Pessoal,

     

    Estou com a seguinte situação:

     

    Tenho uma tabela onde preciso referenciar se determinada data se trata de um sábado, domingo ou feriado, conforme o exemplo abaixo.

     

    |          DATA         |          DIA DA SEMANA       |

    |        21/04/11     |                 Feriado                 |

    |        22/04/11     |                 Feriado                 |

    |        23/04/11     |                 Sábado                 |

    |        24/04/11     |                 Domingo              |

     

    Na tabela acima, supondo que a COLUNA A seja da “DATA”, preciso que na COLUNA B seja informado o DIA DA SEMANA.

     

    Como nossa empresa trabalha com bonificação em dinheiro por execução de serviços prestados aos finais de semana e feriados, esta informação é fundamental para o cálculo de comissionamento dos prestadores de serviços.

     

    Verifiquei varias postagens no fórum, mas não encontrei nada que se encaixa a solução que preciso.

     

    Conto com a ajuda da comunidade.

     

    Sds,

     

    Fernando

    sexta-feira, 20 de maio de 2011 13:35

Respostas

  • Olá amigo, boa tarde.

    Para retornar o DIA DA SEMANA buscando como referência uma determinada DATA você pode usar a função =TEXTO(Valor;Formato_texto). O detalhe é que essa função não irá retornar a palavra "feriado", somente os dias da semana. Ficará da seguinte forma:

    *vamos Simular uma planilha:

    ----------------------------------------------------------------------------------------

                 A                               B

    1       DATA                  Dia da Semana

    2    21/04/11            =TEXTO(A2;"dddd")   -->   Resultado (Quinta-Feira)

    3    22/04/11            =TEXTO(A3;"dddd")   -->   Resultado (Sexta-feira)

    ----------------------------------------------------------------------------------------

    Após isso é só puxar a "Alça de preenchimento" para as demais.

    Espero ter ajudado.

    Um Abraço!

    terça-feira, 26 de junho de 2012 18:22
  • Olá Kellvy.

    Já se passou 1 ano, 1 mês e 6 dias desde que postei essa mensagem no tópico.

    Na ocasião, me lembro que encontrei um alternativa para esta situação, mas não sei te dizer qual foi a fórmula que encontrei.

    Como implantamos um sitema que faz a gestão dessa situação, a planilha acabou sendo descartada, mas vou tentar localiza-la para encontrar a solução que dei e compartilhar com você.

    Mesmo assim, obrigado pela atenção e por compartilhar seu conhecimento.

    Grande abraço.

    quarta-feira, 27 de junho de 2012 18:04

Todas as Respostas

  • Olá Fernando, boa tarde.

    Estou migrando seu post para o fórum especializado em Office.


    Hezequias Vasconcelos

    sexta-feira, 22 de junho de 2012 16:59
    Moderador
  • Olá amigo, boa tarde.

    Para retornar o DIA DA SEMANA buscando como referência uma determinada DATA você pode usar a função =TEXTO(Valor;Formato_texto). O detalhe é que essa função não irá retornar a palavra "feriado", somente os dias da semana. Ficará da seguinte forma:

    *vamos Simular uma planilha:

    ----------------------------------------------------------------------------------------

                 A                               B

    1       DATA                  Dia da Semana

    2    21/04/11            =TEXTO(A2;"dddd")   -->   Resultado (Quinta-Feira)

    3    22/04/11            =TEXTO(A3;"dddd")   -->   Resultado (Sexta-feira)

    ----------------------------------------------------------------------------------------

    Após isso é só puxar a "Alça de preenchimento" para as demais.

    Espero ter ajudado.

    Um Abraço!

    terça-feira, 26 de junho de 2012 18:22
  • Olá Kellvy.

    Já se passou 1 ano, 1 mês e 6 dias desde que postei essa mensagem no tópico.

    Na ocasião, me lembro que encontrei um alternativa para esta situação, mas não sei te dizer qual foi a fórmula que encontrei.

    Como implantamos um sitema que faz a gestão dessa situação, a planilha acabou sendo descartada, mas vou tentar localiza-la para encontrar a solução que dei e compartilhar com você.

    Mesmo assim, obrigado pela atenção e por compartilhar seu conhecimento.

    Grande abraço.

    quarta-feira, 27 de junho de 2012 18:04
  • Olá Nando_Rodrigues.

    Eu vi sim que já tinha um tempo que você havia postado a pergunta. Já tem um tempo que sou associado ao technet e nunca tinha parado pra responder. Estou pegando algumas perguntas que estão sem respostas e tentando ajudar, rs. Mas, se você encontrar a planilha compartilha sim, será bem vinda!

    Não precisa agradecer, precisando estamos ai.

    Um grande abraço!

    quinta-feira, 28 de junho de 2012 12:25