none
Receive Connector Ex 2010 RRS feed

  • Pergunta

  • Olá galera, tenho um problema basico com alguns e-mails, gostaria de saber se o meu receive connector está corretamente com a autenticação correta.

    Esse receive é o externo. ABS!

    quinta-feira, 15 de março de 2012 22:30

Respostas

  • A nivel de servidor, no seu HUB transport a configuração de DNS interno e externo esta para utilizar a da placa fisica ou setado algum manualmente?

    Como esta a configuração dos FORWARDERS no DNS?

    No seu SEND conector no EXCHANGE, na guia NETWORK a opção Use the external DNS lookup Settings on the transport Server esta marcada?

    Você está listado em alguma blacklist?
    http://mxtoolbox.com/blacklists.aspx

    terça-feira, 3 de abril de 2012 21:19
  • Então cara o que deve estar acontecendo é que ele ta expirando antes de alcançar os Root Hints, ele faz uma busca no primeiro DNS, não acha, vai pro segundo, não acha, pro terceiro e depois pros Root Hints, testa habilitar o external DNS lookup e se possivel remove esses fowarders ai pra testar assim ele procura em 1 DNS e sai direto pra Root Hints.

    Você poderia também almentar o delay de busca que se nao me engano são 2 ou 3ms por default via linha de comando, mas seria melhor resolver a questão das maneiras que citei acima.

    • Marcado como Resposta Antikilahdjs segunda-feira, 9 de abril de 2012 14:33
    quarta-feira, 4 de abril de 2012 17:29
  • Olá!

    Percebo que a resposta para uma conexão telnet na porta 25 responde para um endereço de um domínio .intra.
    Sabemos que torna-se uma boa pratica garantir que a resposta para conexões telnet seja retornada por um endereço com registro valido no seu DNS externo. Então aconselho a você utilizar um nome valido na resposta de uma consulta telnet.
    Esse pode ser um dos problemas para você ter problemas com o envio de mensagens.

    Obs: O endereço de resposta é alterado na guia Gerais do seu Receive Connector


    Jonathan Santos | http://jonathanrsantos.wordpress.com MCP | MCSA | MCSA Messaging | MCSE

    • Marcado como Resposta Antikilahdjs segunda-feira, 9 de abril de 2012 14:33
    sábado, 7 de abril de 2012 07:28
    Moderador
  • Ola,

    Você pode fazer vários testes no seu e-mail do nos servidores de destino usando o www.mxtoolbox.com .

    No seu caso por exemil o IP do mail.mascarotour.com.br não possui reverso correto, o IP do mail2 possui. Talvez seja esse o motivo de os servidores de destino não estarem aceitando conexão do seu servidor.

    • Marcado como Resposta Antikilahdjs segunda-feira, 9 de abril de 2012 14:33
    sábado, 7 de abril de 2012 18:48
  • Na guia Authentication desmarque "Exchange Server authentication".
    Esse tipo de autenticação é baseado no GSSAPI, ou seja inicialmente só serviria para comunicação entre servidores Exchange no seu ambiente. Como trata-se de um Connector para recebimento de mensagens publico, você pode desmarcar essa opção e tentar novamente.

     

    Jonathan Santos | http://jonathanrsantos.wordpress.com MCP | MCSA | MCSA Messaging | MCSE

    • Marcado como Resposta Antikilahdjs segunda-feira, 9 de abril de 2012 14:33
    sábado, 7 de abril de 2012 20:28
    Moderador

Todas as Respostas

  • Qual o problema?

    Aparentemente está correto a parte de Autenticação.


    Wesley Martins Silva Linkedin | Twitter | www.wesleymartins.info

    sexta-feira, 16 de março de 2012 03:03
  • Perfeito....então.. algumas vezes os e-mails não saem, mas são raros... até verifico o mx, o reverso e o host se realmente existe, na maioria das vezes está tudo certo do outro lado, mas não sai.... segue o erro..

    Por exemplo, eu lhe disse para receber, desculpe é para enviar.... um erro por exemplo da mailbox

    Identity: srv-exchange\22831\457098
    Subject: SOLICITAÇÃO DE RESERVA HOTEL MAR HOTEL
    Internet Message ID: <9A993EF2250E70488A7C79EC3BFE909865B048@srv-exchange.Mascarotour.intra>
    From Address: sabrina.maltes@mascarotour.com.br
    Status: Retry
    Size (KB): 41
    Message Source Name: FromLocal
    Source IP: 255.255.255.255
    SCL: -1
    Date Received: 16/03/2012 14:06:41
    Expiration Time: 17/03/2012 14:06:41
    Last Error: 451 #4.1.8 Domain of sender address <sabrina.maltes@mascarotour.com.br> does not resolve
    Queue ID: srv-exchange\22831
    Recipients:  reservas@ponteshoteis.com.br

    Obrigado mais uma vez


    • Editado Antikilahdjs sexta-feira, 16 de março de 2012 22:38
    sexta-feira, 16 de março de 2012 18:22
  • Boa tarde, seu Exchange que envia direto os e-mails. ou seja, ele é publicado direto??? Ou voce usa ele como relay??

    Victor R. Petroveski Gestor de TI

    segunda-feira, 19 de março de 2012 14:24
  • Bom dia Victor, envia direto, não tenho relay, uso MX próprio... DNS reverso ok, apontamentos ok, publicado na internet ok, dns interno ok.

    SPF tambem está ok, estranho que é muito poucos dominios que fazem isso, poderia ser algo do outro lado tbm correto?

    segunda-feira, 19 de março de 2012 14:41
  • Sim poderia, por isso perguntei se voce replica em algum lugar. Me parece que é o problema realmente esta no DNS. Voce pode explicar melhor a estrutura?

    Victor R. Petroveski Gestor de TI

    terça-feira, 3 de abril de 2012 18:14
  • Ok, tenho um SV somente do Exchange 2010, tenho 4 DNS replicados, fiz os apontamentos dentro da Zona do DNS conforme abaixo.

    Tenho um firewall na frente, está com as portas normal abertas, o reverso para ambos os 2 ips estão também ok, spf tbm corretamentes configurados.

    Pode ser algo no Exchange que não fiz?

    terça-feira, 3 de abril de 2012 20:07
  • A nivel de servidor, no seu HUB transport a configuração de DNS interno e externo esta para utilizar a da placa fisica ou setado algum manualmente?

    Como esta a configuração dos FORWARDERS no DNS?

    No seu SEND conector no EXCHANGE, na guia NETWORK a opção Use the external DNS lookup Settings on the transport Server esta marcada?

    Você está listado em alguma blacklist?
    http://mxtoolbox.com/blacklists.aspx

    terça-feira, 3 de abril de 2012 21:19
  • Sim o de uso externo e interno está setado para usar a fisica, network cards... não coloquei manual.... nos Forward coloquei um print acima...os mxs estão setados tbm... host a criado etc.... no Exchange os DNS Lookup não estão marcadas, estão para usar o MX Interno.

    Nenhum dos meus 2 ips estão em Black.. obrigado pelo apoio.

    terça-feira, 3 de abril de 2012 22:59
  • Marque a opção Use the external DNS lookup Settings on the transport Server e reinicie o serviço de transport do exchange.

    Depois disso teste o envio


    Quanto ao forwarders que digo, é clicando na console do DNS no servidor com direito, propriedades, Forwarders
    quarta-feira, 4 de abril de 2012 13:41
  • Olá Renato, mas se eu fizer isso ele vai forçar a saida para o externo correto? Fiz a alteração vou verificado o que irá ocorrer, ... tenho 4 DNS contando com o Exchange, então segue como está.

    Obrigado pelo apoio.


    • Editado Antikilahdjs quarta-feira, 4 de abril de 2012 16:46
    quarta-feira, 4 de abril de 2012 16:43
  • Então cara o que deve estar acontecendo é que ele ta expirando antes de alcançar os Root Hints, ele faz uma busca no primeiro DNS, não acha, vai pro segundo, não acha, pro terceiro e depois pros Root Hints, testa habilitar o external DNS lookup e se possivel remove esses fowarders ai pra testar assim ele procura em 1 DNS e sai direto pra Root Hints.

    Você poderia também almentar o delay de busca que se nao me engano são 2 ou 3ms por default via linha de comando, mas seria melhor resolver a questão das maneiras que citei acima.

    • Marcado como Resposta Antikilahdjs segunda-feira, 9 de abril de 2012 14:33
    quarta-feira, 4 de abril de 2012 17:29
  • Perfeito, muito grato pela explicação, então removi os forwards e marquei esse opção no send connector, vou fazer o teste...... agradeço o apoio.....
    quarta-feira, 4 de abril de 2012 18:49
  • Ok, teste e não esqueça de reiniciar a transport rule em services, depois nos de um retorno se resolveu!

    quarta-feira, 4 de abril de 2012 20:43
  • Renato, ok, já fiz isso, também coloquei o DNS para sair com o do Google por exemplo, mas ainda continua......

    O engraçado é que alguns domains eu consigo dar o nslookup......

    Alguns são realmente que está bloqueando, pelo meu Forefront.... mas por exemplo esse lbcd.com.ly é um cliente nosso e não sai os e-mails desse dominio.

    quinta-feira, 5 de abril de 2012 16:18
  • Este lbcd.com.ly realmente nao retorna registros MX

    No iobnet.com.br vc consegue resolver? Aqui resolve:

    C:\Users\renato.rix>nslookup
    Default Server:  svr-scorpius.abet.com.br
    Address:  192.168.0.17

    > set q=mx
    > iobnet.com.br
    Server:  svr-scorpius.abet.com.br
    Address:  192.168.0.17

    Non-authoritative answer:
    iobnet.com.br   MX preference = 10, mail exchanger = iobtl

    iobtlr.iobnet.com.br    internet address = 200.152.211.4

    quinta-feira, 5 de abril de 2012 17:35
  • Olá Renato, não o lbcd não retorna para mim tbm....agora o Iobnet está ok.... como para você.

    Se retorna era para estar ok a saida dos e-mails não é?

    C:\Users\jeferson.gomes>nslookup
    Servidor PadrÒo:  srv-exchange.mascarotour.intra
    Address:  192.168.1.6

    > set q=mx
    > iobnet.com.br
    Servidor:  srv-exchange.mascarotour.intra
    Address:  192.168.1.6

    Não é resposta de autorização:
    iobnet.com.br   MX preference = 10, mail exchanger = iobtlr.iobnet.com.br

    iobtlr.iobnet.com.br    internet address = 200.152.211.4
    >


     

    quinta-feira, 5 de abril de 2012 20:00
  • Olá!

    Percebo que a resposta para uma conexão telnet na porta 25 responde para um endereço de um domínio .intra.
    Sabemos que torna-se uma boa pratica garantir que a resposta para conexões telnet seja retornada por um endereço com registro valido no seu DNS externo. Então aconselho a você utilizar um nome valido na resposta de uma consulta telnet.
    Esse pode ser um dos problemas para você ter problemas com o envio de mensagens.

    Obs: O endereço de resposta é alterado na guia Gerais do seu Receive Connector


    Jonathan Santos | http://jonathanrsantos.wordpress.com MCP | MCSA | MCSA Messaging | MCSE

    • Marcado como Resposta Antikilahdjs segunda-feira, 9 de abril de 2012 14:33
    sábado, 7 de abril de 2012 07:28
    Moderador
  • Você tem razão, não deixei correto, fiz alteração e agradeço pelo apoio... vou fazer os testes e agora creio que irá melhorar .....

    Abs;

    sábado, 7 de abril de 2012 18:39
  • Ola,

    Você pode fazer vários testes no seu e-mail do nos servidores de destino usando o www.mxtoolbox.com .

    No seu caso por exemil o IP do mail.mascarotour.com.br não possui reverso correto, o IP do mail2 possui. Talvez seja esse o motivo de os servidores de destino não estarem aceitando conexão do seu servidor.

    • Marcado como Resposta Antikilahdjs segunda-feira, 9 de abril de 2012 14:33
    sábado, 7 de abril de 2012 18:48
  • Quando tento mudar ele da erro...

    Sabe o que pode ser? hoje está o FQDN interno, para o Intra, nesse caso estou mudando para o publico que é o webmail.meudomain.com.br

    sábado, 7 de abril de 2012 18:51
  • Na guia Authentication desmarque "Exchange Server authentication".
    Esse tipo de autenticação é baseado no GSSAPI, ou seja inicialmente só serviria para comunicação entre servidores Exchange no seu ambiente. Como trata-se de um Connector para recebimento de mensagens publico, você pode desmarcar essa opção e tentar novamente.

     

    Jonathan Santos | http://jonathanrsantos.wordpress.com MCP | MCSA | MCSA Messaging | MCSE

    • Marcado como Resposta Antikilahdjs segunda-feira, 9 de abril de 2012 14:33
    sábado, 7 de abril de 2012 20:28
    Moderador
  • Perfeito Jonathan, muito obrigado, vou realizar os testes, mas eu tinha trocado a guia do Connector para o endereço publico, e já melhorou muito, o fluxo de saida agora está 100% melhor.... :)

    Abs;

    segunda-feira, 9 de abril de 2012 14:32