none
Excel - Tabela Dinâmica - Campo Calculado Condicional RRS feed

  • Pergunta

  • Gostaria de saber se é possível colocar uma condição em um campo calculado de uma tabela dinâmica.

    Tenho uma base de dados que tem uma coluna de valores e outra coluna que estabelece (R ou D) se aquela linha de dados contém uma Receita ou Despesa.

    Gostaria que o campo calculado me apresentasse o valor positivo caso a linha esteja com R ou valor negativo em caso de estar com D.

    Coloquei no campo calculado a seguinte fórmula, mas os valores estão saindo todos multiplicados por -1, ou seja, o Excel está considerando a condição como falsa sempre...

    =SE(R_D="R";Valor;Valor*-1)
    quarta-feira, 10 de maio de 2017 18:15

Respostas

  • Boa noite Gustavo.

    Desculpe a demora. Sobre sua dúvida, para que a fórmula seja automaticamente expandida é preciso que ela seja uma fórmula de coluna inteira (pelo menos inicialmente). Para fazer isto no seu caso, basta que edite alguma das fórmulas (qualquer uma), pressione Enter e clique no mini pop-up (fx) que aparece ao lado da célula e clique em "Substituir todas as ...". A partir daí o Excel entende que todas as linhas desta coluna devem possuir esta fórmula.

    Abraço.


    Filipe Magno

    • Marcado como Resposta Gustavo Cochlar sexta-feira, 19 de maio de 2017 13:03
    terça-feira, 16 de maio de 2017 21:55

Todas as Respostas

  • Gustavo,

    Já tentou fazer o teste lógico em uma planilha simples para ver se o comando está ok?

    =IF(A1="R";B2;B2*-1) esse teste funciona, fiz uma única alteração onde se lê =SE(R_D="R";Valor;Valor*-1) R_D na sua fórmula, mudei para a linha onde está o título R_D, no meu caso ficou na célula A1.

    coluna A ficou com R ou D; Coluna B com valores e coluna C com o resultado (positivo ou negativo);


    Marco Libretti – Achou útil a postagem? Marque e ajude a comunidade.

    quinta-feira, 11 de maio de 2017 13:40
  • Fazendo assim funciona, mas eu teria que colocar mais uma coluna na planilha de base de dados e o usuário teria que lembrar de ir copiando a fórmula para baixo sempre que fosse fazendo lançamentos.

    O objetivo de colocar o cálculo diretamente na tabela dinâmica é pular essa parte...

    Achei que haveria maneira de colocar campo calculado de forma condicional, mas não consigo fazer funcionar...

    sábado, 13 de maio de 2017 02:44
  • Gustavo, sobre sua afirmação: "e o usuário teria que lembrar de ir copiando a fórmula para baixo sempre que fosse fazendo lançamentos." lembro que utilizando "Tabelas" este passo é desnecessário, já que as fórmulas são expandidas automaticamente neste caso (assim como o intervalo de dados que a Tabela Dinâmica deve considerar). Desta forma você poderia, inclusive, tornar as colunas com as fórmulas ocultas, tornando a digitação mais simples.

    Abraço.


    Filipe Magno

    domingo, 14 de maio de 2017 17:57
  • Filipe,

    Talvez eu consiga resolver a situação usando Tabelas, então...

    Alterei o intervalo para que o Excel considere como Tabela e inseri algumas linhas. Tenho certeza que o Excel incluiu na tabela pois colocou as cores alternadas nas linhas. Só que não copiou as fórmulas para as linhas de baixo. Tem que ativar isso em algum lugar?

    Se quiseres dar uma olhada na planilha de exemplo, segue o link: https://www.dropbox.com/s/jwezr9qowezc5oi/Teste03%20-%20Copia.xlsx?dl=0

    segunda-feira, 15 de maio de 2017 18:48
  • Boa noite Gustavo.

    Desculpe a demora. Sobre sua dúvida, para que a fórmula seja automaticamente expandida é preciso que ela seja uma fórmula de coluna inteira (pelo menos inicialmente). Para fazer isto no seu caso, basta que edite alguma das fórmulas (qualquer uma), pressione Enter e clique no mini pop-up (fx) que aparece ao lado da célula e clique em "Substituir todas as ...". A partir daí o Excel entende que todas as linhas desta coluna devem possuir esta fórmula.

    Abraço.


    Filipe Magno

    • Marcado como Resposta Gustavo Cochlar sexta-feira, 19 de maio de 2017 13:03
    terça-feira, 16 de maio de 2017 21:55