none
Erro de Instalação do Sharepoint 2010 - Error 1937 RRS feed

  • Pergunta

  • Prezados amigos,

    Estou tentado efetuar a instalação do Sharepoint 2010 no Windows Server 2008 R2 x64, porém após verificação de todos os Pre-Requisitos inicio a instalação do Sharepoint 2010 Enterprise e é apresentada uma mensagem de erro informando que a instalação foi interrompida, "Error 1937. An error ocurred during the installation os assembly component {AF0FF537-7358-44c4-B379-CB66F9A32668}. HRESULT: 0X80131045".

    Procurando maiores informações no Event Viewer encontrei isso:

    Product: Microsoft SharePoint Foundation 2010 Core -- Error 1937. An error occurred during the installation of assembly component {AF0FF537-7358-44C4-B379-CB66F9A32668}. HRESULT: 0x80131045. assembly interface: IAssemblyCacheItem, function: Commit, assembly name: Microsoft.SharePoint.SetupConfiguration.Intl,version="14.0.0.0000000",processorArchitecture="MSIL",publicKeyToken="71E9BCE111E9429C",fileVersion="14.0.4762.1000",culture="neutral"

    Acho que já fiz e refiz tudo

    Um pouco antes de postar a pergunta iniciei o download do SP1 do Windows Server, porém ainda não instalei.
    Executei a instalação do SP1 e o erro ainda persiste!

    Depois de muito pensar e não chegar a lugar nenhum, resolvi formatar minha máquina Virtual e refaze-la, porém o mesmo problema ocorre.

    Lembrando que executei todas as atualizações disponíveis através do Windows Update e só depois executei a Verificação e Instalação dos Pre-Requisitos.

    Alguém tem algum procedimento que possa me ajudar????


    R O B E R T O H U M M E L Profissional Certificado pela Microsoft Assistência | Suporte | Consultoria em Tecnolofia da Informação

    • Editado Roberto Hummel quarta-feira, 30 de março de 2011 16:09 Novos Procedimentos
    terça-feira, 29 de março de 2011 20:00

Respostas

  • Larah,

    Até tentei verificar o Log, porém na pasta não existia nenhum arquivo.

    Hoje efetuei uma nova tentativa, e para minha surpresa a instalação executou normalmente!

    Agora fica a dúvida, o que pode ter causado o erro????

    COMO A INSTALAÇÃO FOI CONCLUÍDA ESTOU ENCERRANDO O TOPICO.


    R O B E R T O H U M M E L Profissional Certificado pela Microsoft Assistência | Suporte | Consultoria em Tecnolofia da Informação
    • Marcado como Resposta Roberto Hummel segunda-feira, 25 de abril de 2011 15:35
    segunda-feira, 25 de abril de 2011 15:35

Todas as Respostas

  • Roberto,

    Muito estranho isso estar acontecendo, nunca vi nada parecido.

    Se fosse comigo eu iria tentar o inverso, pegar uma máquina zerada, recém instalada com o Windows Server 2008 R2 e iria instalar o SharePoint. Só para ver o que aconteceria. Caso desse certo, iria atualizá-la.

    Outra opção seria arranjar outro instalador, vai que esse esteja corrompido.


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br
    quarta-feira, 30 de março de 2011 23:18
    Moderador
  • Fabian, Obrigado pela resposta, porém após muito tentar e ficar muito tempo pesquisando na net cheguei no Trabalho disposto a efetuar novo download da ISO. E no momento estou com 10% do Download. Referente a sua colocação de só após a instalação do Sharepoint atualizar o server com o SP1, eu também já havia tentado executar a instalação sem a atualização. Após terminar o download vou iniciar uma nova tentativa. Depois eu posto o resultado!
    R O B E R T O H U M M E L Profissional Certificado pela Microsoft Assistência | Suporte | Consultoria em Tecnolofia da Informação
    quinta-feira, 31 de março de 2011 12:43
  • Roberto,

    Assim que terminar nos avise o resultado.


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br
    quinta-feira, 31 de março de 2011 16:02
    Moderador
  • Fabian,

     

    Devido a outras várias ocorrências a nova instalação vai ficar para o final de Semana.

    Na segunda-feira se nada de errado ocorrer eu posto os resulttados.

     


    R O B E R T O H U M M E L Profissional Certificado pela Microsoft Assistência | Suporte | Consultoria em Tecnolofia da Informação
    sexta-feira, 1 de abril de 2011 12:13
  • E aí, fez?
    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br
    quarta-feira, 6 de abril de 2011 10:53
    Moderador
  • Fabian,

    Desculpa a demora, mais esta uma correria que até deixamos um pouco de lado o Sharepoint.

    Mas vamo lá, deixei de ir almoçar hoje para tentar fazer a instalação, detalhe com uma ISO nova.

    O problema ainda persite, e verificando o Log a mesma mensagem é apresentada.

    Product: Microsoft SharePoint Foundation 2010 Core -- Error 1937. An error occurred during the installation of assembly component {AF0FF537-7358-44C4-B379-CB66F9A32668}. HRESULT: 0x80131045. assembly interface: IAssemblyCacheItem, function: Commit, assembly name: Microsoft.SharePoint.SetupConfiguration.Intl,version="14.0.0.0000000",processorArchitecture="MSIL",publicKeyToken="71E9BCE111E9429C",
    fileVersion="14.0.4762.1000",culture="neutral"

    Sabe me dizer se existe alguma incompatibilidade em Relação a Virtualização do Sharepoint 2010, pois atualmente estou tentando configurar uma máquina virtual?

     


    R O B E R T O H U M M E L Profissional Certificado pela Microsoft Assistência | Suporte | Consultoria em Tecnolofia da Informação
    quinta-feira, 14 de abril de 2011 16:10
  • Oi Roberto,

    tentei procurar alguma informação sobre este erro, mas também não cheguei a nenhuma conclusão.

    Em relação a virtualização, não há nenhuma incompatibilidade em trabalhar com ambientes virtualizados. Eu tenho uma farm em cima do Hyper-v e nunca tive nenhum problema.

    Aconcelharia você a olhar o Log de erro do próprio SharePoint e não do Event do Windows. Lá pode ter mais informações específicas do SharePoint.

     


    Espero ter ajudado.
    Ajude manter o fórum organizado, se útil classifique!

    __________________________________________________________

    Larah Vidotti
    - MCTS > Sharepoint 2007 & 2010 Specialist
    - MCTS > Windows Server Virtualization
    - MCP > Windows server 2003
    - Blog
    - Twitter
    quinta-feira, 14 de abril de 2011 19:59
  • Larah,

    Até tentei verificar o Log, porém na pasta não existia nenhum arquivo.

    Hoje efetuei uma nova tentativa, e para minha surpresa a instalação executou normalmente!

    Agora fica a dúvida, o que pode ter causado o erro????

    COMO A INSTALAÇÃO FOI CONCLUÍDA ESTOU ENCERRANDO O TOPICO.


    R O B E R T O H U M M E L Profissional Certificado pela Microsoft Assistência | Suporte | Consultoria em Tecnolofia da Informação
    • Marcado como Resposta Roberto Hummel segunda-feira, 25 de abril de 2011 15:35
    segunda-feira, 25 de abril de 2011 15:35
  • Pessoal,

    Estamos passando por um erro muito semelhante. Estamos obedecendo todos os pré-requisitos de instalação em uma VM no VMware 4.1 e a anomalia está ocorrendo da mesma forma. O que eu entendi da mensagem de erro, é que o problema está localizado no Assembly do Sharepoint 2010 que não consegue ser devidamente compilado durante a instalação gerando este erro 1937. Já tentei pesquisar sobre o problema como o nosso amigo do post realizou, mas nada de concreto e que possa dar alguma luz é encontrado.

    Estamos tentando neste momento realizar uma nova instalação. Estamos seguindo uma documentação, mas gostaria de obter outras que fossem mais completas e até mesmo certificadas por um MVP ou que tenham contemplado a instalação de quem as utilizou com sucesso.

    Grato à todos.

    OBS e RESPOSTA COM SOLUÇÃO PARA O PROBLEMA

    Bom, pesquisando mais sobre este erro, dificilmente encontrei mais informações sobre o motivo deste erro. A instalação gera o erro 1937 devido ao fato da linguagem do Sharepoint Server 2010 não ser a mesma suportada pelo Windows Server 2008. Erroneamente baixamos a mídia da versão Português de Portugal, onde o erro ocorre intermitentemente. Ao baixar a instalação Português Brasil, os problemas terminaram por completo.


    Artur de Souza Aragão - Analista TI Pleno

    quinta-feira, 5 de maio de 2011 13:23