locked
Problema servidor DNS RRS feed

  • Pergunta

  • Ola pessoal, estou com um problema no meu servidor, é o seguinte:


    Em um determinado dia minhas estações amanheceram sem conexão com a internet, entrei no servidor e comecei a tentar identificar o problema, ate que configurei encaminhadores no DNS, como o dns publico do google 8.8.8.8, e o problema foi solucionado. Mas desde então estou tendo muita oscilação na navegação, os sites demoram abrir, fica resolvendo host e alguns dão time out ocorrendo o erro abaixo, depois de recarregar a pagina alguns acabam funcionando. Já no servidor, onde o cabo do modem é conectado direto esse problema não ocorre. As vezes acontece de ter que entrar no site primeiro no servidor e depois nas estações para que funcione (provavelmente é o cache em ação, o site é resolvido no servidor, armazenado e dai consegue conectar nas estações). Liguei no provedor para saber se pode ser algum problema deles, o rapaz disse que houve uma manutenção na rede e me pediu para testar configurando o dns do Google direto no modem, substituindo o dns do provedor, mas isso também não resolveu, também creio que não seja problema no provedor pois no servidor os sites se conectam normalmente, o problema esta nas estações.

    Ao inciar o nslookup as vezes acontece esse erro:

    

    Minha estrutura do servidor é da seguinte forma:

    Internet chega do modem e um cabo vai para o servidor (DNS+DHCP+AD+RRAS) que contem duas placas de rede, uma rede externa, onde vai esse cabo do modem e uma rede interna, que é plugada no switch, distribuindo para as demais estações através do serviço de roteamento e acesso remoto do Windows Server. E eu não possuo proxy.

    Ja tentei:

    Reiniciar o PC do servidor.

    Reiniciar o servidor DNS.

    Limpar o cache do DNS.

    Usar o comando ipconfig /flushdns.

    Ainda sem solução.

    Obrigado.

    ----

    Atualização:

    Ao executar o comando apresenta erros:

    C:\Users\Administrador>dcdiag /test:DNS /dnsforwarders

    Diagnóstico do Servidor de Diretório

    Executando instalação inicial:
       Tentando localizar o servidor local...
       Servidor Local = servidor
       * Floresta AD identificada.
       Coleta de informações iniciais concluída.

    Executando os testes iniciais necessários

       Testando o servidor: Default-First-Site-Name\SERVIDOR
          Iniciando teste: Connectivity
             ......................... SERVIDOR passou no teste Connectivity

    Executando os testes principais

       Testando o servidor: Default-First-Site-Name\SERVIDOR

          Iniciando teste: DNS

             Testes de DNS estão em execução e não em suspensão. Aguarde alguns
             minutos...
             ......................... SERVIDOR passou no teste DNS

       Executando testes de partição em : ForestDnsZones

       Executando testes de partição em : DomainDnsZones

       Executando testes de partição em : Schema

       Executando testes de partição em : Configuration

       Executando testes de partição em : redeleao

       Executando testes de empresa em : redeleao.com
          Iniciando teste: DNS
             Resultados de testes de controladores de domínio:

                Controlador de domínio: servidor.redeleao.com
                Domínio: redeleao.com


                   TEST: Basic (Basc)
                      Aviso: O adaptador 00:15:5D:00:68:01 tem um endereço IP
                      dinâmico (possível erro de configuração)
                      Aviso: O adaptador
                      [00000020] Adaptador de Rede Microsoft Hyper-V tem um
                      servidor DNS inválido: 192.168.0.100 (<name unavailable>)
                      Aviso: O adaptador
                      [00000020] Adaptador de Rede Microsoft Hyper-V tem um
                      servidor DNS inválido: 0.0.0.0 (SERVIDOR)

             Resumo de resultados de testes de servidores DNS usados pelos
             controladores de domínio acima:

                Servidor DNS: 0.0.0.0 (SERVIDOR)
                   Falha de teste 1 neste servidor DNS
                   PTR record query for the 1.0.0.127.in-addr.arpa. failed on the DN
    S server 0.0.0.0               Name resolution is not functional. _ldap._tcp.red
    eleao.com. failed on the DNS server 0.0.0.0

                Servidor DNS: 192.168.0.100 (<name unavailable>)
                   Falha de teste 1 neste servidor DNS
                   Name resolution is not functional. _ldap._tcp.redeleao.com. faile
    d on the DNS server 192.168.0.100

                   servidor                     PASS WARN PASS n/a  n/a  n/a  n/a
             ......................... redeleao.com passou no teste DNS



    • Editado Rafao13 quinta-feira, 28 de setembro de 2017 14:58 Atualização
    quinta-feira, 28 de setembro de 2017 14:01

Todas as Respostas

  • Já tentou outro dns público como o 208.67.222.222?

    A guia usar root hints ta marcada?

    Quem faz o compartilhamento da internet? porque o modem fica ligado direto no servidor?


    MVP - Daniel Santos Blog: www.engdanielsantos.wordpress.com Twitter: @danielsantos_ti

    quinta-feira, 28 de setembro de 2017 14:27
  • Ola Daniel, já tentei usar vários DNS públicos nos encaminhadores, mas não funciona, continua com a oscilação nas estações.

    A pergunta do root hints seria ali na guia Encaminhadores se a opção "Usar dicas de raiz se encaminhadores não estiverem disponíveis'' esta marcada ? Se for isso, sim esta marcada.

    O compartilhamento é através do RRAS por isso o servidor recebe o cabo do modem para o roteamento nas estações.

    Obrigado.

    Atualizei o tópico com um teste de dns que fiz.


    • Editado Rafao13 quinta-feira, 28 de setembro de 2017 15:23
    quinta-feira, 28 de setembro de 2017 15:22
  • Porque não compartilha a internet via hardware (roteador / firewall)?



    MVP - Daniel Santos Blog: www.engdanielsantos.wordpress.com Twitter: @danielsantos_ti


    quinta-feira, 28 de setembro de 2017 15:37
  • Segue:

    Olha o que descobri: Se eu for nas estações e alterar a configuração do adaptador de rede para ao invés de buscar o DNS automaticamente a configuração:

    DNS Preferencial: 192.168.1.100 (IP do servidor)

    Dns Alternativo: 8.8.8.8 (IP DNS publico do Google)

    As oscilações param de ocorrer e a navegação da internet fica normal, mas isso seria uma gambiarra, o problema mesmo não é solucionado.

    quinta-feira, 28 de setembro de 2017 15:44
  • Como funcionaria no caso das estações conectarem tanto no roteador (rede externa) quanto no servidor (rede interna) ? Precisa ter duas placas de rede em cada estação ?

    Não pensei nessa alternativa depois de conhecer o RRAS, antigamente era feito mesmo pelo roteador, mas cada estação precisava ter duas placas, uma apontando para o IP do servidor e se conectar na rede interna e uma para o roteador para se conectar na rede externa, internet.

     
    quinta-feira, 28 de setembro de 2017 15:47
  • Não tem necessidade disso.

    Basta configurar o seu roteador na mesma faixa de rede da sua rede interna.


    MVP - Daniel Santos Blog: www.engdanielsantos.wordpress.com Twitter: @danielsantos_ti

    quinta-feira, 28 de setembro de 2017 16:24
  • Beleza, vamos la:

    alterei o adaptador externo conforme disse, coloquei o ip fixo, o gateway (ip do roteador) e deixei o dns em branco, mas apresentou essa mensagem:

    O ícone do adaptador ficou com um ponto de exclamação com o status Limitado, mas não perdeu a conexão com a internet.

    ##############################

    O adaptador interno ja estava acima do externo nas configurações avançadas de rede

    ##############################

    Realmente nas configs do DNS estava marcado os dois adaptadores, desmarquei o externo

    Sobre os encaminhadores, é correto a utilização deles ? Ou deveria funcionar sem eles estarem configurados ? Pois lembro que antes  de todo esse problema não tinha configurado nada e funcionava tudo normal.

    ##############################

    Nos clientes o gateway já esta o RRAS, conforme configurado no DHCP , agora sobre o DNS esta o ip do servidor, 192.168.1.100 nas estações e não 192.168.0.102. Qual devo configurar nas estações? O correto seria o IP do servidor mesmo , para não dar problemas com a resolução de nomes no domínio, não?! 

    ##############################

    Talvez eu poderia configurar conforme o Daniel disse, mas tenho algumas duvidas, seria apenas trocar o IP do roteador para a mesma faixa de IP do servidor, e conectar o roteador no switch da rede interna, assim deveria desabilitar o RRAS no servidor, mas e o DHCP e DNS teria que modificar alguma configuração ? Teria que desabilitar o DHCP do roteador certo?

    quinta-feira, 28 de setembro de 2017 16:56
  • Correto, amanhã colocarei o IP do roteador na mesma faixa de IP da rede interna, vou adicionar a reserva dele no DHCP e desativar o serviço RRAS.

    Algumas dúvidas sobre esse procedimento:

    - É necessário desabilitar o DHCP no roteador certo? Já que o servidor DHCP do Windows fará a função.

    - O firewall será o próprio roteador, já que a conexão não passar mais pelo Windows? Isso não diminui a segurança da estrutura?

    - o Gateway e o DNS configurados no DHCP ainda será o IP do servidor Windows ou do roteador?

    Se puderem me ajudar nessa implantação agradeço muito.

    Obrigado.

    sexta-feira, 29 de setembro de 2017 00:26