none
IIS 7.5 não atualiza quando modifica arquivo PHP RRS feed

  • Pergunta

  • Pessoal,
    Estou com um problema ...
    Para utilizar o PHP no IIS 7.5 do windows 7, instalei o Microsoft Web Plataform.
    Tudo instalou beleza e executa as páginas normalmente.
    O problema é quando altero o arquivo PHP e vou no navegador executar a página. A página não atualiza, é necessário um tempo e vários refresh para que a modificação feita apareça.
    Isso ocorre tanto no IE8 e no Firefox 3.6.
    O PHP é versão 5.2.12.
    quarta-feira, 3 de fevereiro de 2010 12:06

Respostas

  • Colega,

    1) no browser dê CTRL+F5 na url .

    2) Se nao funcionar, faz o recycle do app pool

    3) se nao funfar, stop/start.



    --

    Se funfar:

    1) é cache do seu browser

    2 e 3) configure o caching no properties do seu virtual directory


    Igor Monteiro - http://igormv.spaces.live.com/ - Office Communications 2007, Sharepoint, Exchange
    • Marcado como Resposta pabloce terça-feira, 2 de março de 2010 16:57
    sexta-feira, 5 de fevereiro de 2010 16:16
  • Removeu também o MySql? O MySql é muito problemático, quando você remove e instala novamente, ocorre diversos problemas.
    Pablo Weyne - http://www.iishelp.com.br - @pabloweyne
    • Marcado como Resposta pabloce terça-feira, 2 de março de 2010 16:57
    quinta-feira, 11 de fevereiro de 2010 20:10

Todas as Respostas

  • Diego,

    A atualização é para ser feita na hora. Não seria cache do seu browser? Já tentou acessar remotamente?
    Pablo Weyne - http://www.iishelp.com.br
    quarta-feira, 3 de fevereiro de 2010 12:50
  • Acredito que não seja o cache, pois acontece em todos navegadores.
    Antes de fazer o upgrade para o windows 7 (utilizava o vista) funcionava normalmente, porém o PHP funcionava no IIS com a configuração do IIS feita no braço, sem ser em fastcgi.
    Remotamente testei e funciona normalmente, não é necessário fechar o browser e ficar atualizando a pagina.
    quarta-feira, 3 de fevereiro de 2010 13:41
  • Remotamente funciona, mas localmente não? Limpou tudo dos browsers?
    Pablo Weyne - http://www.iishelp.com.br
    quarta-feira, 3 de fevereiro de 2010 13:45
  • Sim.
    No servidor remoto cada alteração que faço já atualiza a pagina (servidor remoto é apache). No IIS local demora para as modificações serem mostradas.
    Mesmo limpando cache e etc e em qualquer navegador, por isso estou achando que pode ser alguma configuração do meu IIS, mesmo que as configurações tenham sido feitas pelo microsoft web plataform installer.
    quarta-feira, 3 de fevereiro de 2010 15:41
  • É, realmente nunca vi isso. Só cache mesmo no servidor. Sou responsável por dezenas de servidores Web, inclusive alguns tenho o Web Platform e isso não ocorre.
    Pablo Weyne - http://www.iishelp.com.br
    quinta-feira, 4 de fevereiro de 2010 20:51
  • E há alguma fora de modificar configurações  da cache do servidor ???
    sexta-feira, 5 de fevereiro de 2010 11:29
  • Colega,

    1) no browser dê CTRL+F5 na url .

    2) Se nao funcionar, faz o recycle do app pool

    3) se nao funfar, stop/start.



    --

    Se funfar:

    1) é cache do seu browser

    2 e 3) configure o caching no properties do seu virtual directory


    Igor Monteiro - http://igormv.spaces.live.com/ - Office Communications 2007, Sharepoint, Exchange
    • Marcado como Resposta pabloce terça-feira, 2 de março de 2010 16:57
    sexta-feira, 5 de fevereiro de 2010 16:16
  • Faça o que o Igor sugeriu. Também tenta limpar o cache do Browser.


    Pablo Weyne - http://www.iishelp.com.br - @pabloweyne
    sexta-feira, 5 de fevereiro de 2010 17:02
  • Fiz os procedimentos mas não resolveu.
    Aí desinstalei tudo que tinha do Web Plataform, exlcui arquivos de configuração, temporários e etc...
    Reinstalei e funcionou.
    Porém desta vez o mysql não conecta mais. :S
    Dá o erro Call to undefined function mysql_connect().

    quinta-feira, 11 de fevereiro de 2010 19:35
  • Removeu também o MySql? O MySql é muito problemático, quando você remove e instala novamente, ocorre diversos problemas.
    Pablo Weyne - http://www.iishelp.com.br - @pabloweyne
    • Marcado como Resposta pabloce terça-feira, 2 de março de 2010 16:57
    quinta-feira, 11 de fevereiro de 2010 20:10