none
Fórmula para contar números ímpares e pares RRS feed

  • Pergunta

  • Bom dia,

    Digamos que tenho um LINHA NO Excel 2010 da seguinte forma:

    A1 B1 C1 D1 E1

    1 2 3 4 5

    Qual fórmula devo usar para que tenha o resultado da quantidade de números ímpares em G1 e pares em H1 desta linha?

    Obrigado


    • Editado Marco_AM terça-feira, 31 de julho de 2012 13:04 Correção
    terça-feira, 31 de julho de 2012 12:50

Respostas

  • Obrigado pela resposta Hezequias, mas já consegui sem utilizar linhas auxiliares.

    Ímpares com resultado na célula G1 >>> =SOMARPRODUTO(MOD($A1:$E1;2))

    Pares com resultado na célula H1 >>> =CONT.VALORES($A1:$E1)-$G1

    Valeu

    • Marcado como Resposta Marco_AM terça-feira, 31 de julho de 2012 18:19
    terça-feira, 31 de julho de 2012 18:19

Todas as Respostas

  • Olá Marco, boa tarde.

    Você vai precisar de uma linha auxiliar para testar se o número é impar ou par utilizando a função MOD dividido por 2. Se o resultado for um - "1" é falso, se o resultado for zero - "0" é verdadeiro.

    Depois utilize a função Cont.se para contar os valores zeros que são os números pares e os números um que são os valores impares.

    Exemplo:

    Espero ter ajudado.


    Hezequias Vasconcelos

    terça-feira, 31 de julho de 2012 17:07
    Moderador
  • Obrigado pela resposta Hezequias, mas já consegui sem utilizar linhas auxiliares.

    Ímpares com resultado na célula G1 >>> =SOMARPRODUTO(MOD($A1:$E1;2))

    Pares com resultado na célula H1 >>> =CONT.VALORES($A1:$E1)-$G1

    Valeu

    • Marcado como Resposta Marco_AM terça-feira, 31 de julho de 2012 18:19
    terça-feira, 31 de julho de 2012 18:19
  • Obrigado pela resposta Hezequias, mas já consegui sem utilizar linhas auxiliares.

    Ímpares com resultado na célula G1 >>> =SOMARPRODUTO(MOD($A1:$E1;2))

    Pares com resultado na célula H1 >>> =CONT.VALORES($A1:$E1)-$G1

    Valeu

    Se eu quiser manter a formula  para cada linha independente, incrementando o numero da linha?

    segunda-feira, 16 de setembro de 2019 15:55