none
Busca por Intersecção RRS feed

  • Pergunta

  • Bom dia, 

    Que formula utilizo para receber valores variáveis (ex: 2 valores) e utilizar estes valores como pesquisa em coluna x linha para encontra valores em uma matriz.

    Ex: Uma tabuada em forma de matriz, onde eu recebo um valor A (EX: 4) e um valor B (EX: 5) e tenho que encontrar o valor X dentro da matriz (Nesse caso do Exemplo, o valor 20).

    terça-feira, 23 de abril de 2019 14:42

Todas as Respostas

  • Boa tarde Ricardo.

    Se eu entendi bem a sua pergunta, você poderia utilizar o índice onde, dependendo de como a sua matriz estivesse disposta, o valor 4 poderia ser a sua coluna ou linha assim como o valor 5, retornando o valor 20. Ex.:

    =ÍNDICE(A21:D26;5;4) na matriz com 4 colunas ou =ÍNDICE(A21:D26;4;5) na matriz com 5 colunas...

    terça-feira, 23 de abril de 2019 17:57
  • Então, eu precisava que recebesse valores variáveis, mas acabei que consegui resolver aqui usando uma tabela a mais e 2 PROCV's.

    =PROCV(T7;A2:L19;PROCV(T6;B23:C33;2;FALSO);FALSO)

    Transformei as minhas opções da linha 1 (que são números fracionados), em números inteiros (nas células B23:C33), e utilizei o resultado desse PROCV de numero de Índice no PROCV da matriz principal.

    Preciso apenas fazer as tratativa de erros agora. 

    Mas de qualquer forma muito obrigado!

    terça-feira, 23 de abril de 2019 18:35