locked
Problema com Sysprep no Windows XP RRS feed

  • Pergunta

  • Pessoal, estou com um problema em criar imagens pelo sysprep, tenho estações com XPSP3 e um server WDS na rede.

    Quando executo o sysprep no computador-referência, marco o modo minisetup e lacro novamente, e a opção desligar é escolhida.

    Após isto eu carrego a imagem para o server WDS e tudo certo, mas quando baixo a mesma imagem no computador que foi criada, o windows não consegue inicializar, a barra do XP fica passando lentamente, o hd não dá sinais de atividade e fica por ali, sem fazer nada!!

    Alguém pode me dizer o que poderia ser isso? Pode ser algum programa que estou instalando na imagem?

    Att

    Luis

    sexta-feira, 30 de julho de 2010 01:05

Respostas

  • Boa noite!

     

    Como eu havia mencionado na pergunta, a imagem era instalada no mesmo computador que fora criada anteriormente, não haveria problema algum relacionado a camada de abstração de hardware (hal.dll).

    Mas encontrei o problema, ele estava em um plugin de um banco que estava sendo instaldo nesta imagem, e como ele deve estar atrelado ao SID da instalação do Windows, quando era gerado uma nova com o Sysprep ele encontrava algum problema e travava a inicialização do sistema.

     

    Obrigado!

     

    Luis Fernando Bissani


    Luis Bissani Infraestrutura de TI
    domingo, 8 de agosto de 2010 23:17

Todas as Respostas

  • Luis


    Esse seu problema não está relacionado ao sysprep.
    Pelo que tenho de esperiencia com isso, você provavelmente está tentando instalar essa imagem em um maquina diferente.
    Com o hardware ou pelo menos um dos hardwares diferentes.

    Existe uma dll dentro do sistema operacional chamada hal.dll ela faz idicação para todos os drivers do sistema operacional
    Para subir um imagem em uma maquina diferente você tem que alterar essa dll para uma em branco, mas isso você so consegue
    fazer depois da imagem criada, você precisa de um sistema que permita alterar a imagem.

    No caso do ghost ele tinha uma ferramenta que permitia fazer isso, com o WDS não conheço.

    A hal.dll você consegue encontrar na internet uma vazia.

     

    Raphael Carvalho Cardoso

    quinta-feira, 5 de agosto de 2010 20:41
  • Boa noite!

     

    Como eu havia mencionado na pergunta, a imagem era instalada no mesmo computador que fora criada anteriormente, não haveria problema algum relacionado a camada de abstração de hardware (hal.dll).

    Mas encontrei o problema, ele estava em um plugin de um banco que estava sendo instaldo nesta imagem, e como ele deve estar atrelado ao SID da instalação do Windows, quando era gerado uma nova com o Sysprep ele encontrava algum problema e travava a inicialização do sistema.

     

    Obrigado!

     

    Luis Fernando Bissani


    Luis Bissani Infraestrutura de TI
    domingo, 8 de agosto de 2010 23:17