locked
Erro para salvar arquivos. RRS feed

  • Pergunta

  • Olá pessoal, bom dia!

    De uns tempos (dias) pra cá, um cliente vem reclamando constantemente que o file server está gerando erros ao salvar arquivos.

    Eu presenciei o erro na workstation de um usuário, ele tentou salvar um PDF (anexo de e-mail) na rede e recebeu a mensagem de erro, verifiquei o caminho de gravação e o arquivo foi criado só que com tamanho zero (0), ou seja, não salvou.

    Se o usuário fica insistindo, clicando um salvar, em determinado momento acaba salvando.

    Já verifiquei os logs e não consta nada, os erros acontecem de forma aleatória (com usuários diferentes) e com diversas extensões de arquivos, acontece com muita frequencia arquivos de AutoCad, mas já aconteceu com XLS, PDF, DOC etc...

    Enfim, já perdi horas e não consegui descobrir nada, alguém tem alguma dica ?, já passou por isso ?.

    Abraços,

     


    José Gomes

    quarta-feira, 26 de agosto de 2015 14:28

Respostas

  • José,

    Rode um Check Disk nesta partição para ver se não existe erros e no discos que são compostos pelo Raid.



    Espero ter ajudado. Obrigado. Se a resposta for útil “Marcar como Resposta” para que os demais vejam para ajudar quem contribui com o Fórum Clique em “Votar”. Jefferson Castilho – MCT | MS | MCTIP | MCTS | MCPS | MPN

    sexta-feira, 28 de agosto de 2015 16:38

Todas as Respostas

  • Olá,

    Isso me parece com algum problema com o disco, já chegou a verificar se está gerando algum evento no log de eventos (SYSTEM)?

    Os problemas que eu já tive com file server quando tentava salvar por exemplo, eram causados por bad blocks.


    Maykon

    quarta-feira, 26 de agosto de 2015 14:58
  • Maykon,

    Já verifiquei os discos estão com "saúde" boa, este servidor é relativamente novo, instalei ele em Outubro de 2014 e ele tem 4 Discos de 1TB em Raid 5 com controladora PERC.

    Sobre eventos, no System não tenho absolutamente nenhum erro.

    Abs,


    José Gomes

    quarta-feira, 26 de agosto de 2015 16:03
  • Jose, Boa Tarde

    Passa mais detalhes como SO da Workstation, se esta no domínio e se a rede é cabo ou wifi.

    quarta-feira, 26 de agosto de 2015 17:00
  • André,

    Falha minha, mas não é SO, pois aconteceu com Windows 7 x86, Windows 7 x64 ambas no domínio, aconteceu com um Notebook Windows 7x86 fora do domínio.

    Com Windows 8 e 8.1 ainda não tive relatos.

    A rede é cabeada e é Gigabit, o Switch é um DELL Gigabit gerenciável de 48 portas, os servidores estão ligados nele via fibra ótica.

    Abraços,


    José Gomes

    quarta-feira, 26 de agosto de 2015 17:13
  • José,

    Rode um Check Disk nesta partição para ver se não existe erros e no discos que são compostos pelo Raid.



    Espero ter ajudado. Obrigado. Se a resposta for útil “Marcar como Resposta” para que os demais vejam para ajudar quem contribui com o Fórum Clique em “Votar”. Jefferson Castilho – MCT | MS | MCTIP | MCTS | MCPS | MPN

    sexta-feira, 28 de agosto de 2015 16:38
  • Prezados, boa tarde.

    Verifique as configurações de segurança dessa pasta específica.

    Na guia avançado verifique o grupo em que esse usuário está e veja as permissões que ele possui. Aparentemente ele está sem permissão para modificação e com algum conflito na permissão de gravar:

    sexta-feira, 28 de agosto de 2015 17:37
  • José,

    Rode um Check Disk nesta partição para ver se não existe erros e no discos que são compostos pelo Raid.



    Espero ter ajudado. Obrigado. Se a resposta for útil “Marcar como Resposta” para que os demais vejam para ajudar quem contribui com o Fórum Clique em “Votar”. Jefferson Castilho – MCT | MS | MCTIP | MCTS | MCPS | MPN

    Jefferson,

    Passei o diag de disco e nenhum erro foi encontrado.


    José Gomes

    sexta-feira, 28 de agosto de 2015 19:39
  • Fernando,

    Não é permissão, as permissões está configurada por Grupo e este possuí permissão de Modify, ou seja, consegue ler, gravar, excluir e modificar.

    E também posso afirmar que não é permissão, porque elas não foram modificadas, estão da mesma forma de que quando implantei o server em 2014, e só este mês começou o problema, e também se o usuário ficar clicando em Salvar varias vezes (as vezes precisa clicar até 6 vezes, imagina o stress do usuário), ele acaba salvando o arquivo.

    Abraços,


    José Gomes

    sexta-feira, 28 de agosto de 2015 19:42
  • Bom dia José.

    Você utiliza algum RAID nesse disco ?

    Att,

    Fernando Pessoa

    sábado, 29 de agosto de 2015 15:07