locked
VPN no SBS2003 RRS feed

  • Pergunta

  •  

    Olá!

    Estou querendo permitir conexão VPN ao meu SBS, porém não é ele que tem o IP público. Utilizo um linux que fica com o ip público. Que portas precisam ser redirecionadas para o SBS no linux para que o usuário possa se autenticar?

    domingo, 20 de agosto de 2006 14:50

Respostas

  • Oi Sandro,

    é a porta 1723.

    domingo, 20 de agosto de 2006 15:48
  • Oi Sandro,

    vamos lá. O teu SBS está com o SP1 do W2003, certo?

    Abra Control Panel->Add/Remove Programs.
    Clique em "Windows Small Business Server 2003" e clique em "Change/Remove"
    Siga as solicitações do setup até chegar na tela "Component Selection"
    Nas ações de "Server Tools", mude ela para "Maintenance"
    Então, para a ação de "Client Deployment", altere ela para "Reinstall"
    Complete o setup wizard - os CD's ou DVD do SBS  podem ser solicitados.

     

    terça-feira, 22 de agosto de 2006 16:37
  • Sandro,

    apenas para descargo de consciência, faça o seguinte:

    No Servidor SBS, clique em Start, então em Run, digite regedit e clique em OK.

    Navegue até HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SmallBusinessServer

    Verifique o valor em "ServicePackNumber"

    É "1"? Se não for, então você precisa aplicar o SBS 2003 SP1.

    Para que ele seja completamente aplicado, você precisa instalar todas 5 atualizações listadas abaixo. Adicionalmente, elas precisam ser instaladas na sequência listada.

    Caso algum destes componentes já esteja instalado, você pode passar para o próximo.

    A. Service Pack 1 for the Windows Server 2003 operating system
    B. Windows SharePoint Services 2.0 Service Pack 1
    C. Exchange Server 2003 Service Pack 1
    E. Windows XP SP2 for Client Deployment
    F. Windows Small Business Server 2003 Service Pack 1

    terça-feira, 22 de agosto de 2006 16:49
  • Caro Sandro,

    esta chave é padrão do SBS, portanto se não tens ele, isto indica que não instalou o item F, mesmo.

    Aqui você faz o download dos arquivos:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=b6f8a4c0-b707-4161-adeb-44f1b756119f&DisplayLang=en

    Por acaso você moveu a pasta de programas de clientes para um local diferente do padrão? Caso afirmativo:

    http://support.microsoft.com/?id=830254

     

     

     

    terça-feira, 22 de agosto de 2006 22:10
  • Olá Sandro,
     
    Veja esse link que acho que vai te ajudar.
     
     
    Sds,
     
    Daniel C. Santos
    sexta-feira, 25 de agosto de 2006 00:23
    Moderador

Todas as Respostas

  • Oi Sandro,

    é a porta 1723.

    domingo, 20 de agosto de 2006 15:48
  •  

    Então...

    ainda não consegui fazer a coisa funcionar... alguém pode me ajudar???

    no linux acrescentei este comando:

    iptables -A FORWARD -d 192.168.16.2 -p tcp --dport 1723

    Só que, quando tento fazer a conexão, recebo a mensagem:

    Erro 800: Não é possível estabelecer a conexão VPN. O servidor VPN pode estar inalcançável...

    Isso acontece qualquer que seja a conta que tento me logar.

    Sandro.

    terça-feira, 22 de agosto de 2006 11:45
  •  

    Rodei o Assistente de Conexão Remota no SBS2003, mas ele deu erro no final e, no log, as últimas linhãs são:

    Updating CMP template returned OK
    Updating CMS template returned OK
    Updating SED template returned OK
    Creating proxy configuration file returned OK
    *** Running IExpress to build the package returned ERROR 80004005
    *** ERROR: Cannot delete temp directory CMP5C.tmp
    Specifying error location (in CMAK) returned OK
    *** CRRASCommit::CommitCMAK returned ERROR 80004005
    *** CRRASCommit::CommitEx returned ERROR 80004005

     

    Qual é o problema? E como corrigir?

    terça-feira, 22 de agosto de 2006 12:29
  • Oi Sandro,

    vamos lá. O teu SBS está com o SP1 do W2003, certo?

    Abra Control Panel->Add/Remove Programs.
    Clique em "Windows Small Business Server 2003" e clique em "Change/Remove"
    Siga as solicitações do setup até chegar na tela "Component Selection"
    Nas ações de "Server Tools", mude ela para "Maintenance"
    Então, para a ação de "Client Deployment", altere ela para "Reinstall"
    Complete o setup wizard - os CD's ou DVD do SBS  podem ser solicitados.

     

    terça-feira, 22 de agosto de 2006 16:37
  • Sandro,

    apenas para descargo de consciência, faça o seguinte:

    No Servidor SBS, clique em Start, então em Run, digite regedit e clique em OK.

    Navegue até HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SmallBusinessServer

    Verifique o valor em "ServicePackNumber"

    É "1"? Se não for, então você precisa aplicar o SBS 2003 SP1.

    Para que ele seja completamente aplicado, você precisa instalar todas 5 atualizações listadas abaixo. Adicionalmente, elas precisam ser instaladas na sequência listada.

    Caso algum destes componentes já esteja instalado, você pode passar para o próximo.

    A. Service Pack 1 for the Windows Server 2003 operating system
    B. Windows SharePoint Services 2.0 Service Pack 1
    C. Exchange Server 2003 Service Pack 1
    E. Windows XP SP2 for Client Deployment
    F. Windows Small Business Server 2003 Service Pack 1

    terça-feira, 22 de agosto de 2006 16:49
  •  

    Carlos,

    valeu pela dica, mas não encontrei esta chave no meu SBS, porém nas propriedades do Meu Computador menciona o Service Pack 1.

    pelo que me lembro eu apliquei o SP1 sim, via WSUS. Será que algo não ficou como deveria?

    Como verifico se os componentes que você mencionou estão presentes?

    Pelo que vi, parece que os A, B e C foram feitos, mas não sei verificar o E, e parece que o faltante seja o F.

    terça-feira, 22 de agosto de 2006 17:55
  • Caro Sandro,

    esta chave é padrão do SBS, portanto se não tens ele, isto indica que não instalou o item F, mesmo.

    Aqui você faz o download dos arquivos:

    http://www.microsoft.com/downloads/details.aspx?FamilyID=b6f8a4c0-b707-4161-adeb-44f1b756119f&DisplayLang=en

    Por acaso você moveu a pasta de programas de clientes para um local diferente do padrão? Caso afirmativo:

    http://support.microsoft.com/?id=830254

     

     

     

    terça-feira, 22 de agosto de 2006 22:10
  • Olá Sandro,

    Fiz uma implementação num cliente e configurei VPN sendo que o firewall tb era Linux.

    Para tanto, tive que que encaminhar os pacotes para as portas:

    TCP 1723
    UDP 1701

    Feito isso foi resolvido o problema.

    qq dúvida posta aqui novamente.

    Daniel C. Santos

    Sds,

     

     

     

     

    quarta-feira, 23 de agosto de 2006 22:18
    Moderador
  • Oi Sandro,

    então conseguiu resolver?

    quinta-feira, 24 de agosto de 2006 04:39
  •  

    Daniel, acho que deve ser por aí... só não sei fazer.. eheheh

    Carlos, não!

     

    Bom, vamos lá, desde o começo:

    - meu SBS 2003 está atualizadinho e já rodei com êxito o assistente de conexão remota marcando a VPN.
    - também criei um usuário com perfil Remote User (acho que é isso, aquele User+VPN)
    - os ips do SBS são:  192.168.16.2 (para a rede interna) e 192.168.0.101 (para a conexão com o linux)
    - os ips do linux são:  192.168.0.100 (para a conexão com o SBS/rede interna) e 200.x.x.x (o ip público)

    No linux as regras iptables que aplico são:

    echo  1  >/proc/sys/net/ipv4/ip_forward
    /sbin/modprobe  iptable_nat
    /usr/sbin/iptables  -t  nat  -P  POSTROUTING  DROP
    /usr/sbin/iptables  -t  nat  -A  POSTROUTING  -o  eth0  -j  SNAT  --to  200.x.x.x

    eu tentei fazer o forward assim:

    iptables -A FORWARD -d 192.168.16.2 -p tcp --dport 1723

    Bom... o que está faltando?

    Sandro

    ---------------------------------------------------------------------------
    Eu hei de conseguir, tenho certeza disso... ehehe

    quinta-feira, 24 de agosto de 2006 22:20
  • Olá Sandro,
     
    Veja esse link que acho que vai te ajudar.
     
     
    Sds,
     
    Daniel C. Santos
    sexta-feira, 25 de agosto de 2006 00:23
    Moderador
  • Oi Sandro,

    não entendo de Linux, mas não terias alguma ferramenta de monitoramento neste firewall? Algo que te mostre se a conexão está chegando no SBS ou está ficando no Linux? Aí saberemos onde lutar.

    sexta-feira, 25 de agosto de 2006 11:58
  •  

    E lá vamos nós de novo... hehehe

    Daniel, obrigado pelo link, a partir dele encontrei algumas coisas interessantes.
    Carlos, o problema continua, mas estou desconfiado de ser algo no SBS.

    Vamos aos fatos:
    - pelo que consegui pesquisar e entender do tal do iptables do linux, os três comandos que preciso aplicar são:

    > iptables -t nat -F PREROUTING
    > iptables -t nat -A PREROUTING -d 200.xx.xx.xx -p tcp --dport 1723 -j DNAT --to 192.168.16.2
    > iptables -t nat -A PREROUTING -d 200.xx.xx.xx -p tcp --dport 1701 -j DNAT --to 192.168.16.2
    > iptables -t nat -A PREROUTING -d 200.xx.xx.xx -p 47 -j DNAT --to 192.168.16.2

    o primeiro limpa qualquer pré-roteamento que tenha sido feito (descobri que haviam vários, devido aos testes)
    os demais redirecionam as portas 1723, 1701 e o protocolo 47 (um tal de GRE que não sei do que se trata, mas vi numa rotina de exemplo).

    Meu SBS tem os ips 192.168.16.2 para a rede interna e 192.168.0.101 para ligação com o linux (192.168.0.100). O ip 200.xx.xx.xx é a segunda placa de rede do linux para acesso externo.

    Apliquei as regras acima para o ip 192.168.0.101 e continua o mesmo erro (800: servidor inalcançável).
    Então tentei o ip 192.168.16.2 e mesma coisa.

    Como posso ter certeza de que é o SBS que não está respondendo à solicitação?
    Pela 16.2 ele responde ao ping, mas isto é a partir de uma estação interna.
    A partir do linux ele não respondeu nenhum ping, nem na 16.2, nem na 0.101... Olhando desta forma, realmente, o linux não o está encontrando... (Em tempo, a comunicação entre eles está ok, pois as estações estão navegando na net normalmente)

    Por acaso o micro do linux deveria estar cadastrado no AD?? Se sim, como cadastrar uma máquina linux no AD?

    Bom, é isto. Só lembrando que o assistente de conexão remota foi rodado e concluído com êxito.

    Sandro.

    (a luta continua, companheiros)

    sexta-feira, 25 de agosto de 2006 23:07
  • Sandro,

    tens como remover a máquina linux temporariamente e fazer o teste de conexão no SBS? Assim vais tirar a dúvida, pois se o wizard rodoa perfeito deveria estar funcionando.

    sexta-feira, 25 de agosto de 2006 23:33
  • Sandro, faça o seguinte...

    Isole o problema.

    Já que vc rodou o wizard, teste a conexão de dentro da empresa mesmo. Crie uma conexão vpn apontando para o ip do servidor, veja se conecta. Se conectar o seu problema é de fora pra dentro mesmo e ai focaremos nisso. Senão vamos ficar dando tiro no escuro. Outra coisa, vc liberou nas propriedades do usuário para ele fazer conexão vpn?

    Sds,

    Daniel C. Santos

     

     

    sábado, 26 de agosto de 2006 16:53
    Moderador