none
Sem acesso remoto após instalar RDS RRS feed

  • Pergunta

  • Olá pessoal, boa tarde.

    Estamos com o seguinte problema:

    Cenário:

    Servidor com Windows Server Standard PTBR 2012 R2 updates em dia.
    Serviços instalados: AD DS (servidor é o DC da rede); RDS instalado, remoteapp ok, 6 cals de TS ativadas.

    Problema: Servidor já era DC com acesso remoto para administrador funcionando. Após instalação do RDS, apenas o remoteapp funciona. O acesso remoto via "mstsc" não funciona, nem para o próprio usuário administrador do domínio.

    Ações já realizadas: Grupos do AD verificados, GPO's para liberar acesso remoto definidas, usuários de teste criados, incluídos nos grupos necessários mas mesmo assim sem acesso remoto.

    Erros detectados: Após tentativa de acesso remoto, ocorrem eventos com ID 20499, 1515 e 1511. 

    Ao tentar acesso remoto via "mstsc", o que ocorre é o seguinte: informo o ip ou nome do servidor, o usuário e a senha, ele valida as credencias, começa a carregar o perfil do usuário e imediatamente faz logoff e fecha a tela. Para qualquer usuário ocorre o mesmo processo.

    Agradeço antecipadamente pela atenção.
    Julio

    sábado, 31 de dezembro de 2016 12:34

Todas as Respostas

  • Bom dia ,

    A role de RDS não deve ser instalada no domain controller, é necessário um servidor separado para isso (não quis dizer que não vá funcionar, porém, não é um ambiente suportado pela Microsoft).

    https://msdn.microsoft.com/en-us/library/bb892075%28v=vs.85%29.aspx?f=255&MSPPError=-2147217396

    Outro ponto: tente acessar utilizando "mstsc /admin" e veja se o erro também ocorre.

    Verifique as licenças se estão ok, se os sessions hosts estão aceitando requisições, se não há perfil corrompido ou temporário (1515 e 1511): https://support.microsoft.com/en-us/kb/947215

    Veja se há alguma mensagem de erro ou mensagem relevante nos seguintes logs do event viewer:

    Event Viewer > Applications and service logs > Windows:
    TerminalServicesLocalSessionManager-Operational
    TerminalServicesPnPDevices-Admin
    TerminalServicesRDPClient-Operational
    TerminalServicesRemoteConnectionManager-Operational
    TerminalServicesServerUSBDevices-Admin
    TerminalServicesSessionBroker-Admin

    Espero que possa te ajudar.

    segunda-feira, 2 de janeiro de 2017 12:08
  • Ola Julio,

    Siga as dicas do amigo Renato e você pode tentar refazer o banco de dados de licença para tentar solucionar o problema. Segue procedimento abaixo:

    https://social.technet.microsoft.com/wiki/pt-br/contents/articles/26344.reinstalando-licencas-no-remote-desktop-service-20082012r2.aspx 

    Espero que ajude.


    Vinicius Mozart || MVP - Cloud and Datacenter Management || vinicius.mozart@terra.com.br || http://www.wenz.com.br || Skype:vinicius.mozart

    segunda-feira, 2 de janeiro de 2017 17:27
    Moderador
  • Caro Renato,

    Obrigado pela atenção.
    Entendo que o serviço RDS não deve ser instalado em um servidor que seja DC.
    Mas não tive escolha, pois é o único servidor que o cliente possui.
    Não ia instalar o AD DS, mas no 2012 o servidor que será o RDS deve estar ingressado em um domínio.

    Neste caso a Microsoft nos coloca em um situação complicada, pois para instalar o RDS tem que haver o AD DS e não é suportado instalar o RDS em um DC.

    Em alguns casos como o meu, não temos um segundo servidor exclusivo para ser RDS.

    Bem, segui os passos que vc indicou. Mas infelizmente não funcionou. O acesso via mstsc continua fazendo logoff antes de abrir o desktop do usuário.

    Os logs são estes mesmos: 1515 e 1511.

    Obrigado,

    Julio


    • Editado Júlio Filho segunda-feira, 9 de janeiro de 2017 13:31 erro digitação
    sexta-feira, 6 de janeiro de 2017 23:00
  • Caro Vinícius,

    Obrigado pela dica.

    Fiz a reinstalação das licenças.

    Foram ativadas com êxito.

    Mas o acesso via mstsc continua com a mesma falha.

    Obrigado,

    Julio

    sexta-feira, 6 de janeiro de 2017 23:54