none
Windows vista home basic não funciona dominio RRS feed

  • Pergunta

  • O que acontece aqui é que não consigo colocar este note aqui no dominio que temos aqui na empresa, que é server 2003 R2, quando tento mapear as unidades diz q nao acha o caminho.

    Eu vi num post aqui do forum falando sobre scripts para funcionar os dominios. tentei utilizar um feito por um dos moderadores daqui, mas aconteceu a seguinte mensagem de erro.
    --------------------------------------------------------
    script:        c:\user\leonardo\desktop\script.vbs
    Linha: 6
    Caract.: 1
    Erro: O nome da rede não foi encontrado
    Código:80070043
    Origem:wshnetworkmapnetworkdrive
    --------------------------------------------------------

    Eu usei o seguinte script:

    Set wshNetwork = CreateObject("WScript.Network")
    Set oDrives = WshNetwork.EnumNetworkDrives

    DriveMapper "G:"

    wshNetwork.MapNetworkDrive "G:", "\\servidor\pastas\publico"

    Sub DriveMapper(Drive)
    For i = 0 to oDrives.Count -1 Step 2
       if LCase(Drive) = LCase(oDrives.Item(i)) then
          WshNetwork.RemoveNetworkDrive Drive, true, true
       End if
    Next
    End sub

    o que posso fazer para funcionar?

    Obrigado desde já.
    terça-feira, 23 de junho de 2009 18:54

Todas as Respostas

  • Olá,

    Este script só vai mapear unidade de rede... É isso que você precisa???

    Tente alterar para o numero de IP no lugar do nome do servidor. Exemplo: \\10.0.0.1\pastas\publico


    Faça os testes e nos retorne.

    Até mais,

    Jesiel

    Obs.: Se útil, classifique
    terça-feira, 23 de junho de 2009 19:35
  • Não sei ao certo.

    Eu preciso acessar as unidades na rede com esse windows vista, e como nao tem como por o dominio, achei que essa podia ser a solução.

    O caminho para as pastas é \\servidor\pastas\publico

    sendo que o "pastas" não é compartilhado, então eu só consigo acesso ao publico, por exemplo, com o dominio. Mas o windows nao me da essa opção.

    Tentei do jeito que tu falaste, deu o mesmo erro.

    Obrigado desde já.
    terça-feira, 23 de junho de 2009 21:00
  • Ninguém sabe?

    Obrigado desde já.
    quinta-feira, 25 de junho de 2009 11:00
  • Olá,

    Faça o seguinte teste:

    1 - No dominio crie um usuário com o mesmo nome do windows vista
    2 - Coloque a mesma senha.

    Crie um compartilhamento (c:\teste) e coloque permissão para o usuário criado acima.

    Execute o script abaixo ( Na maquina vista):

    Set wshNetwork = CreateObject("WScript.Network")
    Set oDrives = WshNetwork.EnumNetworkDrives

    DriveMapper "G:"

    wshNetwork.MapNetworkDrive "G:", "\\servidor\teste"

    Sub DriveMapper(Drive)
    For i = 0 to oDrives.Count -1 Step 2
       if LCase(Drive) = LCase(oDrives.Item(i)) then
          WshNetwork.RemoveNetworkDrive Drive, true, true
       End if
    Next
    End sub

    Faça os testes e nos retorne.

    Até mais,

    Jesiel

    Obs.: Se útil, classifique
    quinta-feira, 25 de junho de 2009 13:53
  • Esse script acima funcionou, mas o meu problema se dá pelo seguinte:

    Dentro do servidor as pastas do dominio (as que estão compartilhadas, por exemplo, "Publico";"Administrativo", etc) ficam dentro de uma pasta denominada "Pastas" (Criativo, não?) e essa "Pastas" NÃO está compartilhada. E ai que enfrento meu problema, quando rodo um script para pegar uma pasta dentro do "Pastas" ele diz não encontrar o "Pastas".

    E eu não posso compartilhar essa "Pastas", pois ai todos os usuarios acabam tendo acesso a tudo, já fiz o teste.

    O que podemos fazer?

    Obrigado desde já.
    sexta-feira, 26 de junho de 2009 11:48
  • Olá,

    VOcê terá que criar um mapeamento para cada compartilhamento.

    Exemplo:

    wshNetwork.MapNetworkDrive "G:", "\\servidor\publico"
    wshNetwork.MapNetworkDrive "H:", "\\servidor\administrativo"

    Aqui eu mapeio o G para o publico e o H para o administrativo

    Entendeu??

    Você só consegue mapear compartilhamentos... se a pasta "PASTAS" não esta compartilhada... Você não consiguirá.


    Até mais,

    Jesiel

    Obs.: Se útil, classifique
    sexta-feira, 26 de junho de 2009 12:59
  • Então terei de comprar outro vista para entrar no dominio, correto?

    Obrigado por tudo!
    sexta-feira, 26 de junho de 2009 21:59
  • Olá,

    Correto, se você quer desfrutar das funcionalidades de dominio, por exemplo: Aplicar politicas, você só consiguirá se estiver no dominio.

    Até mais,

    Jesiel

    Obs.: Se útil, classifique
    sábado, 27 de junho de 2009 04:32
  • Leonardo,

    O Windows Vista tem um camaradinha lá nas Contas de Usuário que se chama UAC (Controle de Conta de Usuário), deixa ele desativado.

    E outra, às vezes acontece de vc tentar acessar da seguinte forma e funcionar \\servidor\c$  é um compartilhamento oculto, onde vc tem acesso irrestrito ao conteúdo do c: da máquina em questão.

    Mas pra isso, vc tem de ser o Administrador do Domínio e estar logado em sua máquina como tal pra conseguir acessar o c$ da outra, a não ser que seus usuários não tenham nenhum tipo de restrição.

    Acontece às vezes, principalmente em máquinas com XP que o compartilhamento de arquivos fica desabilitado, então vc cria uma pasta qualquer e compartilha ela, depois pode excluir essa pasta, isso servirá pra habilitar o compartilhamento.

    Dá uma conferida no Firewall do seu Windows e também da máquina que está tentando acessar.

    Ao menos essas situações já ocorreram comigo e resolvi assim.
    Gregorio
    sexta-feira, 3 de julho de 2009 18:33
  • Ah vale resaltar que eu utilizo Win Vista Business, vale a pena confirmar com o pessoal da Microsoft se o Home Basic tem alguma restrição com domínio. Isso não sei lhe dizer.
    Gregorio
    sexta-feira, 3 de julho de 2009 18:35
  • RESOLVIDO!

    Eu já havia desistido e decidido comprar um Vista Bussines, porém hoje de manhã me ocorreu uma idéia que surpreendentemente deu certo.

    Dentro do caminho \\servidor\Pastas\"pastas que eu quero mapear" eu não conseguia acesso sem o Dominio, pois a "Pastas" nao se encontrava compartilhado e apenas com as exceções de usuario do dominio se conseguia acesso as partições dentro dela. O que eu fiz foi o seguinte: Mantive em meu computador mesmo usuario e senha que estao registrados no dominio e então criei atalhos dentro do \\servidor, estes atalhos direcionavam para as "pastas que eu quero mapear" dentro do "Pastas". Essa solução increvelmente simples resolveu completamente meu problema, consegui acesso as partições que meu login tem liberado sem terq compartilhar a "Pastas" e abrir todo o conteudo para todos os usuarios!

    Obrigado a todos pela paciência e atenção,


    Leonardo.

    P.S.: Se puderem marcar como resolvido, agradeço.
    segunda-feira, 13 de julho de 2009 19:09