none
Event Receivers não iniciam quando documentos entram numa lista via web service RRS feed

  • Pergunta

  • Olá,

    Tenho um sistema em sharepoint que utiliza uns event receivers que iniciam no item adding e no item added de uma biblioteca de documentos.

    O sistema utiliza o content organizer e são enviados para essa biblioteca final dependendo do seu content type.

    Se fizer o upload de um documento na drop off library, ele é enviado para a biblioteca final e os eventos iniciam normalmente.

    Se fizer enviar um documento para a drop off library através do web service do sharepoint, o documento é enviado para a biblioteca final mas os eventos não iniciam.

    Alguém sabe uma solução para este problema?

    Cumprimentos,

    Diogo Almeida

    quinta-feira, 23 de julho de 2015 14:08

Respostas

  • Olá Diego,

    Bem vindo no forum :)

    Verifique por favor que o endereço da sua aplicação está na zona default/padrão do mapeamento alternativo (Alternate Access mapping):

    https://technet.microsoft.com/en-us/library/cc263208.aspx

    Configurar o endereço na zona padrão deve resolver o problema (sem certeza absoluta, já que voce não passou algum evento :).


    Abraços

    David

    SharePoint Support Engineer

    Blog: http://spinternals.blogspot.com.br/ 

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    quinta-feira, 23 de julho de 2015 21:01