none
Erro ao instalar certificado A1 no Windows 10 com usuário do Domínio. RRS feed

  • Pergunta

  • Olá

    Quando faço a instalação/importação de um certificado A1 sempre ocorre um erro, como mostrado na mensagem abaixo:

    "Erro interno. Talvez o perfil do usuário não esteja acessível ou a chave privada que você está importando exija um provedor de serviço de criptografia que não está instalado no sistema."

    A instalação finalizou com sucesso em duas situações. Quando foi realizada utilizando um usuário local com privilégios de administrador, e utilizando um usuário local sem privilégios de administrador. 

    Na tentativa de instalar o certificado através de um usuário ingressado no domínio da rede, ocorre o erro! O uso do PC será apenas através de usuários do domínio.

    Já vi todos os fóruns e não achei a solução. Usuário local funciona normalmente, porém usuários do domínio ficam pedindo senha após a instalação e da erro no final, erro citado acima.

    Por favor, preciso resolver isso urgentemente.

    terça-feira, 2 de fevereiro de 2021 12:32

Respostas

  • Boa tarde! Tudo bem?
    O Procedimento funcionou aqui, muiiiiiiiiito obrigado!

    A politica estava desabilitada por padrão, porém habilitei colocando a primeira opção: A entrada do usuário não é necessária quando novas chaves são armazenadas e usadas.

    Após isso foi possível instalar o certificado sem que houvesse que criar a senha de criptografia.

    sábado, 27 de fevereiro de 2021 15:15
  • Olá Rael Wilkerson,

     

    Obrigada por participar da Comunidade TechNet.

     

    Com relação a tentar desabilitar o pop-up de solicitação de senha, tente o procedimento abaixo:

     

    Desinstale o certificado e volte a importar sem habilitar a opção "proteção forte" conforme imagem abaixo:

    Também deve ser revisada a seguinte Política de Grupo:

     

    Configuração do Computador \ Configurações do Windows \ Configurações de Segurança \ Políticas Locais \ Opções de Segurança \ Criptografia do sistema

     

    Criptografia do sistema: Força proteção de chave forte para chaves de usuário armazenadas no computador

    Esta configuração de segurança determina se as chaves privadas dos usuários exigem o uso de uma senha.

    As opções são:

    A entrada do usuário não é necessária quando novas chaves são armazenadas e usadas.

    O usuário é solicitado quando a chave é usada pela primeira vez.

    O usuário deve inserir uma senha cada vez que usar uma chave.

    Para obter mais informações, consulte Infraestrutura de chave pública.

    Padrão: esta política não está definida.

     

    Se essa opção de segurança de política de grupo estiver definida, você deve desativá-la.

     

    Espero que te ajude.

     

    Sinta-se a vontade para consultar qualquer dúvida referente aos produtos Microsoft. Será um prazer ajudar-te.

     

    Obrigada.

     

    Camila Brito

    ____________________________________________________________________________

    Por favor lembre-se de "Marcar como resposta" as respostas que solucionaram seu problema, é uma forma comum de reconhecer aquelas pessoas que te ajudaram, e faz com que seja mais fácil para os outros visitantes encontrar a solução depois.

     

    Microsoft oferece esse serviço de forma gratuita, com a finalidade de ajudar os usuários e ampliar a base de dados de conhecimentos relacionados com os produtos e tecnologias de Microsoft.

     

    Este conteúdo é proporcionado "tal qual" e não implica nenhuma responsabilidade por parte de Microsoft.

    segunda-feira, 15 de fevereiro de 2021 21:58
    Moderador

Todas as Respostas

  • parece ser mais alguma restricao, nao consegue alterar o repositorio de instalacao para este computador ao inves do perfil?

    o que vc pode tentar fazer é pedir para o responsavel pelo AD, mover ele de grupo onde nao tem as gpos e tentar instalar, em seguida volta para o OU

    terça-feira, 2 de fevereiro de 2021 14:10
  • Não há GPO de restrição e estou utilizando o administrador do domínio na maquina pra testar, pra ter certeza que não é permissão e dei permissão para ADM local, mesmo não precisando só pra ter certeza.
    Agora se uso qualquer usuário local instala sem problemas.
    terça-feira, 2 de fevereiro de 2021 14:16
  • vc esta tentando instalar usando um arquivo pfx?

    nunca tentei, mas no usuario que esta instalado vai nas opcoes da internet, certificado e tente exportar o certificado e depois importar

    ou executar, mmc, add certificados e exporta/importa para o usuario do dominio.

    terça-feira, 2 de fevereiro de 2021 14:47
  • Sim, é um certificado A1.

    A maquina foi formatada recentemente.

    Esse procedimento vc fala fazer no usuário local e dps de exportado puxar para o usuário do domínio?

    Pois fiz um parecido pelo firefox e ele importa sem dar erro, porém não reconhece em nenhum site de teste de certificado ou no ecac.

    Mas vou tentar fazer.

    terça-feira, 2 de fevereiro de 2021 16:34
  • isso, creio que o certo é usar o pfx para instalar, pela opcoes da internet fiquei em duvida, mas que sabe pelo mmc funciona.

    acessa no usuario local, abre o mmc, exporta e depois veja se tem a opcao de importar logado no usuario do dominio.

    o que o suporte do certificado fala?

    terça-feira, 2 de fevereiro de 2021 16:48
  • Não falei com o suporte do certificado, pois pelo que vejo é um problema de windows.

    Se no usuário local funciona pq no do domínio não instala e fica pedindo senha no final da instalação. 

    É isso que ta me deixando com a pulga atrás da orelha.

    terça-feira, 2 de fevereiro de 2021 17:43
  • como esta pedindo senha no final acho que tem algo ai...

    executa o gpresult e veja se mostra alguma coisa

    desativa o antivirus tambem

    terça-feira, 2 de fevereiro de 2021 19:09
  • Ele pede pra criar uma senha pra poder utilizar quando for usar o certificado.
    Uma senha além da senha do próprio certificado, mas é uma opção do windows e não do certificado.

    Já desativei o antivírus na primeira tentativa rsrs
    Vou ver se tem algo no GPresult, mas certeza que não tem nenhuma GPO aplicada.

    terça-feira, 2 de fevereiro de 2021 19:21
  • Bom dia! Mais alguém tem alguma ideia?
    Pois com usuário de domínio não funciona.
    Sabem desabilitar essa opção do windows de pedir permissão para usar o certificado? Como se fosse uma UAC para certificados rsrs

    segunda-feira, 8 de fevereiro de 2021 11:56
  • esta complicado ainda mais se nao gpo.

    faz outro teste loga no pc com o administrador do dominio e tenta instalar, funcionando adicione o usuario como admin do dominio, instale e depois remova do grupo de admins.

    segunda-feira, 8 de fevereiro de 2021 16:01
  • O usuário usado já é o administrador do Domínio e já realizei esses testes.

    Com qualquer usuário local instala numa boa, mas com qlq usuário de domínio pede pra criar uma senha.
    Fica complicado colocar o W10 pra funcionar em um domínio que não deixa instalar o certificado.

    Tem como desabilitar essa segurança a mais para certificados que o W10 tem?

    segunda-feira, 8 de fevereiro de 2021 20:12
  • Bom dia! 
    Mais alguma novidade? Pois aqui continuamos com o problema.

    Um usuário de domínio não deixa instalar o certificado A1, pois pede para criar uma senha (sem ser a do próprio certificado) que será utilizada quando for usar o certificado.

    Grato

    segunda-feira, 15 de fevereiro de 2021 12:05
  • Olá Rael Wilkerson,

     

    Obrigada por participar da Comunidade TechNet.

     

    Com relação a tentar desabilitar o pop-up de solicitação de senha, tente o procedimento abaixo:

     

    Desinstale o certificado e volte a importar sem habilitar a opção "proteção forte" conforme imagem abaixo:

    Também deve ser revisada a seguinte Política de Grupo:

     

    Configuração do Computador \ Configurações do Windows \ Configurações de Segurança \ Políticas Locais \ Opções de Segurança \ Criptografia do sistema

     

    Criptografia do sistema: Força proteção de chave forte para chaves de usuário armazenadas no computador

    Esta configuração de segurança determina se as chaves privadas dos usuários exigem o uso de uma senha.

    As opções são:

    A entrada do usuário não é necessária quando novas chaves são armazenadas e usadas.

    O usuário é solicitado quando a chave é usada pela primeira vez.

    O usuário deve inserir uma senha cada vez que usar uma chave.

    Para obter mais informações, consulte Infraestrutura de chave pública.

    Padrão: esta política não está definida.

     

    Se essa opção de segurança de política de grupo estiver definida, você deve desativá-la.

     

    Espero que te ajude.

     

    Sinta-se a vontade para consultar qualquer dúvida referente aos produtos Microsoft. Será um prazer ajudar-te.

     

    Obrigada.

     

    Camila Brito

    ____________________________________________________________________________

    Por favor lembre-se de "Marcar como resposta" as respostas que solucionaram seu problema, é uma forma comum de reconhecer aquelas pessoas que te ajudaram, e faz com que seja mais fácil para os outros visitantes encontrar a solução depois.

     

    Microsoft oferece esse serviço de forma gratuita, com a finalidade de ajudar os usuários e ampliar a base de dados de conhecimentos relacionados com os produtos e tecnologias de Microsoft.

     

    Este conteúdo é proporcionado "tal qual" e não implica nenhuma responsabilidade por parte de Microsoft.

    segunda-feira, 15 de fevereiro de 2021 21:58
    Moderador
  • Vou fazer o teste e aviso se deu certo.

    Perdão pela demora.

    segunda-feira, 22 de fevereiro de 2021 16:32
  • Boa tarde! Tudo bem?
    O Procedimento funcionou aqui, muiiiiiiiiito obrigado!

    A politica estava desabilitada por padrão, porém habilitei colocando a primeira opção: A entrada do usuário não é necessária quando novas chaves são armazenadas e usadas.

    Após isso foi possível instalar o certificado sem que houvesse que criar a senha de criptografia.

    sábado, 27 de fevereiro de 2021 15:15