none
Servidor de Internet RRS feed

  • Pergunta

  • Ola Galera

    Estou com o seguinte cenário vejam só:

    Tenho 3 servidores Windows

    • 2003 como Terminal Server
    • 2008 como AD
    • Um servidor Linux de internet

    Na empresa tenho um link GVT internet que também fecha uma VPN com Jundiai.

    Essa VPN parou de funcionar tudo me indica que o Linux perdeu alguma rota, porem estou ha 3 semanas nesse cenário e nao manjo nada de Linux.

    A unidade Jundiai acessa remotamente o Servidor de TS em São Paulo e ai conseguem acessar a internet

    A rede ta toda complicada, nesse Linux tem Firewall, DNS e Proxy

    Gostaria de trocar esse Linux por um Windows 2003, como Server de Internet.

    Essa seria uma opção válida, o que acham?

    Esse Windows que quero colocar como Server de Internet precisaria ter proxy?

    Se colocar ele teria que usar o RAS do Windows 2003?

    Grato

     

     

    • Movido Richard Juhasz quinta-feira, 2 de junho de 2011 18:30 thread movida (De:Windows Server 2003)
    segunda-feira, 30 de maio de 2011 00:25

Respostas

  • Araujo,

    o foco do Fórum não é Linux, então é interessante vc validar as regras do iptables primeiramente com outros testes.

    Se o fowarding estiver funcionando corretamente no seu iptables, vc pode confirmar isso fazedo os testes que mencionei no post anterior...o mais importante deles:

    telnet "ip_do_servidor_ts" 3389

    Se a conexão falhar, quer dizer que o tráfego para a 3389 ou não está sendo redirecionado para o host interno através da regra de NAT, ou o Firewall está filtrando por alguma razão essa porta.

    Em suma, se der erro no telnet, quer dizer que vc tem um erro de conectividade, e o jeito é vc cair em cima do iptables para identificar a falha.

    Se o telnet funcionar, que dizer que o fowarding do servidor está funcionado e o tráfego está chegando até o servidor de TS dentro da Rede remota e o problema é sistêmico...nesse caso, vc deverá atentar para a mensagem de erro e logs do servidor de TS.

    Qualquer dúvida é só postar...um abraço !

    Att,


    Fabiano Barreira

    MCP + MCDST + MCSA & MCSE on Windows Server 2003 + MCTS + MCITP
    Blog - http://fabianobarreira.wordpress.com
    segunda-feira, 30 de maio de 2011 13:24

Todas as Respostas

  • Bom dia,

    vc está com muitas dúvidas. Vamos por partes:

    Esse Linux que vc menciona, provavelmente é uma distribuição rodando com o Squid instalado. Deve ser seu servidor de Proxy para acesso a Internet.

    Para checar o problema da VPN, vc deve saber como está feita essa conexão. Entre quais servidores, se está usando a VPN nativa do Sistema Operacional, se está usando algum appliance ou aplicação de terceiros, enfim.

    Como vc dará suporte ao ambiente, o ideal é que vc domine as soluções implementadas. Dessa forma, qualquer migração é válida.

    Meu conselho: documente todo o ambiente e entenda como tudo funciona. Vc precisa conhecer com as soluções interoperam para poder fazer o troubleshooting em casos de problemas como esse.

    Att,


    Fabiano Barreira

    MCP + MCDST + MCSA & MCSE on Windows Server 2003 + MCTS + MCITP
    Blog - http://fabianobarreira.wordpress.com
    segunda-feira, 30 de maio de 2011 10:55
  • Bom dia Fabiano

    Então sobre o Linux e isso que vc falou mesmo, ele tem squid e servidor de proxy.

    A VPN "funciona" assim:

    Usuários de Jundiaí logan no meu servidor TS Windows pela conexão remota do Windows, digitando o ip do  TS e ai cai na minha rede e tem acesso a net.

    Porém esse acesso foi perdido sem ter sido feita nenhuma alteração no Linux, apenas reiniciando.

    Olhando no arquivo IPTables ele me mostra as regras Nat configurada e vejo que la para o TS está aparentemente ok.

    Cara sinceramente não sei o que fazer .

    Grato

    segunda-feira, 30 de maio de 2011 11:03
  • Então Araujo, esse tipo de acesso não caracteriza uma VPN.

    Uma VPN trabalha de forma diferente, esse acesso que vc está fazendo é simplesmente um acesso remoto e veja, possui várias brechas de segurança.

    Se o acesso ao servidor de TS está fora, então o link Internet na filial ou matriz caiu (para confirmar isso, faça testes de conectividade usando o ping de dentro dessas Redes), os serviços de Rede estão desativados ou algum Firewall está bloqueando (faça um teste usando o comando telnet na porta 3389 do servidor de TS).

    Descubra para qual endereço IP é feito o acesso ao servidor de TS e execute os testes acima nesse endereço para validar a conectividade e o funcionamento do serviço.

    Att,


    Fabiano Barreira

    MCP + MCDST + MCSA & MCSE on Windows Server 2003 + MCTS + MCITP
    Blog - http://fabianobarreira.wordpress.com
    segunda-feira, 30 de maio de 2011 11:55
  • Fabiano veja o que achei no meu Linux

    iptables -t nat -A PREROUTING -s 200.204.142.252 -m tcp -p tcp --dport 3389 -j DNAT --to-destination 192.168.1.1
    iptables -A FORWARD -d 192.168.1.1 -p tcp --dport 3389 -j ACCEPT
    iptables -t nat -A PREROUTING -s 189.108.200.42 -m tcp -p tcp --dport 3389 -j DNAT --to-destination 192.168.1.1
    iptables -A FORWARD -d 192.168.1.1 -p tcp --dport 3389 -j ACCEPT
    iptables -A PREROUTING -t nat -p tcp --dport 3389 -j DNAT --to 192.168.1.253
    iptables -A FORWARD -d 192.168.1.253 -p tcp --dport 3389 -j ACCEPT

    Pelo pouco que entendi funciona assim

    Os usuários de jundiai se autenticam no 192.168.1.1 que é meu AD em SP.

    E ele faz uma rota para o 192.168.1.253 que é o meu Terminal Server.

    Aparentemente tudo ok.

     

     

     

    segunda-feira, 30 de maio de 2011 12:55
  • Araujo,

    o foco do Fórum não é Linux, então é interessante vc validar as regras do iptables primeiramente com outros testes.

    Se o fowarding estiver funcionando corretamente no seu iptables, vc pode confirmar isso fazedo os testes que mencionei no post anterior...o mais importante deles:

    telnet "ip_do_servidor_ts" 3389

    Se a conexão falhar, quer dizer que o tráfego para a 3389 ou não está sendo redirecionado para o host interno através da regra de NAT, ou o Firewall está filtrando por alguma razão essa porta.

    Em suma, se der erro no telnet, quer dizer que vc tem um erro de conectividade, e o jeito é vc cair em cima do iptables para identificar a falha.

    Se o telnet funcionar, que dizer que o fowarding do servidor está funcionado e o tráfego está chegando até o servidor de TS dentro da Rede remota e o problema é sistêmico...nesse caso, vc deverá atentar para a mensagem de erro e logs do servidor de TS.

    Qualquer dúvida é só postar...um abraço !

    Att,


    Fabiano Barreira

    MCP + MCDST + MCSA & MCSE on Windows Server 2003 + MCTS + MCITP
    Blog - http://fabianobarreira.wordpress.com
    segunda-feira, 30 de maio de 2011 13:24
  • Fabiano

    Fiz o teste telnet e deu ok com a porta 3389, realizando de um pc cliente.

    Seu eu coseguisse que essas redes se enxergassem ja me resolveria, ou seja pingar um ip de um pc em jundiaí

    Grato


    segunda-feira, 30 de maio de 2011 13:57
  • O Telnet funcionou de onde para onde (de qual Rede ou IP para qual IP de destino) ?

    Att,


    Fabiano Barreira

    MCP + MCDST + MCSA & MCSE on Windows Server 2003 + MCTS + MCITP
    Blog - http://fabianobarreira.wordpress.com
    quinta-feira, 2 de junho de 2011 20:20