none
ERROR 404.3 no IIS8 para página asp RRS feed

  • Pergunta

  • Bom dia a todos!

    Tenho uma aplicação ASP clássico que roda perfeitamente no IIS 6.

    Ontem, instalei a mesma aplicação em um cliente com IIS8 Server  2012 e as mesmas não abriram.

    Dá o erro

    HTTP Error 404.3 - Not Found
    A página que você está solicitando não pode ser servida devido à configuração da extensão. Se a página for um script, adicione um manipulador. Se for necessário baixar o arquivo, adicione um mapa MIME.

    Já li vários artigos, de ontem para cá, e todos dizem para não adicionar terminação .asp no MIME. Mesmo porque, tentei adicionar para teste e a página fica desconfigurada.

    Já instalei todos os componentes do IIS (ASP, ASP.NET, CGI, etc..), coloquei o pool para 32bits, redefini ele como Classic, tentei desinstalar o net.4 e nada.

    Criei uma página default.asp apenas com <% Response.write "olá" %> e nada.

    Alguém tem alguma ideia do que mais posso fazer para minhas páginas asp rodarem?

    Obrigado.

    quinta-feira, 13 de março de 2014 14:08

Respostas

  • Já Edinaldo,

    só que agora descobri que a empresa tem suporte com a microsoft.

    Pode deixar que vou abrir um chamado com eles.

    Obrigado pela ajuda e desculpe ter tomado seu tempo.

    quinta-feira, 13 de março de 2014 17:58

Todas as Respostas

  • Olá,

    Veja se este tópico ajuda: http://social.msdn.microsoft.com/Forums/pt-BR/2c2b1103-c827-4a5a-86f3-e8dcc0c429f2/erro-a-pgina-que-voc-est-solicitando-no-pode-ser-servida-devido-configurao-da-extenso-ao?forum=webgeralpt

    ou este: http://social.technet.microsoft.com/Forums/windowsserver/pt-BR/27f94fe1-cf5f-4c05-8ed3-45ac74a94254/iis7-win7-net-40?forum=winiispt

    Atenciosamente,


    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **


    quinta-feira, 13 de março de 2014 14:11
  • Oi Edinaldo,

    obrigado pela resposta.

    Olhei os links que você me indicou. Ou eu já havia testado ou testei, mas não resolveu nada.

    Minhas páginas asp ainda não rodam.

    Se tiver mais alguma dica...

    Obrigado.

    quinta-feira, 13 de março de 2014 16:49
  • Olá,

    Faça uma reinstalação do IIS, seguindo o tutorial:

    http://www.iis.net/learn/get-started/whats-new-in-iis-8/installing-iis-8-on-windows-server-2012

    Atenciosamente,


    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    quinta-feira, 13 de março de 2014 16:56
  • Edinaldo,

    obrigado de novo.

    Foi o que fiz. Após como não funcionou, adicionei também .NET Framework 3.5.

    Como também não funcionou, removi o serviço todo e reinstalei ele novamente, mas o erro persiste.

    Agora, páginas com terminação .html, rodam sem problemas.

    Nesta página html, com links para páginas asp, o navegador abre os arquivos em bloco de notas.

    Ele não está reconhecendo páginas asp como navegáveis.

    quinta-feira, 13 de março de 2014 17:23
  • Já viu este artigo? http://technet.microsoft.com/pt-br/library/hh831475.aspx

    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    quinta-feira, 13 de março de 2014 17:25
  • Já Edinaldo,

    só que agora descobri que a empresa tem suporte com a microsoft.

    Pode deixar que vou abrir um chamado com eles.

    Obrigado pela ajuda e desculpe ter tomado seu tempo.

    quinta-feira, 13 de março de 2014 17:58
  • Que bom, pode ser que eles tenham mais êxito rsrsrs

    Por nada, não tomou tempo não, estamos aqui para nos ajudar...

    Boa sorte!


    Edinaldo Oliveira

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    ** Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde. **

    quinta-feira, 13 de março de 2014 18:00