none
Restore Do servidor de produção para o servidor TESTE via rede RRS feed

  • Pergunta

  • Caros amigos,
    Estou tentando fazer um restore da seguinte forma:

    o servidor de produção tem um backup de 80gb.
    Tenho um servidor para teste onde meu cliente quer a base igual a do servidor de produção nas horas dos testes.

    O que quero fazer:

    Quero levantar o backup que esta nesse servidor de produção no servidor teste e estou usando o seguinte script:

    RESTORE DATABASE [PROTHEUS] FROM  DISK = N'Z:\SQL\PROTHEUS.bak' WITH 
    FILE = 1,  NOUNLOAD,  STATS = 10
    GO

    onde o Z:\SQL é um mapeamento.
    quando executo esse scritp aontece o seguinte erro:

    Msg 3201, Level 16, State 2, Line 1
    Cannot open backup device 'Z:\SQL\PROTHEUS.bak'. Operating system error 3(O sistema não pode encontrar o caminho especificado.).
    Msg 3013, Level 16, State 1, Line 1
    RESTORE DATABASE is terminating abnormally.


    alguém pode me ajudar?
    segunda-feira, 13 de agosto de 2007 21:28

Todas as Respostas

  •  

    bom para funcionar assim o usuario que sobe o servico do seu sql server ( teste ) tem que ter permissoes na pasta e o ideal ( meu ponto de vista ) e usar unc names para acessar as pastas em outro server tipo \\nome_server ....

     

     

    Abs;

    terça-feira, 14 de agosto de 2007 11:06
  • Rafael,

     

    Primeiramente os dois ambientes estão bem similares, ou seja, a mesma configuração de unidades de risco e rede são iguais?

     

     

    O usuário que esta levantando este serviço tem permissão para acessar o outro servidor?

     

     

    terça-feira, 14 de agosto de 2007 12:18
    Moderador
  • Caros amigos.

     

    Hjcedo consegui achar a solução sozinho.

     

    Fiz o seguinte:

     

    fiz o que o amigo que postou antes explicou, coloquei os serviços do sql para subirem com uma conta que exista no servidor de produção para termos a relação de confiança nos servidores.

    no sqlserver2005 eu cliquei com o botão direito em DATABASE fui em restore na hora de apontar a pasta que estava o restore eu coloquei o endereço do mapeamento (ex: \\force-server3\backup)

     

    cara depois que fiz assim o restore funcionou legalsinho

     

    Obrigado pela resposta.

     

     

     

    terça-feira, 14 de agosto de 2007 19:59