none
Liberar Acesso Remoto (problemas com roteador) RRS feed

  • Pergunta

  • Prezados,

     

    Fiz todas as configurações possíveis para liberar o acesso remoto ao SQL SERVER 2005. Está ok com o servidor. O problema é o roteador D-Link 500B. Ele está bloqueando o acesso remoto ao banco. Já liberei no roteador (lá em Advanced Setup -> NAT) a porta 1433 e configurei no SQL SERVER o tráfico TCP/IP para esta porta. Porém o acesso remoto continua sendo negado. Não sei mais o que fazer. Alguem pode me ajudar?

     

    Grato,

    Paulo.

    quarta-feira, 7 de janeiro de 2009 13:57

Respostas

  • Olá Paulo, recomendo a vc que realize as seguintes verificações.

    1 - Certifique-se que vc consegue realizar um telnet para o servidor SQL Server na porta que vc configurou, esqueça tentar se conectar com algum query editor(SSMS ou QA). O primeiro passo é ter a certeza que existe conectividade com o servidor na porta 1433.

     

    Vc não nos falou se existe conectividade com o servidor.... vc só falou que liberou a porta, mas eu pergunto:

    as requisições de conexões não estão chegando no servidor SQL Server?

    ou estão chegando e estão sendo negadas?

    Para confirmar isso, basta vc realizar um telnet, se houver conexão, então seu roteador estará configurado e realizando o NAT corretamente.

     

    Para verificar as conexões negadas, basta verificar no log do SQL Server, se não houver nada lá é porque sequer existe alguma requisição chegando no teu servidor.

     

    Se vc deseja realmente a nossa ajuda, primeiramente vc precisa nos informar se existe conexão. Não adianta agente está especulando sobre como vc deve resolver esse problema a nível de SQL Server se seu NAT não funciona.

     

    Então, nos confirme que vc consegue conexão via telnet,  tenho certeza que vc terá sucesso caso exista outro problema relacionado com SQL, do contrário vc deve procurar ajuda de especialistas em conectividade.

     

    exemplo de telnet:

    telnet [servidor] [porta]

    ex: telnet 200.199.222.121 [1433]

     

     

     

     

     

     

     

     

    • Marcado como Resposta Paulo V. Fiaschi sexta-feira, 30 de janeiro de 2009 10:28
    quinta-feira, 29 de janeiro de 2009 15:55

Todas as Respostas

  • Paulo,

     

    Mas qual é a mensagem apresentada pelo SQL Server?

    quarta-feira, 7 de janeiro de 2009 15:49
    Moderador
  • Olá Paulo,

     

    O primeiro passo é certificar-se de que a porta utilizada é a 1433. Se for o SQL Server 2005 Express provavelmente não será. Você deve verificar a porta utilizada através do utilitário SQL Server Configuration Manager e verificar as propriedades do protocolo TCP/IP.

     

    [ ]s,

     

    Gustavo

    http://gustavomaiaaguiar.spaces.live.com

     

    quarta-feira, 7 de janeiro de 2009 17:27
  • Outra coisa a ser verificada é que o protocolo a ser utilizado na conexão teve ser o TCP e não named pypes.

    Certifique-se de criar um alias no lado do cliente para usar o TCP, vc pode usar o cliconfg.exe

     

    Outra coisa, certifique-se também de no configuration manager(Server Network configuration\protocols for MSSQLSERVER\TCP = Enabled) e no Surface(services and connections\remote connections\), permitir conexão TCP.

     

     

    quinta-feira, 8 de janeiro de 2009 04:11
  • Olá Emanuel, já fiz tudo o que o vc e os outros participantes desse tópico disseram:

    - habilitei conexões remotas no configuration manager e no surface
    - iniciei o processo sql browser
    - especifiquei a parta no configuration manager de modo que seja a 1433
    - liberei a escuta dessa porta no router, testei e ela está escutando
    - criei o alias no cliente usando o cliconfg.exe

    e... advinha?? Nada de funcionar. É frustrante...

    Abs.

    quinta-feira, 29 de janeiro de 2009 13:06
  • Olá Paulo, recomendo a vc que realize as seguintes verificações.

    1 - Certifique-se que vc consegue realizar um telnet para o servidor SQL Server na porta que vc configurou, esqueça tentar se conectar com algum query editor(SSMS ou QA). O primeiro passo é ter a certeza que existe conectividade com o servidor na porta 1433.

     

    Vc não nos falou se existe conectividade com o servidor.... vc só falou que liberou a porta, mas eu pergunto:

    as requisições de conexões não estão chegando no servidor SQL Server?

    ou estão chegando e estão sendo negadas?

    Para confirmar isso, basta vc realizar um telnet, se houver conexão, então seu roteador estará configurado e realizando o NAT corretamente.

     

    Para verificar as conexões negadas, basta verificar no log do SQL Server, se não houver nada lá é porque sequer existe alguma requisição chegando no teu servidor.

     

    Se vc deseja realmente a nossa ajuda, primeiramente vc precisa nos informar se existe conexão. Não adianta agente está especulando sobre como vc deve resolver esse problema a nível de SQL Server se seu NAT não funciona.

     

    Então, nos confirme que vc consegue conexão via telnet,  tenho certeza que vc terá sucesso caso exista outro problema relacionado com SQL, do contrário vc deve procurar ajuda de especialistas em conectividade.

     

    exemplo de telnet:

    telnet [servidor] [porta]

    ex: telnet 200.199.222.121 [1433]

     

     

     

     

     

     

     

     

    • Marcado como Resposta Paulo V. Fiaschi sexta-feira, 30 de janeiro de 2009 10:28
    quinta-feira, 29 de janeiro de 2009 15:55
  • Olá Emanuel, fiz o teste de conectividade que vc disse e deu certo!

    Quando fui testar no management studio por engano esqueci de digitar o nome da instância, ou seja, em vez de "[ipservidor]\sqlexpress" eu apenas digitei "[ipservidor]". Pra minha supersa eu FINALMENTE consegui conectar. Não sei o porque disso, pois na string de conexão local funcionava com o nome da instância. O impartante é que está funcionando...

     

    Obrigado pela ajuda!

     

    quinta-feira, 29 de janeiro de 2009 19:00
  • Paulo, só existem 2 chances de isso ter acontecido:

    1 - ou vc configurou para que a instância fixasse a posta como 1433, visto que é uma instancia nomeada. 

    2 - ou vc possuia um alias que direcionava o trafeco para a instância nomeada.

     

    Quem bom que vc conseguiu, só achei estranho ter demorado tanto.

    Caso alguma das respostas tenha lhe ajudado a solucionar o seu problema classifique-a para o correto encerramento do tópico.

     

    Valeu!

    quinta-feira, 29 de janeiro de 2009 21:28