none
Workflow plataforma 2010 no Sharepoint 2013 [Problema] RRS feed

  • Pergunta

  • Pessoal boa tarde,

    Tenho o seguinte Workflow rodando como base de várias listas no Sharepoint 2010 - porém quando estes fluxos foram migrados para o 2013 o Workflow está ignorando uma condição: "Aguardar o item ficar diferente de Pendente" como na figura baixo:

    Em alguns testes notei que ele retorna estes valores no e-mail:

    Sharepoint 2010 - Valor retornado: 2;#Pendente

    Sharepoint 2013 (Workflow 2010) - Valor retornado: 2;#Pending

    Sharepoint 2013 (Workflow 2013) - Valor retornado: 2

    Será que por não estar coincidindo as informações o Workflow entende que já é um valor diferente e ignora a condição?

    2;#Pendente é diferente de 2:#Pending

    Se alguém puder me ajudar agradeço,

    Abs.

    Henrique

    quinta-feira, 14 de agosto de 2014 20:00

Respostas

  • Após abertura de chamado para Microsoft, foi necessário instalar alguns hot-fixes no Sharepoint Designer 2013 para funcionar corretamente para os fluxos novos (plataforma 2010), infelizmente os fluxos antigos precisaram ser refeitos manualmente.

    Atenciosamente,

    Henrique

    terça-feira, 18 de novembro de 2014 19:37

Todas as Respostas

  • Boa tarde,

    Alguém que tenha a plataforma 2013 funcionando poderia fazer um teste de construção deste mesmo Workflow na plataforma 2010 e verificar se ocorre o mesmo erro?

    Abs.

    Henrique

    segunda-feira, 1 de setembro de 2014 18:16
  • Após abertura de chamado para Microsoft, foi necessário instalar alguns hot-fixes no Sharepoint Designer 2013 para funcionar corretamente para os fluxos novos (plataforma 2010), infelizmente os fluxos antigos precisaram ser refeitos manualmente.

    Atenciosamente,

    Henrique

    terça-feira, 18 de novembro de 2014 19:37