locked
Windows Mobile 5 e Exchange 2007 RRS feed

  • Pergunta

  •  

    Senhores,

     

    A empresa que eu trabalho utiliza o Exchange 2007 e para as conexões via OWA e RPC sobre HTTP utilizamos

    o certificado gerado pelo próprio Exchange Server, quando conectamos via OWA ou RPC recebemos a mensagem

    de warning do certificado e aceitamos e tudo funciona ok, o problema está em um smartphone com Windows Mobile

    5.0 que um diretor comprou, ele não sincroniza direto com o Exchange de jeito nenhum.

     

    Eu fiz algumas pesquisas e descobri que o Windows Mobile 5 tem problemas com este certificado do Exchange,

    porém gostaria de saber se alguém já teve o mesmo problema e trocar algumas idéias.

     

    Obrigado,

     

    José Ricardo

    segunda-feira, 3 de setembro de 2007 17:57

Respostas

Todas as Respostas

  • José Ricardo;

     

     Estou com o mesmo problema que vc, e mesmo instalando o certificado ROOT do servidor no Treo 750 do diretor (qdo digo o mesmo problema, é pq é exatamente o mesmo, rss) e não rodou de jeito nenhum, li e reli vários fóruns e discussões via google, e nada ainda, continuo obtendo o erro 0x80072F17. O aparelho pelo que me parece conecta no servidor (segundo os logs), inicia mostrando no display "Sincronyzing folders" e alguns segundos depois desconecta.

     Algum luz no fim desse túnel galera ??

     

    Obrigado;

     

    Luiz Orlandi

     

    terça-feira, 4 de setembro de 2007 14:16
  •  

    Senhores olhem este post e veja se ajuda

     

    http://www.pocketpcfaq.com/faqs/activesync/mis.htm

     

    If you see the error 80072F17 this means that your digital certificate has expired.  You need to install a new certificate on the device.  You will also see an error regarding the digital certificate if you access Outlook Web Access via your mobile device. Add Root Certificate - Pocket PC 2002. To install a PKCS12 certificate see Pocket PC 2003 Personal Certificate Import Utility or Windows Mobile 5.0 Personal Certificate Import Utility.   Also, you may find the Digital Certificates FAQ helpful.

     

    Caso não ajude tente usar este software para instalar o certificado no smartphone:

    WM5 - Security Manager  Tool

    Não recomendo pois ele tira todas as políticas de segurança do aparelho, mas em alguns testes aqui foi somente com ele que funcionou.

     

     

    Abraços

    Pedro Hernandes

    terça-feira, 4 de setembro de 2007 20:26
  • Pedro,

     

    Aonde eu consigo este programa? Procurei no Google e não achei.

     

    Abraços

     

    terça-feira, 4 de setembro de 2007 21:47
  • Isole o problema, tente fazer a sincronização desmarcando a opção "This server requires an encrypted (SSL)".

    Att,

    • Marcado como Resposta Richard Juhasz segunda-feira, 1 de novembro de 2010 18:33
    quarta-feira, 5 de setembro de 2007 03:09
  • Device Security Manager PowerToy for Windows Mobile 5.0:

    http://bink.nu/forums/p/8631/13445.aspx#13445

    http://www.microsoft.com/downloads/details.aspx?FamilyID=7e92628c-d587-47e0-908b-09fee6ea517a&displaylang=en

     

    Fica devendo essa hem  rsrsrs, brincadeira

     

    Desmarcar a opção de SSL

    Mas ai é totalmente porta 80, tipo, qualquer um pode ver o que está indo para o Smartphone

     

    Aqui na empresa a gente usa com SSL e funciona, então recomendo usar porta 80 somente para teste e em produção colocar através de SSL, 443.

     

    Mas, cada um cada um

    Abraços

    Pedro Hernandes

    • Marcado como Resposta Richard Juhasz segunda-feira, 1 de novembro de 2010 18:33
    quarta-feira, 5 de setembro de 2007 14:14
  • Foi isso que eu quiz dizer amigão , apenas para testes, vamos por partes, pois uso aqui também com SSL e funciona perfeito ! Pq se ai não funcinar nem com 80, o problema pode ser outro.

    quarta-feira, 5 de setembro de 2007 21:03
  •  

    Ufa , fiquei preocupado pois tem muita gente que por dificildade de entender e instalar SSL deixa sincronismo através da porta 80 direto no ambiente de produção

     

    Mas se é assim então blz, precisando estamos ai

    Abraços

    Pedro Hernandes

    sábado, 8 de setembro de 2007 12:57
  •  

    Outra dúvida ainda recorrendo ao mesmo tema:

     

    1 - Estamos com o servidor rodando um Ip dinâmico com um endereço do tipo dyndns.org, é fácilmente encontrado e operado via http://endereco.dyndns.org aparecendo a página do website padrão, e depois entrando no OMA, porém sempre me dá erro no certificado, a barra fica vermelha e tenho de clicar para prosseguir. Minha dúvida é: Como gerar o certificado correspondente a esse site/servidor ? e qual certificado tenho de instalar no Treo ??? Chquei os seguintes processos :

    a ) Firewall (portas configuradas em SSL )

    b) Serviços (Active Sync rodando e configurado nas contas)

    c) Todos os clientes Outlook recebendo e enviando e-mails via servidor

     

     

    Algum help galera ??? estou já há alguns dias nisso e não consigo de forma alguma conectar esse TREO no servidor, uma única vez houve conexão, porém se encerrou sem motivo aparente, nos logs aparece as conexões, mas nada é atualizado no aparelho.

     

    Obrigado;

     

    Luiz

    segunda-feira, 10 de setembro de 2007 14:16
  •  

    Aliás;

     

     Segue os logs abaixo, não sei mais o que fazer galera !!!

     

    #Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status
    2007-09-10 11:55:01 W3SVC1 192.168.0.10 OPTIONS /Microsoft-Server-ActiveSync User=stimoner&DeviceId=8436C5339B0F183EAC5904A45F255BA1&DeviceType=PocketPC&Log=VNATNASNC:0A0C0D0FS:0A0C0D0SP:0C0I0S0R0S0L0H 80 - 201.23.168.12 MSFT-PPC/5.1.2302 200 0 0
    2007-09-10 11:55:01 W3SVC1 192.168.0.10 POST /Microsoft-Server-ActiveSync User=stimoner&DeviceId=8436C5339B0F183EAC5904A45F255BA1&DeviceType=PocketPC&Cmd=GetHierarchy&Log=VNATNASNC:0A0C0D0FS:0A0C0D0SP:0C0I0S0R0S0L0H 80 - 201.23.168.12 MSFT-PPC/5.1.2302 403 0 0
    2007-09-10 12:05:06 W3SVC1 192.168.0.10 OPTIONS /Microsoft-Server-ActiveSync User=stimoner&DeviceId=8436C5339B0F183EAC5904A45F255BA1&DeviceType=PocketPC&Log=VNATNASNC:0A0C0D0FS:0A0C0D0SP:0C0I0S0R0S0L0H 80 - 201.23.168.12 MSFT-PPC/5.1.2302 200 0 0
    2007-09-10 12:05:06 W3SVC1 192.168.0.10 POST /Microsoft-Server-ActiveSync User=stimoner&DeviceId=8436C5339B0F183EAC5904A45F255BA1&DeviceType=PocketPC&Cmd=GetHierarchy&Log=VNATNASNC:0A0C0D0FS:0A0C0D0SP:0C0I0S0R0S0L0H 80 - 201.23.168.12 MSFT-PPC/5.1.2302 403 0 0
    2007-09-10 12:19:50 W3SVC1 192.168.0.10 OPTIONS /Microsoft-Server-ActiveSync User=stimoner&DeviceId=8436C5339B0F183EAC5904A45F255BA1&DeviceType=PocketPC&Log=VNATNASNC:0A0C0D0FS:0A0C0D0SP:0C0I0S0R0S0L0H 80 - 201.23.168.12 MSFT-PPC/5.1.2302 200 0 0

     

     

    Agradeço a ajuda de vcs.

     

    Luiz

    segunda-feira, 10 de setembro de 2007 18:05
  •  

    Luiz você reparou que esses logs mostram que o seu Device está sincronizando por porta 80 e não por 443 ??

     

    Você chegou a configurar as publicações dentro do IIS do servidor Exchange para que ele aceita SSL , 443 ??

     

    Conseguiu instalar o certificado no Treo ??

     

    Abraços

    Pedro Hernandes

    quarta-feira, 12 de setembro de 2007 19:42
  • Oi Pedro;

     

     Sim, sei que estava sendo feito pela 80, tentei com o SSL tb, mas assim tenho o erro de certificado, instalei o certificado no TREO, mas nada acontece. Apesar da prioriadade do cliente atualmente ser e-mails (o que consegui rodar via pop da própria máquina) eu realmente gostaria de fazer a sincronização completa.

     A conexão acontece pela 80, aparece sincornizando pastas, mas logo em seguida ele para, e algumas vezes aparece que a conta não está habilitada para uso com o aparelho, coisa que tenho certeza da configuração, outras simplesmente tenta sincronizar e cai a conexão.

     Não sei se informei, mas estou usando nesse servidor um daqueles serviços dyndns num Ajato de 2mb, não sei se isso têm influência, mas só agora me lembrei dessa informação.

     

    Obrigado pela colaboração e atenção de todos.

     

    Luiz

    quinta-feira, 13 de setembro de 2007 13:56
  • José Ricardo,

     

    Tente este procedimento que escrevi no meu Blog para gerar um instalador para o seu certificado:

    http://insidethevista.spaces.live.com/blog/cns!C77F6CD5622D6F7D!163.entry

     

    Caso ainda apareça algum erro, coloque aqui que eu tento te ajudar.

     

    Abraços,

     

    Allan Winckler

    Windows Mobile Training Specialist

    MCITP - Vista / MCTS - Vista / MCP - Server

    ITGROUP - MS GOLD Certified Partner
    allanw@itgroup.com.br

    quinta-feira, 27 de dezembro de 2007 16:36