none
Problema a juntar novo domain controller RRS feed

  • Pergunta

  • Boa tarde,

     

    Gostaria de saber se me podem ajudar, estou a instalar uma nova máquina Windows server 2003 R2 x64 na floresta da minha empresa, o que acontece é que quando tendo fazer o dcpromo este dá-me o seguinte erro:

     

    the operation failed because:

    System\currentControlSet/Services\ntfrs\parameters\sysvol\nome_do_dominio_da_empresa : The system cannot find the specified file

    "The  system cannot find the file specified"

     

    Já tentei fazer de tudo para conseguir fazer a promoção do servidor mas nada resultou.....:(

     

    Alguma ideia??

     

    Obrigado

    terça-feira, 18 de janeiro de 2011 11:46

Respostas

  • Bom dia,

    vc deve configurar esse novo servidor para usar um DNS Server que seja autoritativo para o domínio no qual ele está sendo inserido.

    Não esqueça de rodar o ADPREP na Floresta, caso não existam outros servidores R2 instalados.

    Att,


    Fabiano Barreira

    MCP + MCDST + MCSA & MCSE on Windows Server 2003 + MCTS + MCITP
    Blog - http://fabianobarreira.wordpress.com
    terça-feira, 18 de janeiro de 2011 13:22

Todas as Respostas

  • Dodomania,

    Proderia passar mais informações?

    Está tentando adicionar mais DC ao seu dominio, será um domínio filho? Uma nova árvore na floresta?

    Em que momento do DCPROMO essa mensagem é exibida?

    Você está informando o nome DNS do domínio principal? A configuração de DNS da máquina que está tentando promover está ok? Está na mesma rede ou em redes diferentes?

     

    ___________________________________________
    Elmo Baraúna (MCP - MCDST - MCSA - MCT)

    terça-feira, 18 de janeiro de 2011 12:25
    Moderador
  • Bom dia,

    verifique se alguma das soluções se aplica ao seu problema:

    http://support.microsoft.com/kb/308311

    http://technet.microsoft.com/en-us/library/bb727058.aspx

     


    Gilberto Soares Lopes http://videoedicas.blogspot.com/
    terça-feira, 18 de janeiro de 2011 12:31
  • Bom dia,

    vc deve configurar esse novo servidor para usar um DNS Server que seja autoritativo para o domínio no qual ele está sendo inserido.

    Não esqueça de rodar o ADPREP na Floresta, caso não existam outros servidores R2 instalados.

    Att,


    Fabiano Barreira

    MCP + MCDST + MCSA & MCSE on Windows Server 2003 + MCTS + MCITP
    Blog - http://fabianobarreira.wordpress.com
    terça-feira, 18 de janeiro de 2011 13:22
  • dê uma olhada nesse site.

     

    http://support.microsoft.com/kb/315457/pt-br


    Pedro Estigarribia Microsoft Certified Technology Specialist
    terça-feira, 18 de janeiro de 2011 14:51
  • Já corri o adprep e nada funcionou. o meu debug_log segue abaixo

     

    o meu log é o seguinte:

     

    Promotion request for replica domain controller
    01/18 16:04:44 [INFO] DnsDomainName  dominio_da_empresa
    01/18 16:04:44 [INFO]     ReplicaPartner  (NULL)
    01/18 16:04:44 [INFO]     SiteName  (NULL)
    01/18 16:04:44 [INFO]     DsDatabasePath  C:\WINDOWS\NTDS, DsLogPath  C:\WINDOWS\NTDS
    01/18 16:04:44 [INFO]     SystemVolumeRootPath  C:\WINDOWS\SYSVOL
    01/18 16:04:44 [INFO]     Account dominio_da_empresa\conta_para_adicionar_novo_dominio
    01/18 16:04:44 [INFO]     Options  131264
    01/18 16:04:44 [INFO] Validate supplied paths
    01/18 16:04:44 [INFO] Validating path C:\WINDOWS\NTDS.
    01/18 16:04:44 [INFO]     Path is a directory
    01/18 16:04:44 [INFO]     Path is on a fixed disk drive.
    01/18 16:04:44 [INFO] Validating path C:\WINDOWS\NTDS.
    01/18 16:04:44 [INFO]     Path is a directory
    01/18 16:04:44 [INFO]     Path is on a fixed disk drive.
    01/18 16:04:44 [INFO] Validating path C:\WINDOWS\SYSVOL.
    01/18 16:04:44 [INFO]     Path is on a fixed disk drive.
    01/18 16:04:44 [INFO]     Path is on an NTFS volume
    01/18 16:04:44 [INFO] Start the worker task
    01/18 16:04:44 [INFO] Request for promotion returning 0
    01/18 16:04:44 [INFO] Searching for a domain controller for the domain dominio_da_empresa that contains the account novo_servidor$

    01/18 16:04:44 [INFO] Located domain controller servidor_da_empresa for domain dominio_da_empresa

    01/18 16:04:44 [INFO] Using site Default-First-Site for server \\servidor_da_empresa

    01/18 16:04:44 [INFO] Forcing time sync
    01/18 16:04:44 [INFO] Forcing a time synch with \\servidor_Da_empresa

    01/18 16:04:44 [ERROR] Failed to get the current time on \\servidor_da_empresa: 5
    01/18 16:04:44 [ERROR] NON-FATAL error forcing a time sync (5).  Ignoring
    01/18 16:04:44 [INFO] Stopping service NETLOGON

    01/18 16:04:44 [INFO] Stopping service NETLOGON

    01/18 16:05:44 [INFO] Configuring service NETLOGON to 1 returned 0
    01/18 16:05:44 [INFO] Stopped NETLOGON
    01/18 16:05:44 [INFO] Deleting current sysvol path C:\WINDOWS\SYSVOL
    01/18 16:05:59 [INFO] Created system volume path
    01/18 16:05:59 [INFO] Copying initial Directory Service database file C:\WINDOWS\system32\ntds.dit to C:\WINDOWS\NTDS\ntds.dit

    01/18 16:05:59 [INFO] Error - System\CurrentControlSet\Services\NtFrs\Parameters\SysVol\dominio_da_empresa: The system cannot find the file specified.  (2)
    01/18 16:05:59 [INFO] Installing the Directory Service

    01/18 16:05:59 [INFO] Calling NtdsInstall for dominio_da_empresa
    01/18 16:05:59 [INFO] Starting Active Directory installation
    01/18 16:05:59 [INFO] Validating user supplied options
    01/18 16:05:59 [INFO] Determining a site in which to install
    01/18 16:05:59 [INFO] Examining an existing Active Directory forest
    01/18 16:06:00 [INFO] Configuring the local domain controller to host Active Directory
    01/18 16:06:00 [INFO] NtdsInstall for dominio_da_empresa returned 2
    01/18 16:06:00 [INFO] DsRolepInstallDs returned 2
    01/18 16:06:00 [ERROR] Failed to install to Directory Service (2)
    01/18 16:06:03 [INFO] Starting service NETLOGON

    01/18 16:06:03 [INFO] Configuring service NETLOGON to 2 returned 0
    01/18 16:06:03 [INFO] The attempted domain controller operation has completed

    01/18 16:06:03 [INFO] DsRolepSetOperationDone returned 0

     

    Alguma ideia?

     

    Obrigado!

    terça-feira, 18 de janeiro de 2011 16:19
  • Percebi que está tendo problema de sincronismo e hora, verifique se a hora dos dois servidores estão configuradas corretamente.
    Gilberto Soares Lopes http://videoedicas.blogspot.com/
    terça-feira, 18 de janeiro de 2011 16:34
  • Sim, confirmei que as horas e a data estão correctas.

     

    Tenho mais dois servidores na floresta e ambos estão com os fusos horários correctos.

    terça-feira, 18 de janeiro de 2011 16:45
  • Olá Dodomania.

    Além do fuso horário, a opção de horário de verão está marcada? 

     

    Abraço.

     


    Richard Juhasz http://www.forumguys.com.br/
    quinta-feira, 10 de março de 2011 18:20