none
Communicator não loga automaticamente (CERT OK, DNS OK) RRS feed

  • Pergunta

  • Communicator não loga automaticamente, Se eu for em configurações e colocar o servidor manualmente, o communicator conecta.

    Servidor padrao:  s2kad01.domain.com.br
    Address:  145.35.0.2

    > set type=srv
    > _sipinternaltls._tcp.domain.com.br
    Servidor:  s2kad01.domain.com.br
    Address:  145.35.0.2

    _sipinternaltls._tcp.domain.com.br     SRV service loc
              priority       = 0
              weight         = 0
              port           = 5061
              svr hostname   = srvocs.domain.com.br
    srvocs.domain.com.br   internet address = 145.35.0.200
    srvocs.domain.com.br   internet address = 145.35.0.199

    So falta isso pra ficar bonito aqui.

    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    quinta-feira, 25 de junho de 2009 14:15

Respostas

  • O seu dominio SIP também é domain.com.br?

    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 14:40
  • sim, mas o que eu quis dizer é se a entrada que você criou foi no dominio SIP?


    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 15:23
  • Ola Felipe,

    Junto com a dica do Bruno, Tu nao tá criando sip.dominio.com.br em uma zona empresa.local, correto? Tu está criando tudo na zona dominio.com.br? Quer dizer que agora o OCS communicator está fucnioanndo? Se a respsota for sim, tu nao havia testado a configuracao manual?
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 16:21
  • Opa Felipe,

    Sem stress, pode deixar pq tem os teus comentários neles que ficaram legais e vao ajudar outras pessoas. Eu vou tentar dar um merge neles, senao a gente deixa os tres, mas para os próximos a gente mantem o mesmo tópico que fica mais fácil, blz?

    Abracao.
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 17:31
  • E no event viwer do cliente? O que é logado?

    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 19:42
  • Ola Felipe,

    Junto com a dica do Bruno, para o logon do Communicator tu nao precisa do sip.domain.local, se o teu sip configurado no teu usuario é empresa.local e a zona também e empresa.local, ja deveria estar funcionando.

    Nao esqueça de habilitar o debug no communicator, em suma, tudo que foi visdto no outro tópico :)
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 19:45
  • Ola Felipe,

    Aqueles registros é o que o OCS busca por padrao, o que tá acontencendo é que tua zona DNS é difernete to teu SIP domain, tu tem que fazer split dns senao nao vai rolar mesmo.

    Abre o teu DNS server do teu controlador de dominio, qts zonas tu tem? Lista elas aqui, na verdade o pessoal tá batendo na mesma tecla desde o início, mas tu tava mexendo na zona errada :(
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 20:58
  • Ou então muda o dominio SIP para "senacrj.edu.br".


    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 21:22
  • Felipe,

    split dns nao é rocket science nem brain surgery, é tranquilo.  Se o interno é secarj.edu.br cria os certificados novamente para este dominio e adiciona ele na lista de sip domains suportados nas configuracoes globais, fora isso acompanha os logs do ocs communicator que nao tem erro.


    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    sexta-feira, 26 de junho de 2009 03:10
  • Felipe,

    Nao velho.. isto está escrito no tutorial que tu seguiu, mas nao importa tu ter o nome no certificado se tu nao tem no dns, nao adianta tu ter uma zona x.com.br apontando para y.com.br e tendo y.com.br no certificado.

    Garanta que o sip domain que tu quer usar nos usuarios, tenha o certificado para omesmo dominio e também o certificado tenha o mesmo. Se nao parecer complicado é pq tá certo.
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    sexta-feira, 26 de junho de 2009 17:01
  • Opa Felipe,

    Sem stress, o problema é que temos ficar nas boas praticas que desta forma fica facil, se o teu SIP que tu quer para os usuários é @rj.senac.br, tu obrigatoriamente tem que ter uma zona rj.senac.br, senao o automa'tico nao vai funcionar.

    Se nao quiser criar zona/split dns, configura manualmente ou atraves de politicas.


    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    sexta-feira, 26 de junho de 2009 17:42
  • Se tu considera suporte eu te cobro :) hehe

    Precisa ter o Outlook 2007 configurado corretamente como tambem os Webservices do Exchange 2007 funcionando, tu tem isso?
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    sexta-feira, 26 de junho de 2009 20:28
  • Abre um novo post para aquele erro pq este ficou muito extenso e como nao se trata da mesma coisa é melhor abrir um segundo.
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    sexta-feira, 26 de junho de 2009 20:29

Todas as Respostas

  • O seu dominio SIP também é domain.com.br?

    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 14:40
  • não...esse ai é so ilustrativo
    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    quinta-feira, 25 de junho de 2009 14:50
  • sim, mas o que eu quis dizer é se a entrada que você criou foi no dominio SIP?


    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 15:23
  • foi....sip.dominio.com.br o mesmo que ta no certificado e criado como dominio sip
    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    quinta-feira, 25 de junho de 2009 15:25
  • Ola Felipe,

    Junto com a dica do Bruno, Tu nao tá criando sip.dominio.com.br em uma zona empresa.local, correto? Tu está criando tudo na zona dominio.com.br? Quer dizer que agora o OCS communicator está fucnioanndo? Se a respsota for sim, tu nao havia testado a configuracao manual?
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 16:21
  • Vou explicar o cenario.

    possuo um dominio local chamado empresa.local.
    Criei um dominio sip no deploy do ocs chamado sip.empresa.local
    Vinculei ao certificado o nome do OCSserver e o nome de dominio sip=sip.empresa.local

    Fiz todas as configurações conforme o Anderson ensinou.
    O Communicator loga..só manualmente.

    E uma coisinha, coloquei o cwa no mesmo servidor, com ips diferentes para cada disco virtual do IIS, porém, não coloquei um certificado valido nele para nao dar problema,
    o CWA funciona normalmente porém dando o velho erro de certificado e por enquanto não está me incomodando pois está funcionando.

    Fiz outro post também querendo saber da exclamação que aparece no communicator falando que não consegue conectar com o adress book do exchange.


    No geral fiz uma cagada aqui criando 3 posts pra coisas diferentes, estarei deletando, Desculpe.
    Fora isso tudo está funcionando.

    Só faltando esses "pequenos"detalhes se alguem poder me socorrer serei eternamente grato.

    Obrigado



    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    quinta-feira, 25 de junho de 2009 17:27
  • Opa Felipe,

    Sem stress, pode deixar pq tem os teus comentários neles que ficaram legais e vao ajudar outras pessoas. Eu vou tentar dar um merge neles, senao a gente deixa os tres, mas para os próximos a gente mantem o mesmo tópico que fica mais fácil, blz?

    Abracao.
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 17:31
  • Vamos primeiro ao problema do automatic configuration.

    A entrada SRV _sipinternaltls você tem que criar na mesma zona de domínio que está depois do @ quando você entra no Communicator.

    Por exemplo se no Communicator Cliente quando você vai entrar você digita bruno@estrozi.local é no dominio estrozi.local que você tem que criar esta entrada. Mesmo se o dominio do seu AD for laboratorio.local você tem que criar no dominio estrozi.local.

    Outra coisa, cria neste mesmo dominio "estrozi.local" uma entrada do tipo A com o nome SIP então ficaria "sip.estrozi.local" e quando você pingar esta entrada tem que responder pelo IP que o Front-End está configurado.

    Caso nada disso funcione, habilita o log do cliente do Communicator e tenta entrar, no event viewer vai dizer quais entradas ele está procurando e não está encontrando, ai você posta ak.

    Obs.: Os domínios que eu citei são só exemplos.

    [],

    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    quinta-feira, 25 de junho de 2009 18:02
  • Bruno,

    O sipinternaltls ta criada desse jeito mesmo, ta apontando pro empresa.local, tive o cuidado de manter os mesmos nomes no domain sip e no domain local, pra nao ter este tipo de problema, a unica coisa que eu nao fiz que vou fazer agora é esse lance da entrada sip.empresa.local tipo A apontando pro FE, coisa que eu nao fiz, vamo ver se resolve.

    Ja dou um retorno pra ver se funcionou

    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    quinta-feira, 25 de junho de 2009 18:59
  • Bruno, Não funcionou cara, demora bastante pra logar gera o erro falando que o server está indisponível.
    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    quinta-feira, 25 de junho de 2009 19:32
  • E no event viwer do cliente? O que é logado?

    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 19:42
  • Ola Felipe,

    Junto com a dica do Bruno, para o logon do Communicator tu nao precisa do sip.domain.local, se o teu sip configurado no teu usuario é empresa.local e a zona também e empresa.local, ja deveria estar funcionando.

    Nao esqueça de habilitar o debug no communicator, em suma, tudo que foi visdto no outro tópico :)
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 19:45
  • Vou colocar como são as coisas aqui nao vo tentar mudar os nomes pra vcs entenderem ate mesmo quem ve os dominios com nomes reais nao entendem.

    Tenho 4 meses de casa, peguei o primeiro pipino refazer as regras do ISA, agora o OCS caiu nas minhas costas.

    Os logs

    OCS Server
    Erro
    The process ASMCUSvc(2344) failed to send health notifications to the MCU factory at https://srvocs.senacrj.edu.br:444/LiveServer/MCUFactory/.
    Failure occurrences: 5, since 24/6/2009 18:39:31.


    Warning
    One or more phone numbers failed to normalize.

    936 total numbers failed to normalize. They are listed in the text file: 'C:\Arquivos de programas\Microsoft Office Communications Server 2007 R2\Web Components\Address Book Files\Files\Invalid_AD_Phone_Numbers.txt'
    Cause: One or more phone number attributes in Active Directory contained text that could not be normalized. Normalization rules are contained in the optional Company_Phone_Number_Normalization_Rules.txt file located in the output location or in the generic rules built into Address Book Server. Refer to the documentation for a description of the built-in generic normalization rules. Use the ABServer -dumpRules command to see all the rules that Address Book Server is currently configured with.
    Resolution:
    Either create a Company_Phone_Number_Normalization_Rules.txt file in the output location and make sure it covers all cases found in your Active Directory deployment or fix the invalid phone number(s) in the Active Directory record(s).


    -

    Agora o Communicator

    O Communicator não pôde resolver o nome de host DNS do servidor de logon sipinternal.rj.senac.br.
     
     Solução:
     Se você estiver usando configuração manual no Communicator, verifique se o nome do servidor foi digitado corretamente e por completo. Se estiver usando configuração automática, o administrador de rede precisará verificar a configuração do registro DNS A para o sipinternal.rj.senac.br, pois ele não pôde ser resolvido.

    O Communicator não pôde resolver o nome de host DNS do servidor de logon sipexternal.rj.senac.br.
     
     Solução:
     Se você estiver usando configuração manual no Communicator, verifique se o nome do servidor foi digitado corretamente e por completo. Se estiver usando configuração automática, o administrador de rede precisará verificar a configuração do registro DNS A para o sipexternal.rj.senac.br, pois ele não pôde ser resolvido.

    O Communicator não pôde resolver o nome de host DNS do servidor de logon sip.rj.senac.br.
     
     Solução:
     Se você estiver usando configuração manual no Communicator, verifique se o nome do servidor foi digitado corretamente e por completo. Se estiver usando configuração automática, o administrador de rede precisará verificar a configuração do registro DNS A para o sip.rj.senac.br, pois ele não pôde ser resolvido.

    -

    Comentario
    Sinceramente não sei do que se trata esse Externao e internal,não publiquei nada disso aqui, a unica coisa que fiz foi no subject name do certificado foi publicar dois nomes sip.rj.senac.br e sip.senacrj.edu.br.

    Aqui esses DNS
    rj.senac.br é o Externo

    senacrj.edu.br é o interno do dominio 

    Não me perguntem o porque, quando entrei ja estava assim

    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    quinta-feira, 25 de junho de 2009 20:24
  • Ola Felipe,

    Aqueles registros é o que o OCS busca por padrao, o que tá acontencendo é que tua zona DNS é difernete to teu SIP domain, tu tem que fazer split dns senao nao vai rolar mesmo.

    Abre o teu DNS server do teu controlador de dominio, qts zonas tu tem? Lista elas aqui, na verdade o pessoal tá batendo na mesma tecla desde o início, mas tu tava mexendo na zona errada :(
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 20:58
  • Ou então muda o dominio SIP para "senacrj.edu.br".


    Bruno Estrozi - MCSE/MCTS/MCITP - Unified Communications Specialist
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    quinta-feira, 25 de junho de 2009 21:22
  • Split DNS não pelo amor de Deus.

    DNS Externo;

    www.rj.senac.br
    www.senacrio.com.br

    Interno

    senacrj.edu.br (somente)


    Na primeira vez fiz dois dominios sip, um rj.senac.br e ou senacrj.edu.br só que eu setava o rj.senac.br porém o senacrj.edu.br era o sip primario, tanto que eu tentei remover ele e não consegui.

    Vou tentar criar um novo dominio sip como senacrj.edu.br, nem vou mexer no certificado pq ele ja ta com subjects names pra sip.senacrj.edu.br e sip.rj.senac.br


    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    quinta-feira, 25 de junho de 2009 23:50
  • Felipe,

    split dns nao é rocket science nem brain surgery, é tranquilo.  Se o interno é secarj.edu.br cria os certificados novamente para este dominio e adiciona ele na lista de sip domains suportados nas configuracoes globais, fora isso acompanha os logs do ocs communicator que nao tem erro.


    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    sexta-feira, 26 de junho de 2009 03:10
  • Pois então Anderson, foi isso que eu fiz da primeira vez,

    O certificado está assim

    subject name ; srvocs.senacrj.edu.br

    subject alternate name; sip.rj.senac.br,senacrj.edu.br,srvocs(esse eu coloquei pra nao precisar colocar o nome complento na configuração manual do communicator0

    e no global settings>settings>domains
    sip.rj.senac.br
    sip.senacrj.br



    e o sip.rj.senac.br ta com a flag.

    se é isso o que tu ta falando pra eu fazer eu ja fiz, no momento que levantei o server


    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    sexta-feira, 26 de junho de 2009 13:18
  • Anderson, olha que doidera

    Revisei meus dns internos, ate ai tudo bem, ai reparei o seguinte, a entrada A do srvocs estava duplicada uma apontando pro ip 199 e outra com mesmo nome apontando pro 200, deletei a que apontava pro 199 e conectou no communicator pelo automatico, porém eu desloguei e tentei conectar novamente e nao foi.


    Agora que nao to entendendo mesmo o problema.

    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    sexta-feira, 26 de junho de 2009 13:52
  • Felipe,

    Nao velho.. isto está escrito no tutorial que tu seguiu, mas nao importa tu ter o nome no certificado se tu nao tem no dns, nao adianta tu ter uma zona x.com.br apontando para y.com.br e tendo y.com.br no certificado.

    Garanta que o sip domain que tu quer usar nos usuarios, tenha o certificado para omesmo dominio e também o certificado tenha o mesmo. Se nao parecer complicado é pq tá certo.
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    sexta-feira, 26 de junho de 2009 17:01
  • Anderson, sei que ja ta ficando chato isso, sei mesmo.
    entao vou te mostrar todas as configurações importantes daqui.

    SRV sipinternatls - apontado pro srvocs.senac.rj.br

    CNAME AS - apontando para cwa.senacrj.edu.br
       DOWNLOAD - apontando para cwa.senacrj.edu.br

    A  srvocs.senacrj.br - apontando para 145.35.0.200
    A  cwa.senacrj.edu.br - apontando para 145.35.0.199

    Certificado

    Subject Name - srvocs.senacrj.edu.br
    Subject Alternate name - sip.rj.senac.br,sip.senacrj.edu.br,srvocs

    SIP

    sip.rj.senac.br
    sip.senacrj.edu.br


    Ps. coloquei meu usuario com @senacrj.edu.br reiniciei os serviços. e assim loga no automatico, porém eu nao posso usalo assim.

    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    sexta-feira, 26 de junho de 2009 17:36
  • Opa Felipe,

    Sem stress, o problema é que temos ficar nas boas praticas que desta forma fica facil, se o teu SIP que tu quer para os usuários é @rj.senac.br, tu obrigatoriamente tem que ter uma zona rj.senac.br, senao o automa'tico nao vai funcionar.

    Se nao quiser criar zona/split dns, configura manualmente ou atraves de politicas.


    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    sexta-feira, 26 de junho de 2009 17:42
  • Confirmou o que eu ja estava esperando, vou deixar @senacrj.edu.br mesmo pois dessa maneira ele fica melhor em pois configura automatico, e nao fica pedindo usuario e senha quando o usuario entra no cwa.

    Muito Obrigado pelo Suporte.

    Sem querer abusar mas ja abusando é o seguinte.

    o cliente está funcionando tudo bem, configuração automatica, agora esta aparendo uma mensagem no menu de notificações que é a seguinte

    O Communicator está tentando localizar os serviços web do exchange. As informações do calendário do Outlook e a mensagem de ausência temporária talvez não estejam disponiveis e suas chamadas talvez não sejam encaminhadas com base no seu horario de trabalho.

    Sabe do que se trata?

    não aparece nada no log do communicator. e os logs que tem no FE sao os mesmos la de cima do topico

    Felipe Mendes D dos Santos MCP | MCDST | MCSA
    sexta-feira, 26 de junho de 2009 20:19
  • Se tu considera suporte eu te cobro :) hehe

    Precisa ter o Outlook 2007 configurado corretamente como tambem os Webservices do Exchange 2007 funcionando, tu tem isso?
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    sexta-feira, 26 de junho de 2009 20:28
  • Abre um novo post para aquele erro pq este ficou muito extenso e como nao se trata da mesma coisa é melhor abrir um segundo.
    Grande abraço, Anderson Patricio http://www.andersonpatricio.org .:. http://blog.andersonpatricio.org http://msmvps.org/blogs/andersonpatricio
    • Marcado como Resposta Felipe Mendes domingo, 28 de junho de 2009 17:12
    sexta-feira, 26 de junho de 2009 20:29