none
Casa Decimal IIS 6.0 RRS feed

  • Pergunta

  • Prezados,

    Eu tenho um Portal Educacional da RM Sistemas em ASP.NET. rodando no meu IIS 6.0
    Sempre funcionou bem no Windows 2003 server Brazilian x32 antigo que eu tinha.
    Por varios motivos reinstalei o Servidor e coloquei a Versao 2003 English x32 R2.
    Ok Funcionando.

    Porem os professores começaram a lancar as notas dos alunos no portal..tudo perfeiro..
    Só que algumas notas que no banco de dados aparecem corretamente como 7,7 ou 3,6..enfim
    No Portal Academico via web..esta aparecendo 77,00 ou 36,00 ..etc..etc.
    O engraçado é que notas inteiras tipo 1,0 ou 2,0 aparecem no portal academico correto.. 1,0 .. 2,0..enfim..

    Ja alterei os idiomas regionais do meu novo servidor p/ portuguese (brazil) ..etc..

    Mas nada...alguem teria alguma dica se há alguma configuracao no IIS que eu possa alterar?!?

    Ricardo Manica
    quarta-feira, 29 de abril de 2009 17:31

Respostas

  • Entendo, Ricardo. Bem, eu não estou vendo o servidor, mas já tive um problema como esse e a solução foi alterar as configurações regionais do sistema no servidor. Tem certeza de que não está faltando nada nessa configuração?

    Um abraço,

    Igor Humerto
    • Sugerido como Resposta pabloce terça-feira, 5 de maio de 2009 21:40
    • Marcado como Resposta pabloce quarta-feira, 6 de janeiro de 2010 11:27
    quinta-feira, 30 de abril de 2009 14:27

Todas as Respostas

  • Fala Ricardo!

    Tudo bem?

    Meu amigo, posso estar errado, mas a formatação dos dados e consequentemente a aparência que os mesmos devem apresentar não deve ser ajustada no código da página? Tipo, acho que quem deve fazer isso é o desenvolvedor da página, pois, caso contrário, sempre que o idioma do sistema for diferente, você vai precisar se preocupar com isso. Com a alteração sendo feita diretamente no código (e existe meio de fazer isso até em javascript), você nunca teria esse tipo de problema.


    Sendo assim, a minha sugestão seria a de que você falasse com a equipe de desenvolvimento para tentar ajustar o código da página ao invés de precisar fazer a configuração no servidor.

    Um abraço,

    Igor Humberto
    quinta-feira, 30 de abril de 2009 14:07
  • Fala Igor, blz?

    é que tenho um certo problema com o Desenvolvedor, é uma empresa muito grande e esse sistema é "fechado"digamos.
    Para fazer alguma anteracao no código vai me custar muito tempo e dinheiro.
    Por isso eu estou pensando em alterar algo no proprio servidor.
    Mas já estou vendo que a solucao mais rapida para o meu caso é reinstalar o servidor na linguagem Brazilian mesmo.

    Valeu a ajuda..
    Abraços
    quinta-feira, 30 de abril de 2009 14:10
  • Entendo, Ricardo. Bem, eu não estou vendo o servidor, mas já tive um problema como esse e a solução foi alterar as configurações regionais do sistema no servidor. Tem certeza de que não está faltando nada nessa configuração?

    Um abraço,

    Igor Humerto
    • Sugerido como Resposta pabloce terça-feira, 5 de maio de 2009 21:40
    • Marcado como Resposta pabloce quarta-feira, 6 de janeiro de 2010 11:27
    quinta-feira, 30 de abril de 2009 14:27
  • Eu também tive o mesmo poblema e resolvi alterando as configurações regionais.
    Pablo Weyne - IIS - http://pabloweyne.spaces.live.com/blog
    • Sugerido como Resposta pabloce terça-feira, 5 de maio de 2009 21:40
    terça-feira, 5 de maio de 2009 21:40