none
Configurando a autenticação de usuários no ISA Server RRS feed

  • Pergunta

  • Bom galera, realizei a instalação do Isa server 2006 em meu servidor Windows Server 2003, criei uma regra a onde eu liberei acesso a internet a todos os usuarios, resolvi fazer uma configuração a onde as informação do proxy seja passado por DHCP, configurando WPAD (Web Proxy Autodiscovery Protocol), ido ate "auto discovery" e habilitado ""publish automatic discovery information for this network" mas agora gostaria que os usuarios autenticasse no momento de navegar na internet, li alguns tutoriais e achei o processo bem simples, fui ate aba "Web Browser -> Authentication -> [x]Require all users to authenticate" o problema que não esta funcionado. 
    Pode ser que tenha feito a co0ngigurançãp WPAD?
    Fico muito grato pela ajuda

    Clayton Agenil da Silva
    quinta-feira, 22 de setembro de 2011 20:26

Respostas

Todas as Respostas

  • Clayton, o que não ta funcionando?

    Os usuários nao navegam?

    Você monitorou o trafego nos logs do ISA? Não aparece como autenticado?

     


    Renato Marson Pagan http://renatopagan.wordpress.com/
    quinta-feira, 22 de setembro de 2011 20:45
  • Caro Renato.

    Os usuarios navegam, mas não aparece a tela de logon para os usuarios realizar a autenticação


    Clayton Agenil da Silva
    sexta-feira, 23 de setembro de 2011 11:29
  • Clayton, esse comportamento é o normal e esperado.

    As máquinas clientes que estão no dominio fazem autenticação integrada.

    O navegador se autentica no ISA utilizando o usuário que está logado na máquina.

    Se você for no Monitoring do ISA irá ver que as conexões estão autenticadas.

     

    Ele só pede usuário e senha se a maquina cliente nao está no dominio.


    Renato Marson Pagan http://renatopagan.wordpress.com/
    sexta-feira, 23 de setembro de 2011 11:56
  • Caro Renato, se possível retira a autenticação e força que o usuário entrasse com senha quando fosse abri o IE.

    Outra coisa eu configurei o meu servidor para que as informações do proxy seja passada via DHCP via WPAD, criado um HOST(A) no meu DNS e criado uma politica no GPO a onde de faz a detecção do proxy automaticamente, no Isa habilitei  WPAD (Web Proxy Autodiscovery Protocol), ido ate "auto discovery" e habilitado "publish automatic discovery information for this network" , desta forma não necessido coloca as informações do proxy no internet.

    No inicio estava funcionado normalmente, mas agora parou de funciona, não sei ao certo o que ocorreu, mas passou não funciona depois que eu tentei configurar autenticação na aba "Web Browser -> Authentication -> [x]Require all users to authenticate" 

    Bom cara, sou novato na parte de configuração do Isa, estou lendo varios tutoriais, o problema que este tutorias, te ensina a configura mas não resolver possível problema que possa ocorre. 


    Clayton Agenil da Silva
    sexta-feira, 23 de setembro de 2011 12:36
  • Bom Dia!

     

    Estou passando por uma situação identica ao tema relacionado ao acesso webmail interno.

    Todo Usuário que acessa do navegador Internet Explorer para acessar o webmail interno fica solicitando costantemente login e senha do usuario, sendo no Navegador Firefox (Mozila) o acesso ao webmail funciona normalmente. Criei uma regra no ISA liberando o acesso total para o endereço do webmail, mas mesmo assim no navegador internet explorer a autenticação persiste. Segue abaixo como é o meu ambiente de rede.

    - Ambiente de Rede.

    A plataforma que habilitei aos usuarios da rede interna, é que todo computador fora do dominio no caso usuarios que tenham equipamentos pessoais como notebook, que ele solicite o login e senha do usuario p/ a liberação da internet, no caso os computadores que estão no dominio essa solicitação não é feita.

     

    Exemplo: login: contoso\rgemaque para liberar a internet.

     

    Por favor peço por gentileza se alguem pode ajudar a solucionar este problema.

     

    Desde já agradeço pela ajuda.

     

    Atenciosamente,

     

    Ronaldo Gemaque

    quinta-feira, 20 de outubro de 2011 15:23
  • Clayton, Por acaso após ter feito a configuração do AutoDiscovery, nao criaste algum bloqueio que impeça que os computadores clientes possam acessar o servidor que contenha o wpad?

    quando isto me ocorreu, criei uma regra que libera o acesso ao DHCP, tanto para Pedido como para Resposta na rede local e também criei outra regra liberando o protocolo HTTP para o endereço onde esta o WPAD, por ex:    http://foo.com/wpad.dat

    E lembre-se de mover estas duas regras para o topo da lista,

    e não exigir que todos os usuários tenham que fazer logon, para que tal regra possa ser executada antes mesmo do usuário ter logado, e assim capturar o endereço do DHCP junto com a configuração do autoproxy


    Buscamos saber quem somos, mas somos aquilo que buscamos. [FSPR]

    domingo, 4 de março de 2012 18:55
  • Bom dia !

    Srs, seguindo as perguntas acima e respostas, verifico no monitoramento do isa server por exemplo pego um ip de uma maquina e start query, peço para o usuario começar a navegar e ao passo que fico monitorando vejo que hora aparece o dominio/usuario logado, hora aparece o dominio/ADM da Rede logado.

    Como fazer para que somente apareça o usuario que esta logado mesmo na maquina ?? Ai sim poderei configurar as regras corretamente, o que devo fazer ???

    Grato

    Roger 


    Rinco - www.rincko.com.br

    sexta-feira, 30 de novembro de 2012 13:33
  • Boa tarde, Rinco!

    Na regra que aparece, exemplo: Acesso a Internet esta marcado como ALL Authenticated User ou um grupo especifico com os usuários? 

    Se o usuário se logar e tentar acessar a internet, ele vai passar pela regra, mas autenticando o usuário que esta com o logon na máquina, não poderia, informar outros usuários.

    Tentou fazer em sua máquina ou em outras para ver se o problema aparece?


    Douglas Urbano

    sexta-feira, 30 de novembro de 2012 17:32
  • Boa tarde, Rinco!

    Seu problema foi solucionado?


    Douglas Urbano

    segunda-feira, 3 de dezembro de 2012 17:02
  • Boa tarde !

    Douglas, desculpe nao ter respondido mais rapido, o problema ainda nao foi solucionado.

    Respondendo ao seu questionamento:

    "Na regra que aparece, exemplo: Acesso a Internet esta marcado como ALL Authenticated User ou um grupo especifico com os usuários? "

    Nesta regra eu tenho grupos que estao relacionados aos meu grupos de usuarios do AD, porem tem um detalhe, quando uma maquina nova é configurada para o dominio e no IE que no caso aqui configuro o proxy apontando para onde esta meu Isa, quando testo o acesso a internet, geralmente ele pede  dominio/usuario e senha, entao era colocado o usuario do Administrador / senha. Depois não é mais pedida senha alguma, e o usuario pode navagar normalmente. 

    Tem como reverter isso e fazer este primeiro acesso com o proprio usuario logado na maquina ?? ou algo que limpe ...

    Grato pela ajuda...


    Rinco - www.rincko.com.br

    segunda-feira, 3 de dezembro de 2012 17:47
  • Boa tarde, Rinco!

    Entendi o porque do usuário administrador. Você loga com este usuário, fica com a sessão do admin, esta forma, é incorreta, na verdade, o correto é configurar a descoberta automática, para isso, você pode seguir este tutorial:

    http://www.isaserver.org/tutorials/Configuring_Automatic_Discovery_for_ISA_Server_Clients.html

    Feito isso, no seu servidor, acesse sua console de GPO, e configura automatico, ou seja, quando você adicionar uma máquina no dominio, ou mesmo, as que já estão, automaticamente, ele vai preencher os campos do proxy para você, exemplo, imaginando que seu ISA tem o IP: 192.168.0.1, ele configuraria para vocÊ e com a porta, exemplo: 8080

    http://blogs.technet.com/b/wokubo/archive/2010/11/02/como-configurar-internet-explorer-proxy-settings-via-gpo.aspx

    Com isso, quando o usuário se logar, não mais, pedirá usuário e senha, e sim, o seu firewall vai verificar se o usuário esta dentro do acesso permitido, se estiver, acessa a net, se não, o acesso é negado.


    Douglas Urbano



    • Editado Douglas Urbano segunda-feira, 3 de dezembro de 2012 18:49
    • Marcado como Resposta Ricardo Russo terça-feira, 11 de dezembro de 2012 12:30
    segunda-feira, 3 de dezembro de 2012 18:47