none
Excel introdução de formula RRS feed

  • Pergunta

  • Boa noite,

    Pretendo inserir numa planilha de Excel, um lembrete a cada 7 dias.

    O calculo deve ser efetuado a partir de uma célula de introdução manual e o resultado que pretendo devolvido, deve ser igual ou superior a hoje().

    Por exemplo: na célula A1 coloco a data 01-11-2016, pretendo que na célula A2 me seja devolvida a informação da próxima data do lembrete que, sendo hoje dia 27, deve devolver o próximo dia 29-11-2016. Quando chegar ao dia 29 a informação deve ser do dia 06-12-2016...

    Agradecia a vossa ajuda para solucionar este problema.

    Obrigado

    domingo, 27 de novembro de 2016 22:17

Todas as Respostas

  • Olá. Desculpe-me mas, não entendi a relação do valor de entrada com o dia do lembrete. 

    Bom, sendo hoje dia 27, e você quer dia 29, basta: =HOJE()+2

    domingo, 27 de novembro de 2016 23:00
  • Boa tarde,

    O que pretendo é que a formula efetue o calculo de um lembrete a cada sete dias a partir do campo de introdução manual e que me mostre o próximo lembrete a partir de hoje inclusive.

    No caso, referi o dia 29 que resulta da soma de 1+7=8+7=17+7=22+7=29.

    No dia 30-11-2016 deverá aparecer a data de 06-12-2016.

    Obrigado

    APinto

    segunda-feira, 28 de novembro de 2016 15:12
  • Veja se esta fórmula funciona: 

    =SE(HOJE()-A1>7;A1+(7*(QUOCIENTE(HOJE()-A1;7)+1));SE(OU(HOJE()-A1=7;HOJE()-A1=0);HOJE()+7;"Datas Inconsistentes"))

    Se não funcionar, deixe-me saber.


    segunda-feira, 28 de novembro de 2016 16:57
  • Olá Maurício,

    Está em falta a mensagem com o próprio dia, isto é, quando o 7º dia é hoje ele mostra a data do próximo lembrete e não a data de hoje.

    Se o registo foi feito no dia 21 ele deve mostrar o lembrete de hoje dia 28 e não o de dia 5/12.

    Obrigado

    APinto

    segunda-feira, 28 de novembro de 2016 22:41
  • Bom, tentei corrigir conforme sua necessidade. Verifique se agora atende.

    =SE(E(HOJE()-A2>=0;HOJE()-A2<7); A2+ 7;SE(HOJE()-A2=7; HOJE();SE(HOJE()-A2>7;SE(MOD(HOJE()-A2;7) > 0;A2+(7*(QUOCIENTE(HOJE()-A2;7)+1));A2+(7*(QUOCIENTE(HOJE()-A2;7))));"Datas inconsistentes")))

    terça-feira, 29 de novembro de 2016 10:15
  • Olá Maurício,

    Esta fórmula está pior. Vou propor outra forma.

    O que eu pretendo é só que numa determinada célula me apareça a data do lembrete.

    Imaginemos o seguinte: eu tenho um pequeno ficheiro de 6 colunas em que na primeira célula (A1) coloco uma data POR EXEMPLO 23-11-2016.

    Se eu construir uma tabela a partir da coluna AA até AH com as formulas =SE(A1=0;" ";(A1+7)), =SE(A1=0;" ";(A1+14)), =SE(A1=0;" ";(A1+21)) ... essa tabela fica assim; 30-11-2016 - 07-12-2016 - 14-12-2016 - 21-12-2016 - 28-12-2016 - 04-01-2017 - 11-01-2017 e 18-01-2017.

    Você constrói uma fórmula para mostrar na célula B1 a próxima data do lembrete a partir desta tabela?

    Nesse caso, a informação a mostrar na célula B1 até ao dia 30-11-2016 será 30-11-2016, a partir do dia 01-12 até ao dia 07-12-2016 será 07-12-2016 ...

    Parece mais fácil?

    Agradeço a sua paciência

    terça-feira, 29 de novembro de 2016 12:09
  • Bom... A fórmula anterior atende o que você especificou. Sinto muito, mas não entendi a nova abordagem.
    • Editado J. Maurício terça-feira, 29 de novembro de 2016 12:28
    terça-feira, 29 de novembro de 2016 12:28
  • Boa tarde,

    Talvez tenha complicado a questão.

    Pretendo uma formula para a célula B1 que procure na tabela de uma linha que vai de AA1 a AH1 uma data que deve ser igual a hoje ou, sendo superior, seja a mais próxima de hoje.

    Talvez desta forma simplifique a resposta

    Obrigado

    terça-feira, 29 de novembro de 2016 15:11
  • Boa tarde. Se possível, anexe uma imagem com o layout de sua tabela;
    • Editado J. Maurício terça-feira, 29 de novembro de 2016 15:47
    terça-feira, 29 de novembro de 2016 15:47
  • Olá Maurício,

    Estive ausente e não vim à net.

    A minha conta não permite associar imagens, posso enviar por email?

    Apenas pretendo uma formula que procure numa tabela em linha com o máximo de 8 células, a data no futuro igual a hoje ou posterior.

    Obrigado, 

    quarta-feira, 30 de novembro de 2016 23:26
  • Boa noite.

    Supondo que você tenha o arranjo abaixo no qual a célula A1 é de entrada manual e nas demais vai se acrescentando mais 7 dias em relação à célula da coluna imediatamente à esquerda.

    Use a fórmula abaixo para trazer o valor de data maior ou igual a hoje que esteja contida no arranjo.

    =SE((SEERRO(CORRESP(HOJE();A1:H1;0);0))>0;HOJE();ÍNDICE(A1:H1;1;CORRESP(HOJE();A1:H1;1)+1))

    Se não for esse o comportamento esperado, deixe-me saber.



    • Editado J. Maurício quinta-feira, 1 de dezembro de 2016 00:19
    quinta-feira, 1 de dezembro de 2016 00:17
  • Olá Maurício

    Esta formula está bem para datas antigas ou cujo resultado do primeiro calculo de 7 dias seja até hoje.

    Por exemplo 18-11-2016 resulta em 02-12-2016 porque é o segundo calculo, a data de 24-11-2016 tem como resultado 01-12-2016 e todas as datas anteriores também estão bem.

    Falta algo para as datas com resultado no futuro, se eu registar datas a partir de 25 o resultado é #N/D.

    Obrigado

    quinta-feira, 1 de dezembro de 2016 14:04
  • Isso é óbvio. Qual seria o critério para escolher a data se a primeira do intervalo for maior que HOJE()? 

    A única possibilidade que vejo é devolver a própria célula A1:

    =SE(A1>HOJE();A1;SE((SEERRO(CORRESP(HOJE();A1:H1;0);0))>0;HOJE();ÍNDICE(A1:H1;1;CORRESP(HOJE();A1:H1;1)+1)))

    • Editado J. Maurício quinta-feira, 1 de dezembro de 2016 14:46
    • Marcado como Resposta Guilherme Macedo S quinta-feira, 1 de dezembro de 2016 16:45
    • Não Marcado como Resposta ToninhoZé quarta-feira, 15 de março de 2017 15:55
    quinta-feira, 1 de dezembro de 2016 14:16
  • Ok Maurício,

    Solução encontrada, problema resolvido.

    Obrigado,

    quinta-feira, 1 de dezembro de 2016 15:43
  • Disponha. Se possível, marque meu post anterior na opção "Propor como Resposta" para ajudar outras pessoas com problema semelhante. Obrigado.
    • Editado J. Maurício quinta-feira, 1 de dezembro de 2016 15:52
    quinta-feira, 1 de dezembro de 2016 15:52