none
Instalar Remover Progamas - Windows 7

    Pergunta

  • Amigos,

    Boa tarde. Hoje me apresentou o seguinte problema no Windows 7:
    Ao tentar Instalar e ou Remover algum programa, exibe-se a seguinte mensagem:

    "Another installation is in progress. You must complete that installation before continuing this one."

    Ja reiniciei a maquina;
    Ja restaurei a ponto de restauração anterior ao problema (que começou a ser exibido hoje pela manhã).

    Mas o problema persistiu.

    Alguem tem alguma dica?
    sexta-feira, 25 de setembro de 2009 18:23

Respostas

  • Acesse iniciar > programas . acessórios 
    Clique em  prompt de comando com botão direito
    Selecione executar como administrador
    Digite os comandos abaixo

    - msiexec /unregister 
    - msiexec /regserver 

    Efetue novo teste após isso

    Caso persista utilize o utilitário de limpeza do Windows Installer para efetuar a limpeza de instalações incompletas
    http://support.microsoft.com/kb/290301

    Caso ainda persista após isto efetuar a documentação abaixo apartir do método 4
    http://support.microsoft.com/kb/555175

    Aguardo a resposta

    Att, Daniel U. Silva - Analista de suporte MCTS Windows Vista / Windows 7 / Windows Server 2008 / Sharepoint Server
    • Marcado como Resposta Karlos Morais segunda-feira, 28 de setembro de 2009 18:32
    segunda-feira, 28 de setembro de 2009 17:49

Todas as Respostas

  • Acesse o msconfig (Iniciar > Executar  > msconfig)
    Efetue uma inicialização limpa marcando a opção
    - Inicialização seletiva
    E desmarcando
    - Carregar itens de inicialização
    Acesse a guia serviços e oculte os serviços Microsoft
    Desmarque todos os outros
    Aplique e reinicie

    Provavelmente solucione o problema, é provável que algum software esteja tentando concluir a instalação e esteja travado e inicie sempre junto com a máquina.

    Se persistir poste novamente para analisarmos melhor o que ocorre
    Tente incluir um print de tela do gerenciador de tarefas (ctrl+shift+esc) na guia de processos
    Att, Daniel U. Silva - Analista de suporte - Designer web
    sexta-feira, 25 de setembro de 2009 18:57
  • Cara va em:

    Iniciar  > executar > regedit

    (HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ Installer \ InProgress )

    clique com o botão direito na chave InProgress e exportar "salve no desktop".

    Apos isso apague e inicie o processo de instalação ou desinstalação.

    Essa chave sera recriada.

    Caso ajude marque como respondido
    sexta-feira, 25 de setembro de 2009 23:16
  • Daniel,

    Fiz o pocedimento conforme você indicou mais a situação persistiu. Não da para colocar imagem aqui, mas olhando o Gerenciador de Tarefas, verifiquei que existem dois processos dos Windows Installer rodando. Finalizei os dois, e tentei novamente fazer a desisntalação de um programa. Edxibiu a mesma mensagem, encerrei a instalação e verifiquei que o processo do installer continuou, outra observação é que o Usuario do processo é o "SISTEMA", que só apareceu depois que marquei a opção "Mostrar processos de todos os usuarios".

    Felipe,

    Esse procedimento eu ja havia feito e tambem não deu certo.

    Mais alguma sugestão?
    segunda-feira, 28 de setembro de 2009 13:01
  • Acesse iniciar > programas . acessórios 
    Clique em  prompt de comando com botão direito
    Selecione executar como administrador
    Digite os comandos abaixo

    - msiexec /unregister 
    - msiexec /regserver 

    Efetue novo teste após isso

    Caso persista utilize o utilitário de limpeza do Windows Installer para efetuar a limpeza de instalações incompletas
    http://support.microsoft.com/kb/290301

    Caso ainda persista após isto efetuar a documentação abaixo apartir do método 4
    http://support.microsoft.com/kb/555175

    Aguardo a resposta

    Att, Daniel U. Silva - Analista de suporte MCTS Windows Vista / Windows 7 / Windows Server 2008 / Sharepoint Server
    • Marcado como Resposta Karlos Morais segunda-feira, 28 de setembro de 2009 18:32
    segunda-feira, 28 de setembro de 2009 17:49
  • Daniel,

    Agora deu certo utilizei a limpeza do Windows Installer conforme você indicou.

    Obrigado pela colaboração.
    segunda-feira, 28 de setembro de 2009 18:33