none
VPN X DNS RRS feed

  • Pergunta

  • Boa tarde a todos,

     

    Estou com um problema com os meus Clientes de VPN junto ao meu ISA 2006, configurei o VPN Client Acess para aceitar solicitações dos clientes VPN na minha rede e os clientes conseguem autenticar na VPN sem mais problemas, porém após autenticar na VPN aconteçe alguns problemas estranhos.

     

    Primeiro, o cliente VPN mesmo estando configurado para pegar o IP via DHCP ele é configurado com um IP da minha rede porém com uma máscara estranha, 255.255.255.255!.

     

    Segundo, mesmo o grupo VPN Client estando configurado para ter acesso a todos os serviços da minha rede inclusive DNS eu não consigo fazer consultas DNS na minha rede interna. Um simples ping para o nome de um de meus servidores não é executado com sucesso, porém se eu executar este ping para o IP do servidor o mesmo é executado com sucesso.

     

    Bom, com esses problemas meus usuários não conseguem fazer quase nada quando conectados pela VPN. Alguém já teve algum problema parecido com esse ou tem alguma idéia do que está acontecendo no meu ISA?.

     

    Atenciosamente,

     

    Robson Matos

     

    quarta-feira, 26 de dezembro de 2007 20:09

Todas as Respostas

  • Olá Robson,

     

    Só para nos situarmos, a tua configuração de VPN Server, está próximo do que fala este tutorial?

    http://www.andersonpatricio.org/Tutoriais/Tutoriais.asp?Tut=070

     

    Além dessa mascara, ele não deve aparecer default gateway correto? Ou o gateway é o mesmo IP que tu pegou ao conectar-se a VPN? Seu ISA 2006 tem SP2?

     

    Como no teu caso a VPN está autenticada, devemos verificar os seguintes pontos:

    - Criar uma regra no ISA permitindo o acesso de clientes VPN para a rede interna (com os protocolos necessários);

    - Verifique se o cliente remoto não está utilizando nenhum tipo de firewall;

     

    No mais, este assunto já foi tratado aqui no Fórum, no link abaixo tem um post bem completo sobre isto:

    http://forums.microsoft.com/technet-br/ShowPost.aspx?PostID=1386841&SiteID=29

     

    Dá uma olhada nessas informações e posta aqui para te ajudarmos.

     

     

    quarta-feira, 26 de dezembro de 2007 20:25
  •  

    Fala André blz?,

     

    Cara está exatamente como no tópico que você me enviou, inclusive o firewall aqui da empresa, também ISA 2006 está configurado da mesma forma e funcionando normalmente. Com relação a atualização, o SP2 do ISA 2006 vc não quis dizer o "ISA Server 2006 Supportability Update" ?, pois está atualização está aplicada sim!.

     

    Bom cara, aconteçe justamente o que você colocou no seu último post o gateway que os clientes VPN pegam é o seu próprio IP. Bom, essa situação é estranhissima pois como coloquei mais a cima tenho um ISA 2006 configurado da mesma forma e funcionando, olhei lá o link que vc me enivou com outro post aqui do forúm e refiz todas as configurações exatamente como estão lá e nada de funcionar!, e ai alguém tem uma sugestão?.

     

    Atenciosamente,

     

     

    quarta-feira, 26 de dezembro de 2007 21:16
  • Tudo na Buena Robson,

     

    Tchê, quando falei no SP2 eu tava pensando no ISA2004!! Desculpe

    Se teu ISA 2006 está devidamente atualizado tranqüilo.

     

    Vamos ao trobleshooting:

    Em monitoring, o que loga de tráfego VPN? Te certificou que nada está bloqueando as consultas?

     

    Podemos fazer um teste, já que os servidores respondem ao ping pelo IP, na conexão criada no cliente podemos adicionar o sufixo DNS do teu domínio manualmente lá nas propriedades da conexão VPN -> TCP/IP -> Advanced -> DNS.

     

    Para teste, adicona o sufixo DNS teudominio.com.br, e verifica se vai resolver nomes.

    Se funcionar, teremos de configurar para o teu DHCP encaminhar o sufixo DNS para os clientes VPN.

     

    Posta aqui os teus testes!

     

    quinta-feira, 27 de dezembro de 2007 01:22
  • E ae André beleza cara?!

     

    Seguinte, configurei o sufixo DNS do meu domínio manualmente lá nas propriedades da conexão VPN como você sugeriu e funcionou!, agora consigo pingar pra os nomes da minha rede interna normalmente. Agora como configuro para o meu servidor DHCP encaminhar o sufixo DNS para os clientes VPN?, seria lá no scopo do servidor DHCP adicionando a opção 015 DNS Domain Name?. Pois se for já estava configurado e ai já não entendo por quê os clientes VPN não estavam pegando o sufixo DNS, preciso fazer mais alguma configuração no ISA ou no DHCP?.

     

    Abraços!

    sexta-feira, 28 de dezembro de 2007 19:55
  • Fala Robson, blz?

    Um excelente 2008 pra ti!

     

    Seguinte, cara tenho um tutorial que tá quentinho pra ser publicado que fala sobre essa configuração. Enquanto não tá publicado no site do anderson, vou te passar as dicas aqui para tu fazer:

     

    Primeiro faz esta verificação:

    1. Abra a console do Routing and Remote Access, em start >> Administrative Tools
    2. Clique com o botão direito no servidor e selecione Properties: 
    3. Nas propriedades do servidor clique na tab IP, nesta tab é que deve ser configurado o pool de endereços estáticos ou a utilização de endereços do DHCP (no exemplo, será utilizado a configuração do DHCP). Não esqueça de marcar as checkbox, enable broadcast name resolutio

    Segunda verificação:

    1. Na console do RRAS expanda a opção IP Routing, clique com o botão direito em General e selecione New Routing Protocol
    2. Após selecionar New Routing Protocol, clique na opção DHCP Relay Agent e clique em ok
    3. Aparecerá a nova opção, DHCP Relay Agent, clique com o botão direito e selecione Properties
    4. Em DHCP Relay Agent Properties, digite o endereço IP do servidor DHCP e clique em Add. Clique em Apply e após ok
    5. Clique novamente com o botão direito em DHCP Relay Agent e selecione New Interface
    6. Selecione a interface Internal (utilizada pelo RRAS), Clique Ok
    7. Após clicar em Ok, revise as configurações do DHCP Relay Properties – Internal Properties e clique em Ok

    Vê isto e depois posta aqui!!

    quarta-feira, 2 de janeiro de 2008 13:14
  • Fala André tudo blz velho?, um excelente 2008 para você também cara, saúde, paz e sucesso para todos nós nesse ano de 2008!.

     

    Cara resolvido o problema!, com esse último tópico que você colocou matamos a questão, a configuração do meu firewall como DHCP Realy Agent resolveu o problema e agora os clientes VPN pegam o sufixo DNS normalmente sem precisar configura-lo manualmente.

    Lembro-me de ter lido alguma coisa sobre DHCP Realy Agent quando estudei pra a 70-350 mais não me atentei pra isso quando tive esse problema aqui, minha cabeça já estava em 2008!."risos" De qualquer maneira valeu mesmo pela força cara!. Abraços e qualquer coisa estamos ai!.

     

    Feliz 2008 para todos!

    quarta-feira, 2 de janeiro de 2008 13:42
  • Fala Robson!

     

    Feito então!

    Este procedimento vai estar em breve disponível no www.andersonpatricio.org.

    E que 2008 seja um ano de muita paz, saúde e sucesso para todos nós!

    Ah! Não esqueça de classificar quando útil!

    quarta-feira, 2 de janeiro de 2008 13:47