none
Web Listener VPN RRS feed

  • Pergunta

  • Boa tarde.

     

    No meu ISA Server tem uma publicação do site.com.br apontado para o IIS de outra maquina que está o DC (servidor)

    No dns do DC apontei o www da zona site.com.br para o ip do ISA (10.1.1.10).

     

    Tudo funcionando perfeitamente.

    Só que quando alguem da VPN acesso e tenta acessar o site da erro.

    Ai eu dei um ping e retornou o IP 10.1.1.10

    Só que ai verifiquei e estava liberado o acesso da VPN para o rules.

    Ai fui n dns alterei o ip do www para o ip da vpn 10.1.1.150

     

    Quando eu fiz isso o pessoal da VPN conseguio acessar e o pessoal da rede interna não conseguio.

     

    Como faço para quando acessar via VPN o ip ser 10.1.1.150 e quando for interno o ip for 10.1.1.10

     

    Não sei se o problema é de alguma configuração do isa para liberar o site ou do dns.

     

    Alguem pode me ajudar?

    quarta-feira, 13 de agosto de 2008 16:16

Todas as Respostas

  • Alguem pode me ajudar?

    quinta-feira, 21 de agosto de 2008 16:06
  • Rudá,

     

    Cara eu nao sei se é pq ja sao 00:10 eu to lerdo pacas, mas nao entendi nada.

    Você poderia explicar melhorapara eu ver se posso te ajudar?

     

    abraços

    sexta-feira, 22 de agosto de 2008 03:07
    Moderador
  • Luiz,

     

    Rss.

     

    Vou explicar melhor.

     

    Tenho minha rede com essa faixa: 10.1.1.1 até 10.1.1.149

    Minha VPN está nessa faixa 10.1.1.150 até 10.1.1.169

    O IP do ISA Server é 10.0.1.10 (Externo) 10.1.1.10 (Interno) 10.1.1.150 (VPN)

    E tinho o servidor de domínio 10.1.1.1

    Nesse servidor tem o dns com a zona site.com.br

    Nessa zona criei site.com.br e www.site.com.br e apontei para o ip 10.1.1.10 para abrir o site.

    Criei no ISA o Site apontando para o IIS permitindo vir da rede interna externa e da vpn.

    Quem ta na rede interna 10.1.1.1 até 10.1.1.149 consegui acessar.

    Quem ta de fora da rede (externo) consegue acessar.

    Quem ta na VPN não consegue acessar.

    Ai cheguei e mudei o ip no dns do site.com.br e do www.site.com.br para 10.1.1.150

    Quem ta na rede interna 10.1.1.1 até 10.1.1.149 não consegui acessar.

    Quem ta de fora da rede (externo) consegue acessar.

    Quem quem ta na VPN consegue acessar.

    sexta-feira, 22 de agosto de 2008 10:59
  • Agora eu entendi...

    Dentro da sua zona DNS...

    crie apenas um registro www apontando para o server onde esta o site... nao precisa do caminio completo...

    Faz o teste e me avisa.

    Isso esta acontecendo pq na realidade o IP do seu servidor não é o 150, nesse caso ele é apenas um IP "ficticio" para usuarios VPN.

    abraços
    sexta-feira, 22 de agosto de 2008 13:03
    Moderador
  • O problema é que eu tenho que passar pelo ISA Server.

    Por isso apontei o www para o ip 10.1.1.10, mas o pessoal da VPN não consegui abrir, só consegui se eu colocar 10.1.1.150, só que ai o pessoal da rede interna não acessa.

    O que ta acontecendo que é ou um ou outro acessa.

    sexta-feira, 22 de agosto de 2008 14:06
  • Faz um teste coloca na placa de rede do seu servidor o IP 150...deixe ele com dois IPS e veja se funciona.

    isso esta sendo erro de apontamento....

    No aguardo

    abraços
    sexta-feira, 22 de agosto de 2008 14:15
    Moderador
  • Quando fiz isso o ip do servidor da vpn mudou para 151 ai tive que mudar o dns par a151 para funcionar.

    sexta-feira, 22 de agosto de 2008 14:36
  • na realidade a VPN gerencia isso sozinho...

    Cara como estao seus registros DNS?

    www
    site

    ?
    sexta-feira, 22 de agosto de 2008 14:51
    Moderador
  • Como assim?

     

    Seria se está tudo funcionando sem erros?

    Aqui no log não aparece nenhum erro.

    Todos da rede interna estão funcionando.

    O problema é de quem acessa via VPN.

    domingo, 24 de agosto de 2008 16:54
  • Sim teria q estar funcionando...

     

    Vc criou apenas o registro "www" dentro da zona site.com.br.?

     

    Pois a VPN ele cria um IP para o servidor diferente doque é da placa de rede entende? tanto que ai vc pode ver que é 150...

     

    Isso esta sendo apenas um erro de apontamento DNS....

     

    No aguardo

     

    Abraços

    domingo, 24 de agosto de 2008 18:13
    Moderador
  • É eu tenho site.local que é o domínio. ai criei outra zona (site.com.br) dentro do dns do servidor DC (10.1.1.1) e criei dentro dessa zona o www apontando para o ip 10.1.1.10 que é o ip do servidor ISA que está na placa.

     

    segunda-feira, 25 de agosto de 2008 02:22
  • Ao invés de apontar para o seu servidor ISA aponta ele para o servidor onde esta o site mesmo....
    segunda-feira, 25 de agosto de 2008 12:20
    Moderador
  •  

    Como falei não posso apontar para o IIS direto pq eu preciso que passe pelo IIS.

    Pq quando acessa http://www.site.com.br/algo ou http://algo.site.com.br ele vai abrir outra pagina de um servidor de pabx.

     

    Por isso preciso que seja apontado para o IIS.

    segunda-feira, 25 de agosto de 2008 14:03
  • IIS ou ISA?
    segunda-feira, 25 de agosto de 2008 14:07
    Moderador
  •  

    Ops errei rss.

     

     

    "Como falei não posso apontar para o IIS direto pq eu preciso que passe pelo ISA.

    Pq quando acessa http://www.site.com.br/algo ou http://algo.site.com.br ele vai abrir outra pagina de um servidor de pabx.

     

    Por isso preciso que seja apontado para o ISA.

    "

    segunda-feira, 25 de agosto de 2008 14:11
  • Entendi.

     apublicação do seu isa server esta correta?
    segunda-feira, 25 de agosto de 2008 14:36
    Moderador
  • Eu acho que ta. Já que o pessoal da rede interna e da externa acessa.

    Criei o Web Listener dando permissão de todas as redes (Externo, Interno, VPN, VPN Quarentena, LocalHost)

    segunda-feira, 25 de agosto de 2008 14:43
  • Estranho...

    era esse o passo q eu ia falar, pra vc colocar eles no listener e testar...

    veja se agora vai..
    segunda-feira, 25 de agosto de 2008 15:35
    Moderador
  • Mesmo abilitando todos os acessos ele da erro.

    segunda-feira, 25 de agosto de 2008 18:57
  • Qual erro ele esta dando?

    segunda-feira, 25 de agosto de 2008 19:09
    Moderador
  • Olá Rudá,

    quando os seus clientes da VPN conectam, ele conseguem acessar a rede 10.1.1.1-150 normalmente? Digo, o roteamento está funcionando entre essas redes?

    Atenciosamente,
    Paulo Oliveira.
    terça-feira, 26 de agosto de 2008 19:47
  • Conseguimos acessar as pastas as outras maquinas pela VPN.
    terça-feira, 26 de agosto de 2008 19:52
  • Então não tem como os clientes VPN acessarem o mesmo FQDN que os clietes da rede interna, ja que você deseja que os clientes VPN acessem o ISA e os da rede interna acessem o IIS.

    Uma vez que não seria interessante ter o mesmo registro no DNS apontando para IP´s diferentes.

    Uma sugestão seria criar um registro A no DNS, por exemplo www2 ou um path diferente no IIS (talvez menos aplicável).

     

    Atenciosamente,

    Paulo Oliveira.

     

    terça-feira, 26 de agosto de 2008 20:03