none
Falha ao subir SQL Agent RRS feed

  • Pergunta

  • Bom dia. Instalei o SQL Server 2008 R2 Enterprise x64, em uma máquinas para testes com Windows 7. Ainstalação foi ok, porém ao tentar subir o serviço do SQL Agent, retorna a mensagem de que o serviço foi iniciado e finalizado. tentei subir pelo Config. Manager, SSMS e services.msc.

    Realizei as seguintes configurações com sucesso:

    sp_configure 'show advanced options', 1; GO RECONFIGURE; GO sp_configure 'Agent XPs', 1; GO RECONFIGURE GO

    OBSERVAÇÃO: Ao tentar rodar a sp_readerrorlog, obtive o seguinte erro:

    Msg 22004, Level 16, State 1, Line 0 Failed to open loopback connection. Please see event log for more information. Msg 22004, Level 16, State 1, Line 0 error log location not found

    Tem alguma coisa a ver? Alguém saberia me ajudar como habilitar o Agent?

    Obrigado!

    Luiz Fernando

    quarta-feira, 12 de dezembro de 2012 14:07

Respostas

  • Marcus, não adiantou instalar outra instância. Formatei minha máquina e, antes de colocá-la no domínio, realizei as devidas atualizações e instalei o sql server. Resolvido!

    Obrigado a todos pela ajuda.

    Luiz Fernando

    • Marcado como Resposta Luiz Fernando BR quinta-feira, 31 de janeiro de 2013 10:41
    quinta-feira, 31 de janeiro de 2013 10:41

Todas as Respostas

  • Luiz, veja se pode ser o usuário que esta configurado para subir este serviço do SQL Server.

    Se possível altere o usuário e mande retorno.

    Espero que ajude, vlew.


    --
    Marcus Vinícius Bittencourt
    blog: isqlserver.wordpress.com
    www.sqlserverRS.com.br

    quarta-feira, 12 de dezembro de 2012 15:21
  • Olá Marcus. Utilizei um usuário local com critérios de administrador, conta do sistema, local, até criei um em nosso ad, porém sem sucesso. Ocorre a mesma mensagem: - no Configuration Manager "The request failed or the service did not respond in a timely fashion.", no Services.msc "O serviço SQL Agent em computador local foi iniciado e interrompido....."

    quarta-feira, 12 de dezembro de 2012 16:50
  • Luiz, veja se no event viewer tem alguma mensagem mais sugestiva e nos mande por favor.


    --
    Marcus Vinícius Bittencourt
    blog: isqlserver.wordpress.com
    www.sqlserverRS.com.br

    quarta-feira, 12 de dezembro de 2012 17:32
  • Marcus, no visualizador de eventos do Windows consta a seguinte mensagem de erro:

    SQLServerAgent could not be started (reason: Unable to connect to server '(local)'; SQLServerAgent cannot start).

    Detalhe: Também não consigo acesso via sqlcmd. Segue mensagem do cmd:

    HResult 0x1B, Level 16, State 1
    Registry information is corrupt or missing. Make sure the provider installed and registered correctly.
    Sqlcmd: Error: Microsoft SQL Server Native Client 10.0 : Client unable to establish connection.
    Sqlcmd: Error: Microsoft SQL Server Native Client 10.0 : A network-related or instance-specific error has occurred while establishing a connection to SQL Server. Server is not found or not accessible. Check if instance name is correct and if SQL Server is configured to allow remote connections. For more information see  SQL Server Books Online..


    quarta-feira, 12 de dezembro de 2012 17:51
  • Tu ta conectando normalmente no teu SQL Server?

    Veja no configuration manager quais os protocolos que estão habilitados para conexão.

    Tenta conectar no próprio servidor usando (local) no nome do servidor.

    O problema pode estar sendo na conexão e não específicamente no start do serviço.

    mande o retorno.


    --
    Marcus Vinícius Bittencourt
    blog: isqlserver.wordpress.com
    www.sqlserverRS.com.br

    quarta-feira, 12 de dezembro de 2012 17:58
  • Conecto normalmente de forma mista. Alterei o nome do server na conexão para (local) e conectou normalmente, porém ao tentar dar start no Agent, deu a mensagem:

    No SSCM estão habilitados o Shared Memory e o TCP/IP

    Porém, no SQL Native Client 10.0 Configuration, não tenho nada no Client Protocols.

    quarta-feira, 12 de dezembro de 2012 18:06
  • Não tem nada habilitado ou simplesmente não tem nada nesta opção?

    Se for possível habilita o TCP/IP pra fazer um teste.


    --
    Marcus Vinícius Bittencourt
    blog: isqlserver.wordpress.com
    www.sqlserverRS.com.br

    quarta-feira, 12 de dezembro de 2012 18:09
  • Não.... os protocolos Shared Memory e o TCP/IP estão habilitados corretamente:

    O que não tem nada, é o Cliente protocols do Native Client.

    quarta-feira, 12 de dezembro de 2012 18:23
  • Luiz, nunca enfrentei um caso como este, mas em Native Client tem que aparecer os protocolos também, e segundo o erro do sqlcmd é exatamente este o método de conexão utilizado.

    Infelizmente parece que algum problema na instalação pode ter deixado isso incompleto.

    Como teu ambiente é de testes, tu não quer de repente reinstalar o SQL Server?

    Espero que ajude, vlew.


    --
    Marcus Vinícius Bittencourt
    blog: isqlserver.wordpress.com
    www.sqlserverRS.com.br

    quinta-feira, 13 de dezembro de 2012 16:26
  • Obrigado pela ajuda Marcus, porém já fiz isto inúmeras vezes (reinstalar o produto).

    Vou tentar formatar esta máquina, talvez seja algo relacionado ao sistema operacional.

    Mais uma vez, obrigado.

    Luiz Fernando

    sexta-feira, 14 de dezembro de 2012 16:50
  • Luiz, de repente tente antes de formatar, instalar uma nova instancia para ver se de repente não é alguma sujeira de registro.

    Espero que ajude.


    --
    Marcus Vinícius Bittencourt
    blog: isqlserver.wordpress.com
    www.sqlserverRS.com.br

    sexta-feira, 14 de dezembro de 2012 17:28
  • Luiz,

    Talvez ajude -> http://www.pythian.com/news/27905/sql-serveropening-errorlogfailed-to-retrieve-data-for-this-request-microsoft-sqlserver-management-sdk-sfc/

    sexta-feira, 14 de dezembro de 2012 19:35
  • Marcus, não adiantou instalar outra instância. Formatei minha máquina e, antes de colocá-la no domínio, realizei as devidas atualizações e instalei o sql server. Resolvido!

    Obrigado a todos pela ajuda.

    Luiz Fernando

    • Marcado como Resposta Luiz Fernando BR quinta-feira, 31 de janeiro de 2013 10:41
    quinta-feira, 31 de janeiro de 2013 10:41