none
FTP IIS 7.5 RRS feed

  • Pergunta

  • Senhores,

    Configurei um site FTP no IIS 7.5. Levei um bom tempo para conseguir descobrir que é necessario um usuário de dominio válido se quiser publicar uma pasta de rede.

    Criei uma pasta dentro de Inetpub-Ftproot-LocaUser-NomeDoUsuario

    O usuário que utilizo é do IIS e não do AD, consigo conectar na pasta acima sem problemas.

    Dentro desta pasta quero colocar 2 pastas virtuais apontando para pastas compartilhadas da rede.

    Ao adicionar uma pasta virtual conectando com usuário válido do AD funciona, no momento que adiciono a segunda pasta virtual e configuro o usuário recebe o erro abaixo ao tentar conectar no FTP.

    Alguém consegue ajudar?

    Obrigado.


    Leônidas - Analista de Suporte - MCP

    quinta-feira, 15 de maio de 2014 16:34

Respostas

  • Senhores!

    A Dias procurando o problema no lado errado...

    Hoje estava com mais tempo aqui, parei, pensei... procurei até que encontrei o problema. Era permissão do compartilhamento, o SERVIDORFTP$ tinha permissão na pasta mas não no compartilhamento!

    Na verade não achei a solução para o problema usando o connect as, mas consegui utilizar agora com o Pass-through authentication.

    Muito Grato a todos!


    Leônidas - Analista de Suporte - MCP

    • Marcado como Resposta Leônidas segunda-feira, 23 de junho de 2014 16:38
    segunda-feira, 23 de junho de 2014 16:38

Todas as Respostas

  • Ainda não encontrei solução para esta questão.

    Sugestões?

    Grato.


    Leônidas - Analista de Suporte - MCP

    segunda-feira, 26 de maio de 2014 19:16
  • Leônidas, desculpe a demora na resposta. 

    Caso não tenha conseguido resolver esse problema, você pode seguir este artigo: http://support.microsoft.com/kb/977754/pt-br

    Abraços,


    Erick Albuquerque | Microsoft MVP
    MVP Profile | Twitter | Linkedin | http://iisbrasil.wordpress.com
    Windows 8 / 2012: http://windows8dicas.com.br

    terça-feira, 3 de junho de 2014 17:26
    Moderador
  • Olá Erick,

    Na verdade creio que não seria bem isso.

    O FTP funciona com uma pasta, no momento que adiciono a segunda pasta e no basic settings configuro o Connect as.  aparece o erro acima. Se tiver somente uma pasta fica OK.


    Leônidas - Analista de Suporte - MCP

    terça-feira, 10 de junho de 2014 20:00
  • Leônidas,

    Primeiro precisamos ter em mente que o erro 550 é acesso negado;

    Você não repassou os detalhes de como o IIS(FTP) esta configurado, então segue um link que possa ajudá-lo em algum detalhe que possa ter passado desapercebido.

    http://www.iis.net/learn/publish/using-the-ftp-service/configure-ftp-with-iis-manager-authentication-in-iis-7#01

    Realizei um LAB basedado nas suas informações e obtive sucesso e pude simular o erro , mais ou menos, pois não cheguei a receber um erro "Keyset does not exist" por isso acredito que o link possa ajudar, enfim, no meu caso percebi que a conta IIS Manager User só é capaz de acessar e gravar dados no diretório virtual que aponta para um caminho de rede se a conta de computador SERVIDORFTP$ ou o grupo DOMAIN\Users ou Authenticated Users possuir acesso para representar esse usuário, pois o proprietário do diretório que eu criei acessando o ftp://servidorftp/diretóriovirtual >> new >> folder foi a conta do de computador do servidor ftp.

    Não vejo funcionalidade na configuração do Connect as que você tentou realizar.

    Espero ter ajudado.

    abs,


    Não se pode ensinar alguma coisa a um homem; apenas ajudá-lo a encontrá-lo dentro de si mesmo.



    • Editado Felipe Feydit quarta-feira, 11 de junho de 2014 01:29
    • Sugerido como Resposta Felipe Feydit segunda-feira, 23 de junho de 2014 18:21
    quarta-feira, 11 de junho de 2014 01:25
  • Novidades Leônidas ?

    Se quiser derrubar uma árvore na metade do tempo, passe o dobro do tempo amolando o machado.

    sábado, 14 de junho de 2014 21:01
  • Olá Felipe, desculpe a demora na resposta mas tive outros problemas por aqui.

    utilizando o método Application User (Pass-thtough authentication) e utilizando a conta SERVIDORFTP$ na pasta não consigo acessá-la permissão negada Erro 550

    Também executei o comando abaixo mas não adiantou.

    ICACLS "%\\servidor\pasta" /Grant "Network Service":M /T

    Com o Connect as e utilizando uma conta do AD com permissão na pasta virtual  remota (está em outro servidor) consigo acessá-la sem problemas. Mas ao adicionar mais uma pasta virtual com as mesmas características recebo o erro do primeiro post.

    Lembrando que os erros aparecem diferentes. Utilizando Application User aparece erro 550 Permission Denied. Utilizando connect as ao adicionar a segunda pasta aparece o erro do primeiro post.

    Algo a mais que notei. Adiciono a primeira pasta (usando connect as) e conecto no FTP, funciona. Adiciono a segunda pasta e conecto no FTP consigo conectar mas só aparece a primeira pasta. Aperto F5 e então o erro do primeiro post aparece!, depois disso sempre aparece ao conectar.


    Leônidas - Analista de Suporte - MCP

    quarta-feira, 18 de junho de 2014 14:16
  • Quais o métodos de autenticação configurados/habilitados ?

    Como esta configurado o isolamento ?


    Se quiser derrubar uma árvore na metade do tempo, passe o dobro do tempo amolando o machado.

    quarta-feira, 18 de junho de 2014 14:31
  • Autenticação está habilitada somente IisManagerAuth, pois os usuários que se conectam no FTP não são usuários do Dominio, só existem no IIS.

    Isolamento: User Name Directory (Disable Global Virtual Directories)

    O usuário que coloco no Connect as é um usuário de dominio que criei para utilizar neste caso, pois não conseguia acessar as pastas remotas sem ele.


    Leônidas - Analista de Suporte - MCP

    quarta-feira, 18 de junho de 2014 16:10
  • O método que você criou com a estrutura LocalUser já isola os usuários.

    Altera o isolamento do IIS para "Do not isolate users" e marca a opção "Start Users in" User name Directory.

    Com relação ao Connect as, não configuro usuário especifico e funciona, pois como falei neste caso irá utilizar a conta do servidor IIS para autenticar e as permissões de Share e NTFS estando corretamente configuradas o acesso é realizado.

    No seu caso, você esta especificando uma conta, verifique se a mesma esta ativa, se não esta com a senha errada ou expirada, ao lado do botão Connect as há um botão de teste que te indica algum problema de conexão.

    Reveja também as permissões efetivas dessa conta no caminho de rede que você configurou, analisando o padrão das permissões mais restritivas sobrepõem as demais.


    Se quiser derrubar uma árvore na metade do tempo, passe o dobro do tempo amolando o machado.

    quarta-feira, 18 de junho de 2014 17:33
  • Alterando o isolamento o FTP não conectou mais diretamente na pasta do usuário.

    Dentro do Site FTP Criei uma pasta chamada LocalUser e dentro dela uma com o nome do usuário. Se utilizar o isolamento que me propos a sessão FTP inicia na raiz, se utiliza como estava antes inicia na pasta do usuário.

    Sobre o Connect as, no site que temos no mesmo IIS também utilizo a conta do servidor e funciona perfeitamente. Meu problema está no FTP que não consegui fazer funcionar da mesma forma, por isso utilizei o conect as.

    Sobre a conta que uso nele, ela funciona. Consigo acessar o FTP sem problemas quando ele tem somente 1 pasta virtual, se adicionar a segunda que acontece o problema e tanto faz qual eu adiocionar primeiro. Se utilzar somente a Inbound funciona, somente a Outbound funciona. Quando a segunda entra na jogada estraga tudo.


    Leônidas - Analista de Suporte - MCP

    quarta-feira, 18 de junho de 2014 18:08
  • Também li em algum lugar (nao lembro qual) que o FTP no iis não usa o Application Pools, assim não consegue usar a conta do servidor para autenticar em caminho UNC.

    Encontrei este artigo http://support.microsoft.com/kb/247970/pt-br mas ele se refere ao iss 5.0 no IIS 7.5 é possível definir essas informações na interface.


    Leônidas - Analista de Suporte - MCP

    quarta-feira, 18 de junho de 2014 18:40
  • Olá Felipe, desculpe a demora na resposta mas tive outros problemas por aqui.

    utilizando o método Application User (Pass-thtough authentication) e utilizando a conta SERVIDORFTP$ na pasta não consigo acessá-la permissão negada Erro 550

    Também executei o comando abaixo mas não adiantou.

    ICACLS "%\\servidor\pasta" /Grant "Network Service":M /T

    Com o Connect as e utilizando uma conta do AD com permissão na pasta virtual  remota (está em outro servidor) consigo acessá-la sem problemas. Mas ao adicionar mais uma pasta virtual com as mesmas características recebo o erro do primeiro post.

    Lembrando que os erros aparecem diferentes. Utilizando Application User aparece erro 550 Permission Denied. Utilizando connect as ao adicionar a segunda pasta aparece o erro do primeiro post.

    Algo a mais que notei. Adiciono a primeira pasta (usando connect as) e conecto no FTP, funciona. Adiciono a segunda pasta e conecto no FTP consigo conectar mas só aparece a primeira pasta. Aperto F5 e então o erro do primeiro post aparece!, depois disso sempre aparece ao conectar.


    Leônidas - Analista de Suporte - MCP

    Você utiliza configuração de portas passivas ?

    Os diretórios virtuais apontam para o mesmo servidor na rede ? este servidor esta atras de algum firewall ?

    Você consegue criar um video para apresentar o problema e indicar as permissões de acesso nos diretórios envolvidos.?

    Fiz vários testes aqui e não percebo a causa.

    Chegou a seguir o KB citado pelo Erick ?


    Se quiser derrubar uma árvore na metade do tempo, passe o dobro do tempo amolando o machado.




    sábado, 21 de junho de 2014 17:23
  • Felipe,

    Não uso modo passivo

    Os diretórios estão em outro servidor da rede, as duas pastas estão no mesmo servidor. O unico firewall é o do windows, não deve ser isso, pois com uma pasta funciona.

    Sobre o vídeo acho que não consigo, mas vou fazer alguns prints a anexar.

    Li o Kb do Erick, mas este erro eu não aparece pra mim.

    Grato.


    Leônidas - Analista de Suporte - MCP

    segunda-feira, 23 de junho de 2014 14:18
  • Ok, aguardamos mais informações para decifrar esse enigma.


    Se quiser derrubar uma árvore na metade do tempo, passe o dobro do tempo amolando o machado.

    segunda-feira, 23 de junho de 2014 15:35
  • Senhores!

    A Dias procurando o problema no lado errado...

    Hoje estava com mais tempo aqui, parei, pensei... procurei até que encontrei o problema. Era permissão do compartilhamento, o SERVIDORFTP$ tinha permissão na pasta mas não no compartilhamento!

    Na verade não achei a solução para o problema usando o connect as, mas consegui utilizar agora com o Pass-through authentication.

    Muito Grato a todos!


    Leônidas - Analista de Suporte - MCP

    • Marcado como Resposta Leônidas segunda-feira, 23 de junho de 2014 16:38
    segunda-feira, 23 de junho de 2014 16:38
  • Como havia dito , problemas de permissão.

    Para usar o Connect as, o usuário ou grupo que o mesmo faz parte, deve ter acesso ao recurso de rede, mesma situação.

    abs,


    Se quiser derrubar uma árvore na metade do tempo, passe o dobro do tempo amolando o machado.



    segunda-feira, 23 de junho de 2014 18:21