none
Configurar Conta de serviço SQL Server Standard 2008 RRS feed

  • Pergunta


  • Olá,

    Antes de mais nada, desculpe se estou postando no fórun errada é que não sei mais se meu problema é de windows Server ou Sql Server.

    Primeiro vou explicar o cenário que tenho na empresa.
    O servidor controlador de domínio fica em 1 máquina com windows server standard 2003.
    O servidor que estou tentando instalar o SQL server 2008,  é em um novo servidor que está instalado o Windows Server Enterprise 2008, porém quando vou configurar as contas de serviço, o assistente só permite continuar se coloco a conta: AUTORIDADE NT\SERVIÇO DE REDE, qualquer outro usuário do domínio ele não permitir continuar, se  coloco o administrador da máquina também não é possível continuar a instalação. Mensagen retornada "As credenciais fornecidas para o serviço Analysis Services são inválidas. Para continuar, forneça informações válidas de conta e senha para o serviço Analysis Services"

    Você tem alguma dica, se é algo no firewall do windows server enterprise 2008 que tenho que liberar?

    Já liberei todas as portas que o Sql server utiliza com o Script:

    @echo =========  SQL Server Ports  ===================
    @echo Enabling SQLServer default instance port 1433
    netsh firewall set portopening TCP 1433 "SQLServer"
    @echo Enabling Dedicated Admin Connection port 1434
    netsh firewall set portopening TCP 1434 "SQL Admin Connection"
    @echo Enabling conventional SQL Server Service Broker port 4022
    netsh firewall set portopening TCP 4022 "SQL Service Broker"
    @echo Enabling Transact-SQL Debugger/RPC port 135
    netsh firewall set portopening TCP 135 "SQL Debugger/RPC"
    @echo =========  Analysis Services Ports  ==============
    @echo Enabling SSAS Default Instance port 2383
    netsh firewall set portopening TCP 2383 "Analysis Services"
    @echo Enabling SQL Server Browser Service port 2382
    netsh firewall set portopening TCP 2382 "SQL Browser"
    @echo =========  Misc Applications  ==============
    @echo Enabling HTTP port 80
    netsh firewall set portopening TCP 80 "HTTP"
    @echo Enabling SSL port 443
    netsh firewall set portopening TCP 443 "SSL"
    @echo Enabling port for SQL Server Browser Service's 'Browse' Button
    netsh firewall set portopening UDP 1434 "SQL Browser"
    @echo Allowing multicast broadcast response on UDP (Browser Service Enumerations OK)
    netsh firewall set multicastbroadcastresponse ENABLE

    DESDE JÁ MUITO OBRIGADA PELA AJUDA.
    sábado, 13 de fevereiro de 2010 13:29

Respostas

  • Bom dia,

    Eu tive uma situação parecida. Para resolver o problema, efetuei o seguinte procedimento:

    Na instalação, deixei como localsystem as contas para execução dos serviços.

    Após conclusão da instalação, acessei o SQL server configuration manager e alterei a contato do serviço para uma conta do AD.

    Att,

    Léo
    • Marcado como Resposta Neia_S quarta-feira, 17 de fevereiro de 2010 13:35
    segunda-feira, 15 de fevereiro de 2010 14:00

Todas as Respostas

  • Boa Tarde,

    Me parece ser um problema relacionado ao Windows e não ao SQL Server.
    Essa máquina Windows 2008 Enterprise está no domínio ?

    [ ]s,

    Gustavo Maia Aguiar
    http://gustavomaiaaguiar.spaces.live.com/blog

    Encontrando índices não utilizados
    http://gustavomaiaaguiar.spaces.live.com/blog/cns!F4F5C630410B9865!945.entry


    Classifique as respostas. O seu feedback é imprescindível
    sábado, 13 de fevereiro de 2010 17:29
  • Não conheço quase nada de administraçao windows server, principalmente de 2008, é completamente diferente do 2003. Mas olhando no AD o servidor em questão consta no grupo de computadores, assim, como os demais servidores.

    Consigo acessar pastas de outros servidores, se vou acessar um determinado diretório da rede que ainda não acessei é solicitado usuário e senha, coloco o usuario e senha que criei no AD e ele permite o acesso.

    Algo que acho estranho é que, quando vou acessar o servidor ele não acessa como os demais, onde solicitam:
    usuário
    senha
    dominio

    Por default, vem nomeServidor\usuario e solicita a senha ou icone ao lado para trocar de usuário. Mas mesmo alterando o usário não consigo cetar o dominio.

    E como ccitei no tópico, o assistente de instalação do SQL não válida nem o administrador local do servidor, somente AUTORIDADE NT\SERVIÇO DE REDE ou as outras Autoridades que vem cetadas.

    O que você me aconselha a fazer?

    Obrigada.
    sábado, 13 de fevereiro de 2010 21:12
  • Bom dia,

    Eu tive uma situação parecida. Para resolver o problema, efetuei o seguinte procedimento:

    Na instalação, deixei como localsystem as contas para execução dos serviços.

    Após conclusão da instalação, acessei o SQL server configuration manager e alterei a contato do serviço para uma conta do AD.

    Att,

    Léo
    • Marcado como Resposta Neia_S quarta-feira, 17 de fevereiro de 2010 13:35
    segunda-feira, 15 de fevereiro de 2010 14:00
  • Neia_S;

    Acho importante identificar algumas coisas:
    1-Realmente é necessário a utilização de um usuário do AD como serviço do SQL? Pq? Usa SSIS, RS, AS ?
    -Caso não seja necessário uma conta do AD, crie no servidor com Win2008 um usuário, não adicione nada de direitos para ele, apenas crie o usuário com uma senha. No momento da instalação do SQL Server configure este usuário que vc criou como conta de serviço do SQL Server. Isto será o suficiente para que os serviços subam corretamente.
    -Caso seja realmente necessário uma conta de usuário do AD, não posso afirmar com certeza se este é o procedimento recomendado, sugiro antes de fazer isto uma consulta à documentação do SQL Server, mas por sua conta e risco você pode colocar este usuário do AD como administrador local do servidor com Windows 2008 e então efetuar a instalação do SQL 2008 colocando este usuário do AD como conta de serviço.

    Att,
    Ricardo Muramatsu


    http://ricardomura.spaces.live.com
    terça-feira, 16 de fevereiro de 2010 19:26