none
Impressoras presas no Terminal Server RRS feed

  • Pergunta

  • Boa tarde,

    Tenho o seguinte problema, o cliente conecta no servidor pelo TS carrega as impressoras certinho. Quando ela se desconecta da seção as impressoras continuam lá, ai fica umas 20 impressoras sendo que só 3 pessoas estão conectadas no servidor. quando eu tento excluir a impressora manualmente da erro de impressora invalida, para resolver o problemas tenho que reiniciar o servidor isso umas 2 vezes ao dia.

    As configurações do Cliente RDP está a seguinte

    Sessões:

    Finalizar a sessão desconectada após 10 Minutos

    Limite de sessão ociosa: 15 Minutos

    Quando o Limite da sessão for atingido ou a sessão for interrompida: Finalizar Sessão

    sexta-feira, 8 de junho de 2012 16:59

Respostas

Todas as Respostas

  • Amigo,

    Segue um link sobre o assunto. Veja se o seu ambeinte se encaixa nesta situação:

    http://blogs.technet.com/b/latam/archive/2010/04/09/lidando-com-problemas-de-impress-o-em-sess-es-terminal-services.aspx

    Obrigado.


    Paul Haro - Microsoft Certified Professional

    sexta-feira, 8 de junho de 2012 17:47
    Moderador
  • Então dei uma lida rápida e o texto é para Server 2008 o meu é 2003, mas creio que a metodologia é a mesma. Vou me aprofundar mais no texto quando chegar em casa.

    Também instalei o uphclean, mas não resolveu pois o usuário demora muito para fazer o logoff. Uma dúvida é só instalar o uphclean e pronto ou tem que fazer alguma configuração?

    sexta-feira, 8 de junho de 2012 20:26
  • Olá Narrdo,

    Depois de instalado, o uphclean trabalha como serviço do Windows:

    http://support.microsoft.com/kb/837115/pt-br

    Obrigado.


    Paul Haro - Microsoft Certified Professional

    terça-feira, 12 de junho de 2012 11:31
    Moderador
  • Então está certo o UPHclean está iniciado, até o presente momento todos os usuários estão desconectando do servidor e suas impressoras estão sendo excluídas.

    Uma pergunta, é possível um computador da rede estar causando tudo isso?

    Porque percebi que tem 2 computadores do financeiro que, as vezes impressoras não são excluídas. Um deles loga na sessão 1 carrega as impressoras, quando saem do servidor as impressoras continuam na sessão 1. Quando eles voltam as vezes caem na sessão 4 e carrega novas impressoras para a sessão 4, e as impressoras da sessão 1 continuam lá até que o servidor seja reiniciado.

    Por enquanto está normal, mas também não percebi que alguém do financeiro fez o logon no servidor. Vou ficar de olho!

    terça-feira, 12 de junho de 2012 13:00
  • Verifique os drivers de impressão destes desktops.

    Obrigado.


    Paul Haro - Microsoft Certified Professional

    terça-feira, 12 de junho de 2012 13:15
    Moderador
  • Vou fazer isso depois eu volto para dar o feedback

    Conectaram 5 pessoas ao mesmo tempo no servidor, quando sairam as impressoras de financeiro-02 e recepcao-01 ficaram presas. Como disse o pc do financeiro sempre está no meio desse problema. Vou fazer uma manutenção nesses dois pc's irei desinstalar e instalar todas as impressoras.

    terça-feira, 12 de junho de 2012 14:20
  • Verifique nestes desktops, principalmente a versão do rdp e cuide para que estejam em dia com o Windows Update.

    Obrigado.


    Paul Haro - Microsoft Certified Professional

    terça-feira, 12 de junho de 2012 14:31
    Moderador
  • Ok.

    A empresa tem 2 servidores que ficam no mesmo ambiente físico, porem um atende Itaquera e o outro é para Guarulhos, ambos tem o mesmo software cada um com seus próprios banco de dados. O servidor de Itaquera é DC e Guarulhos é Membro do Domínio, as pessoas de Itaquera acessa o seu banco de dados pelo seu software cliente, para acessar o programa de  Guarulhos eles utilizam o TS que o programa é executo durante o logon, não permitindo eles utilizarem mais nada do servidor.

    O servidor de Itaquera está funcionando perfeito, poucas pessoas acessam Itaquera por TS e quase todos acessam Guarulhos por TS. 

    Olhando as propriedades do sistema dos dois Servidores percebi o seguinte:

    Itaquera

    Guarulhos

    Será que é a mídia?

    terça-feira, 12 de junho de 2012 17:19
  • Amigo,

    O que é que vc percebeu ?

    Obrigado.


    Paul Haro - Microsoft Certified Professional

    terça-feira, 12 de junho de 2012 19:04
    Moderador
  • O porque desses dois desenhos do computador do windows ser um azul e o outro não, penso ser mídias diferentes e com isso esta acontecendo os problemas.

    O desenho do computador azul é o de Guarulhos e o outro é o de Itaquera.

    sexta-feira, 15 de junho de 2012 12:07
  • Hoje eu usei o Process Expore e descobrir que o Winlogon.exe estava em 100% era por causa disso que eu tinha que reiniciar o servidor. Tirei um print de algumas informações.

    Através dessa imagem da para concluir alguma coisa?

    sexta-feira, 15 de junho de 2012 18:02
  • amigo,

    A questão das cores não tem relação com os erros de impressão.

    sobre o winlogon, sugiro que analise o log de eventos, afim de encontrar informações pertinentes.

    Obrigado.


    Paul Haro - Microsoft Certified Professional

    sexta-feira, 15 de junho de 2012 18:03
    Moderador
  • Tem alguns eventos.

    Falha ao carregar o caminho de perfil do Terminal Server. Observe que o caminho de perfil deve ter menos de 256 caracteres. Nome de usuário: XXXXXX Domínio: XXXXXX

    Os usuarios estão somente no grupo Area de trabalho remota e usuarios do dominio.

    sexta-feira, 15 de junho de 2012 19:03
  • Com esses problemas eu troquei os servidores, instalei e configurei os dois.

    Agora ficou assim.

    SRV 1 = WINS, AD, DNS, ARQUIVOS, TS, (Programa com o BD Itaquera)

    SRV 2 = TS, (Programa com o BD Guarulhos)

    Os problemas continuam, mas com menos ocorrências. O que eu acho mais estranho é que, os dois tem as mesmas configurações de TS e apenas  o SRV 2 da problemas!

    Usando um conjunto de ferramentas process explore e UPHclean descobri que o csrss.exe e o winlogon.exe são os últimos a serem fechados causando a lentidão no LOGOFF. Percebo que quando o usuário está com o logoff lento eu uso um .BAT para limpar o spooler , ai ele se desconecta de vez.

    olha uma imagem que eu tirei, e um LOG do UPHclean.

    LOG

    The following handles in user profile hive S-1-5-21-2450021506-3548129940-2071800965-500 (S-1-5-21-2450021506-3548129940-2071800965-500) have been remapped because they were preventing the profile from unloading successfully: 
     
    procexp.exe (3396)
      HKCU (0x510)

    winlogon.exe (4040)
      HKCU\Printers\DevModePerUser (0x424)

    Alguém pode me ajudar, está difícil?

    quarta-feira, 20 de junho de 2012 17:28